background image
346 Chapter 11: Scaling IP Addresses with NAT
Note that the range of available addresses does not contain the statically assigned address. The
resource has a uniquely defined address in the outside world. The 222.12.12.0 network is
legitimate in the Internet community and would be advertised there. The 222.12.12.1 inside
address is addressable and entered into the DNS tables for the Internet community. In this way,
the device that is statically (and always) translated to the 222.12.12.1 address is available to the
outside world.
NAT Overloading Configuration
To convert the configuration for simple NAT translation to overload, the administrator must use
the overload argument. Overloading an Inside Global address uses the same syntax as the
simple NAT translation, but with the extra argument, the router knows to track the port numbers
for the translation table.
The configuration in Example 11-3 extends simple NAT translation to an overload
implementation.
Example 11-2
Static NAT Configuration
access-list 1 permit 10.0.0.0 0.0.0.255
ip nat pool natpool 222.12.12.2 222.12.12.254 netmask 255.255.255.0
ip nat inside source static 10.0.0.1 222.12.12.1
ip nat inside source list 1 pool natpool
!declare inside interfaces
interface e0
ip address 10.0.0.1 255.255.255.0
ip nat inside
!declare outside interface
interface s0
ip address 144.14.14.1 255.255.255.0
ip nat outside
Example 11-3
NAT Overload Implementation
!define what addresses are to be converted
access-list 1 permit 10.0.0.1 0.0.0.255
!define the pool of addresses to use for translation and
!what interfaces and addresses to use
ip nat pool natpool 123.123.123.1 123.123.123.2 netmask 255.255.255.0
ip nat inside source list 1 pool natpool overload