background image
3-35
Cisco AVVID Network Infrastructure Enterprise Quality of Service Design
956467
Chapter 3 QoS in an AVVID-Enabled Campus Network
Selecting an Access-Layer Switch
Enabling Priority Queuing
To enable priority queuing, do the following:
Step 1
Specify the interface range.
3550G-Access(config)#interface range g 0/1 - 12
Step 2
Specify the priority queue.
3550G-Access(config-if-range)#priority-queue out
Step 3
Move the CoS 5 traffic to queue 4, which is the priority queue for the Catalyst 3500 family.
3550G-Access(config-if-range)#wrr-queue cos-map 4 5
Configuring ACLs
There are times when classification of traffic by the access-layer switch is required. The Catalyst 3550
has a powerful set of features that allow us to classify traffic as it enters the network. The following
configuration illustrates how to classify VoIP bearer and control traffic with the Catalyst 3550 as it
enters the network.
Step 1
Create the ACLs to identify the traffic.
3550G-Access(config)#ip access-list extended VOICE
3550G-Access(config-ext-nacl)#remark Match the UDP ports that VoIP Uses for Bearer Traffic
3550G-Access(config-ext-nacl)#permit udp any any range 16384 32767
3550G-Access(config)#ip access-list extended VOICE-CONTROL
3550G-Access(config-ext-nacl)#remark Match VoIP Control Traffic
3550G-Access(config-ext-nacl)#remark SCCP
3550G-Access(config-ext-nacl)#permit tcp any any range 2000 2002
3550G-Access(config-ext-nacl)#remark H323 Fast Start
3550G-Access(config-ext-nacl)#permit tcp any any eq 1720
3550G-Access(config-ext-nacl)#remark H323 Slow Start - Verify could be in 3000 range for
CM or 11000 to 65535 with newer IOS's
3550G-Access(config-ext-nacl)#permit tcp any any range 11000 11999
3550G-Access(config-ext-nacl)#remark H323 MGCP
3550G-Access(config-ext-nacl)#permit udp any any eq 2427
Step 2
Create classes that use the ACLs as admission criteria.
3550G-Access(config)#class-map match-all VOICE
3550G-Access(config-cmap)#description VOIP Bearer Traffic
3550G-Access(config-cmap)#match access-group name VOICE
3550G-Access(config)#class-map match-all VOICE-CONTROL
3550G-Access(config-cmap)#description VOIP Control Traffic (SCCP, H225, H254, MGCP)
3550G-Access(config-cmap)#match access-group name VOICE-CONTROL
Step 3
Create a policy to set the DSCP PHB label/value for the classes.
3550G-Access(config)#policy-map ACCESS-C3550-LAN-EDGE-IN
3550G-Access(config-pmap)#description Set DSCP PerHopBehavior Label for VOIP Control and
Bearer Traffic
3550G-Access(config-pmap)#class VOICE-CONTROL
3550G-Access(config-pmap-c)#set ip dscp 26
3550G-Access(config-pmap)#class VOICE
3550G-Access(config-pmap-c)#set ip dscp 46