background image
6-12
Cisco AVVID Network Infrastructure Enterprise Quality of Service Design
956467
Chapter 6 QoS with MPLS in an AVVID-Enabled Network
Implementing MPLS VPN QoS
policy-map PE-EDGE-OUT
class VOICE-MPLS
priority percent 33
class DATA-MPLS
bandwidth percent 42
random-detect dscp-based
class class-default
random-detect dscp-based
!
mpls traffic-eng auto-bw timers
!
ip vrf testvrf
rd 100:20
route-target import 100:30
!
!
interface Loopback0
ip address 172.16.255.1 255.255.255.255
no ip directed-broadcast
!
interface POS0/0/0
ip address 172.16.0.1 255.255.255.252
no ip directed-broadcast
ip router isis
encapsulation ppp
ip route-cache distributed
service-policy output PE-EDGE-OUT
tag-switching ip
!
interface Serial1/0/0
ip address 192.168.1.1 255.255.255.252
ip vrf forwarding testvrf
no ip directed-broadcast
ip route-cache distributed
service-policy input PE-EDGE-IN
!
router isis 60
net 49.0011.0000.0000.0005.00
is-type level-2-only
metric-style wide
max-lsp-lifetime 65500
lsp-refresh-interval 64000
log-adjacency-changes
!
router bgp 10
no synchronization
bgp log-neighbor-changes
network 192.168.1.0
neighbor 172.16.255.2 remote-as 10
neighbor 172.16.255.2 update-source Loopback0
!
address-family ipv4 vrf testvrf
redistribute connected
neighbor 192.169.1.2 remote-as 60
neighbor 192.169.1.2 activate
neighbor 192.169.1.2 send-community both
neighbor 192.169.1.2 as-override
neighbor 192.169.1.2 route-map RESTRICT-SOO in
neighbor 192.169.1.2 description --------------- CE ROUTER
no auto-summary
no synchronization
exit-address-family
!