background image
4-31
Cisco AVVID Network Infrastructure Enterprise Quality of Service Design
956467
Chapter 4 QoS in an AVVID-Enabled Wide-Area Network
QoS Recommendations for Remote Branch Routers
Example 4-21 DSCP Classification at the Ingress Interface
ip cef
!
class-map match-all SAP
match access-group 100
class-map match-all SQLNET
match protocol sqlnet
class-map match-all CITRIX
match protocol citrix
class-map match-any EMAIL
match protocol pop3
match protocol imap
match protocol smtp
class-map match-all TELNET
match protocol telnet
class-map match-all RCMD
match protocol rcmd
class-map match-all FTP
match protocol ftp
class-map match-all BACKUPS
match access-group 101
class-map match-any P2P
match protocol napster
match protocol fasttrack
!
policy-map REMOTE-LAN-EDGE-IN
class SAP
set ip dscp af21
class SQLNET
set ip dscp af22
class CITRIX
set ip dscp af23
class EMAIL
set ip dscp af11
class TELNET
set ip dscp af12
class RCMD
set ip dscp af13
class FTP
set ip dscp 2
class BACKUPS
set ip dscp 4
class P2P
set ip dscp 6
!
interface FastEthernet0/0
description CAT3500 REMOTE-BRANCH ACCESS-SWITCH
no ip address
no ip mroute-cache
load-interval 30
speed auto
duplex auto
!
interface FastEthernet0/0.50
description NATIVE SUBNET 10.1.50.0 DATA
encapsulation dot1Q 50
ip address 10.1.50.1 255.255.255.0
service-policy input REMOTE-LAN-EDGE-IN
This command applies the input MQC policy to the
service-policy output REMOTE-LAN-EDGE-OUT
sub-interface.
!
...
access-list 100 permit tcp any any eq 3200
access-list 101 permit tcp any host 10.1.100.100