background image
412 Chapter 6: Routing
company wanted to use private IP addresses, then the intermingling of IP routes would be
disastrous. For instance, if both Company A and Company B decided to use network 10.0.0.0,
subnets would overlap and only some of the traffic would be delivered correctly.
The benefit of tunneling for VPNs is that the service provider network does not learn routes
about Company A or Company B. The tunnels use addresses in the service provider network.
The routing protocol on Routers A1 and A2 send updates to each other over the tunnel, so these
two routers think they are logically adjacent. Likewise, Routers B1 and B2 send updates to each
other; these updates do not need to be processed by the service provider routers. Also, because
the customer routes are not learned by the service provider, there is no need for route
redistribution or route filtering.
Configuring Tunneling
Tunneling configuration is not very complicated if you remember the framing with the
transport, encapsulation, and passenger protocols. A tunnel interface is created on each router
at the ends of the tunnel. To accommodate the transport protocol, an IP address is used at the
endpoints of the tunnel; these IP addresses are used as the source and destination IP addresses
of the encapsulated packets. The type of encapsulation protocol is configured; there are six
alternatives. Finally, the tunnel interface is configured just like any other interface to enable the
desired passenger protocols. Examples 6-22 and 6-23 show the configuration of Routers A and
D, respectively, from Figure 6-16.
Example 6-22
Router A Tunnel Configuration
ipx routing
!
interface serial 0
ip address 10.1.2.1 255.255.255.0
interface ethernet 0
ip address 10.1.1.1 255.255.255.0
ipx network 1
!
interface tunnel 0
tunnel source ethernet 0
tunnel destination 10.1.5.4
ipx network 3
!
router igrp 9
network 10.0.0.0
Example 6-23
Router D Tunnel Configuration
ipx routing
!
interface token 0
ip address 10.1.4.4 255.255.255.0
interface ethernet 0
ip address 10.1.5.4 255.255.255.0
ch06.fm Page 412 Monday, March 20, 2000 5:11 PM