background image
388 Chapter 6: Routing
waste processing cycles. The show ip route output on Albuquerque lists the previously missing
subnet, 10.1.3.192/26; this is expected as highlighted in the debug ip rip messages received by
Albuquerque from Seville (10.1.6.253). The subnet masks are shown in the prefix style, with
/26 representing mask 255.255.255.192. Also, note the debug output designating tag 0--this
means that all the external route tags have value 0, which is the default.
Migration from RIP-1 to RIP-2 requires some planning. RIP-1 sends updates to the broadcast
address, whereas RIP-2 uses a multicast. A RIP-1 only router and a RIP-2 only router will not
succeed in exchanging routing information. To migrate to RIP-2, one option is to migrate all
routers at the same time. This might not be a reasonable political or administrative option,
however. If not, then some coexistence between RIP-1 and RIP-2 is required.
The ip rip send version command can be used to overcome the problem. Essentially, the
configuration tells the router whether to send RIP-1 style updates, RIP-2 style updates, or both
for each interface. Consider the familiar Figure 6-10 network, with RIP-1 still configured on all
three routers. If two of the routers are migrated--for instance, Albuquerque and Seville--then
they can communicate with RIP-2 easily. However, by default these two routers will now send
only RIP-2 updates, which Yosemite cannot understand because it is still running RIP-1. The
configurations in Examples 6-11, 6-12, and 6-13 overcome the problem by having Albuquerque
and Seville send only RIP-1 updates to Yosemite.
Example 6-11
Configuration on Albuquerque
interface ethernet 0
ip addr 10.1.1.251 255.255.255.0
interface serial 0
ip addr 10.1.4.251 255.255.255.0
ip rip send version 1
ip rip receive version 1
interface serial 1
ip address 10.1.6.251 255.255.255.0
!
router rip
network 10.0.0.0
version 2
Example 6-12
Configuration on Yosemite
interface ethernet 0
ip addr 10.1.2.252 255.255.255.0
interface serial 0
ip addr 10.1.4.252 255.255.255.0
interface serial 1
ip address 10.1.5.252 255.255.255.0
!
router rip
network 10.0.0.0
ch06.fm Page 388 Monday, March 20, 2000 5:11 PM