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About This Guide

This guide provides the necessary information to help you use Cisco QAM Gateway Manager to 
configure and monitor Cisco uMG9850 QAM Modules installed in Cisco Catalyst 4500 series switches. 
The Cisco uMG9850 QAM module supports the delivery of digital broadcast and video-on-demand 
(VoD) services on a hybrid fiber coax (HFC) cable network.

This section discusses the following major topics:

• Document Audience

• Document Organization

• Document Conventions

• Related Documentation

• Obtaining Documentation

• Documentation Feedback

• Cisco Product Security Overview

• Obtaining Technical Assistance

• Obtaining Additional Publications and Information
vii
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About This Guide
Document Audience
Document Audience
This guide is a reference resource for network managers, system administrators responsible for 
managing the video network, and network analysts responsible for configuring the network.

Document Organization
This document is organized as shown in Table 1.

Document Conventions
The following conventions are used in this document:

Table 1 Document Organization

Chapter/Appendix Title Description

Chapter 1, “Introduction to Cisco QAM Gateway 
Manager”

Provides a product overview and describes basic 
concepts and tasks.

Chapter 2, “Installing Cisco QAM Gateway 
Manager”

Outlines minimum system requirements and 
set-up requirements.

Chapter 3, “Using Cisco QAM Gateway 
Manager”

Describes the use of Cisco QAM Gateway 
Manager for configuration of Cisco QAM 
Gateway devices.

Chapter 4, “Monitoring” Provides information on monitoring configured 
devices and lists application display messages.

Convention Description

boldface font Commands and keywords are in boldface.

italic font Arguments for which you supply values are in italics.

[ ] Elements in square brackets are optional.

{x | y | z} Alternative, mutually exclusive, keywords are grouped in braces and separated 
by vertical bars.

[x | y | z] Optional alternative keywords are grouped in brackets and separated by 
vertical bars.

string A nonquoted set of characters. Do not use quotation marks around the string or 
the string will include the quotation marks.

screen font Terminal sessions and information the system displays are in screen font.

boldface screen 

font
Information you must enter is in boldface screen font.

italic screen font Arguments for which you supply values are in italic screen font.
viii
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About This Guide
Related Documentation
Tip Means the following information might help you solve a problem.

Note Means reader take note. Notes contain helpful suggestions or references to material not covered in the 
publication.

Caution Means reader be careful. In this situation, you might do something that could result in corruption of data.

Related Documentation
The following documentation provides information relating to the installation, configuration, and 
operation of Cisco uMG9850 QAM Modules, Cisco Catalyst 4500 series switches, and Cisco QAM 
Gateway Manager.

Cisco uMG9850 QAM Module
Information regarding the Cisco uMG9850 QAM module can be found at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/cable/vod/umg9850/index.htm

Cisco Catalyst 4500 Series Switches
Information regarding Cisco Catalyst 4500 series switch hardware can be found at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat4000/hw_doc/index.htm

Information regarding Cisco Catalyst 4500 series switch software can be found at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat4000/index.htm

^ The symbol ^ represents the key labeled Control—for example, the key 
combination ^D in a screen display means hold down the Control key while 
you press the D key.

< > Nonprinting characters, such as passwords, are in angle brackets in contexts 
where italics are not available. Angle brackets are also used for variables.

[ ] Default responses to system prompts are in square brackets.

!, # An exclamation point (!) or a pound sign (#) at the beginning of a line of code 
indicates a comment line.

Convention Description
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Cisco QAM Gateway Manager User Guide, Release 1.1

OL-5763-02

http://www.cisco.com/univercd/cc/td/doc/product/cable/vod/umg9850/index.htm
http://www.cisco.com/univercd/cc/td/doc/product/lan/cat4000/hw_doc/index.htm
http://www.cisco.com/univercd/cc/td/doc/product/lan/cat4000/index.htm


  

About This Guide
Obtaining Documentation
Cisco QAM Gateway Manager
Additional documentation for Cisco QAM Gateway Manager can be found at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/cable/vod/cqgm/index.htm

Obtaining Documentation
Cisco documentation and additional literature are available on Cisco.com. Cisco also provides several 
ways to obtain technical assistance and other technical resources. These sections explain how to obtain 
technical information from Cisco Systems.

Cisco.com
You can access the most current Cisco documentation at this URL:

http://www.cisco.com/univercd/home/home.htm

You can access the Cisco website at this URL:

http://www.cisco.com

You can access international Cisco websites at this URL:

http://www.cisco.com/public/countries_languages.shtml

Documentation DVD
Cisco documentation and additional literature are available in a Documentation DVD package, which 
may have shipped with your product. The Documentation DVD is updated regularly and may be more 
current than printed documentation. The Documentation DVD package is available as a single unit. 

Registered Cisco.com users (Cisco direct customers) can order a Cisco Documentation DVD (product 
number DOC-DOCDVD=) from the Ordering tool or Cisco Marketplace.

Cisco Ordering tool:

http://www.cisco.com/en/US/partner/ordering/

Cisco Marketplace:

http://www.cisco.com/go/marketplace/

Ordering Documentation
You can find instructions for ordering documentation at this URL:

http://www.cisco.com/univercd/cc/td/doc/es_inpck/pdi.htm

You can order Cisco documentation in these ways:

• Registered Cisco.com users (Cisco direct customers) can order Cisco product documentation from 
the Ordering tool:

http://www.cisco.com/en/US/partner/ordering/
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About This Guide
Documentation Feedback
• Nonregistered Cisco.com users can order documentation through a local account representative by 
calling Cisco Systems Corporate Headquarters (California, USA) at 408 526-7208 or, elsewhere in 
North America, by calling 1 800 553-NETS (6387).

Documentation Feedback
You can send comments about technical documentation to bug-doc@cisco.com.

You can submit comments by using the response card (if present) behind the front cover of your 
document or by writing to the following address:

Cisco Systems
Attn: Customer Document Ordering
170 West Tasman Drive
San Jose, CA 95134-9883

We appreciate your comments.

Cisco Product Security Overview
Cisco provides a free online Security Vulnerability Policy portal at this URL:

http://www.cisco.com/en/US/products/products_security_vulnerability_policy.html

From this site, you can perform these tasks:

• Report security vulnerabilities in Cisco products.

• Obtain assistance with security incidents that involve Cisco products.

• Register to receive security information from Cisco.

A current list of security advisories and notices for Cisco products is available at this URL:

http://www.cisco.com/go/psirt

If you prefer to see advisories and notices as they are updated in real time, you can access a Product 
Security Incident Response Team Really Simple Syndication (PSIRT RSS) feed from this URL:

http://www.cisco.com/en/US/products/products_psirt_rss_feed.html

Reporting Security Problems in Cisco Products
Cisco is committed to delivering secure products. We test our products internally before we release them, 
and we strive to correct all vulnerabilities quickly. If you think that you might have identified a 
vulnerability in a Cisco product, contact PSIRT:

• Emergencies— security-alert@cisco.com

• Nonemergencies — psirt@cisco.com

Tip We encourage you to use Pretty Good Privacy (PGP) or a compatible product to encrypt any sensitive 
information that you send to Cisco. PSIRT can work from encrypted information that is compatible with 
PGP versions 2.x through 8.x. 
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About This Guide
Obtaining Technical Assistance
Never use a revoked or an expired encryption key. The correct public key to use in your correspondence 
with PSIRT is the one that has the most recent creation date in this public key server list:

http://pgp.mit.edu:11371/pks/lookup?search=psirt%40cisco.com&op=index&exact=on

In an emergency, you can also reach PSIRT by telephone:

• 1 877 228-7302

• 1 408 525-6532

Obtaining Technical Assistance
For all customers, partners, resellers, and distributors who hold valid Cisco service contracts, Cisco 
Technical Support provides 24-hour-a-day, award-winning technical assistance. The Cisco Technical 
Support Website on Cisco.com features extensive online support resources. In addition, Cisco Technical 
Assistance Center (TAC) engineers provide telephone support. If you do not hold a valid Cisco service 
contract, contact your reseller.

Cisco Technical Support Website
The Cisco Technical Support Website provides online documents and tools for troubleshooting and 
resolving technical issues with Cisco products and technologies. The website is available 24 hours a day, 
365 days a year, at this URL:

http://www.cisco.com/techsupport

Access to all tools on the Cisco Technical Support Website requires a Cisco.com user ID and password. 
If you have a valid service contract but do not have a user ID or password, you can register at this URL:

http://tools.cisco.com/RPF/register/register.do

Note Use the Cisco Product Identification (CPI) tool to locate your product serial number before submitting 
a web or phone request for service. You can access the CPI tool from the Cisco Technical Support 
Website by clicking the Tools & Resources link under Documentation & Tools. Choose Cisco Product 
Identification Tool from the Alphabetical Index drop-down list, or click the Cisco Product 
Identification Tool link under Alerts & RMAs. The CPI tool offers three search options: by product ID 
or model name; by tree view; or for certain products, by copying and pasting show command output. 
Search results show an illustration of your product with the serial number label location highlighted. 
Locate the serial number label on your product and record the information before placing a service call.

Submitting a Service Request
Using the online TAC Service Request Tool is the fastest way to open S3 and S4 service requests. (S3 
and S4 service requests are those in which your network is minimally impaired or for which you require 
product information.) After you describe your situation, the TAC Service Request Tool provides 
recommended solutions. If your issue is not resolved using the recommended resources, your service 
request is assigned to a Cisco TAC engineer. The TAC Service Request Tool is located at this URL:

http://www.cisco.com/techsupport/servicerequest
xii
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About This Guide
Obtaining Additional Publications and Information
For S1 or S2 service requests or if you do not have Internet access, contact the Cisco TAC by telephone. 
(S1 or S2 service requests are those in which your production network is down or severely degraded.) 
Cisco TAC engineers are assigned immediately to S1 and S2 service requests to help keep your business 
operations running smoothly.

To open a service request by telephone, use one of the following numbers:

Asia-Pacific: +61 2 8446 7411 (Australia: 1 800 805 227)
EMEA: +32 2 704 55 55
USA: 1 800 553-2447

For a complete list of Cisco TAC contacts, go to this URL:

http://www.cisco.com/techsupport/contacts

Definitions of Service Request Severity
To ensure that all service requests are reported in a standard format, Cisco has established severity 
definitions.

Severity 1 (S1)—Your network is “down,” or there is a critical impact to your business operations. You 
and Cisco will commit all necessary resources around the clock to resolve the situation. 

Severity 2 (S2)—Operation of an existing network is severely degraded, or significant aspects of your 
business operation are negatively affected by inadequate performance of Cisco products. You and Cisco 
will commit full-time resources during normal business hours to resolve the situation.

Severity 3 (S3)—Operational performance of your network is impaired, but most business operations 
remain functional. You and Cisco will commit resources during normal business hours to restore service 
to satisfactory levels.

Severity 4 (S4)—You require information or assistance with Cisco product capabilities, installation, or 
configuration. There is little or no effect on your business operations.

Obtaining Additional Publications and Information
Information about Cisco products, technologies, and network solutions is available from various online 
and printed sources.

• Cisco Marketplace provides a variety of Cisco books, reference guides, and logo merchandise. Visit 
Cisco Marketplace, the company store, at this URL:

http://www.cisco.com/go/marketplace/

• Cisco Press publishes a wide range of general networking, training and certification titles. Both new 
and experienced users will benefit from these publications. For current Cisco Press titles and other 
information, go to Cisco Press at this URL:

http://www.ciscopress.com

• Packet magazine is the Cisco Systems technical user magazine for maximizing Internet and 
networking investments. Each quarter, Packet delivers coverage of the latest industry trends, 
technology breakthroughs, and Cisco products and solutions, as well as network deployment and 
troubleshooting tips, configuration examples, customer case studies, certification and training 
information, and links to scores of in-depth online resources. You can access Packet magazine at 
this URL:

http://www.cisco.com/packet
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About This Guide
Obtaining Additional Publications and Information
• iQ Magazine is the quarterly publication from Cisco Systems designed to help growing companies 
learn how they can use technology to increase revenue, streamline their business, and expand 
services. The publication identifies the challenges facing these companies and the technologies to 
help solve them, using real-world case studies and business strategies to help readers make sound 
technology investment decisions. You can access iQ Magazine at this URL:

http://www.cisco.com/go/iqmagazine

• Internet Protocol Journal is a quarterly journal published by Cisco Systems for engineering 
professionals involved in designing, developing, and operating public and private internets and 
intranets. You can access the Internet Protocol Journal at this URL:

http://www.cisco.com/ipj

• World-class networking training is available from Cisco. You can view current offerings at 
this URL:

http://www.cisco.com/en/US/learning/index.html
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C H A P T E R 1

Introduction to Cisco QAM Gateway Manager

This chapter provides basic information about Cisco QAM Gateway Manager and includes the following 
sections:

• Overview, page 1-1

• Cisco QAM Gateway Manager Views, page 1-2

• Basic Tasks, page 1-15

Overview
Cisco QAM Gateway Manager is a PC-based graphical user interface (GUI) element management 
application to be used with Cisco uMG9850 QAM Modules installed in Cisco Catalyst 4500 series 
switches. The SNMP-based Java application is used for basic configuration, monitoring, and 
troubleshooting, and also includes hierarchical views of devices and their components, as well as a 
Telnet interface to the managed devices.

Hardware and Software Supported
Table 1-1 lists Cisco hardware supported by Cisco QAM Gateway Manager, along with the minimum 
software release required for each.

Table 1-1 Supported Hardware and Software

Product Number Description

Minimum 
Software 
Release Notes

Cisco Catalyst 
Switches

WS-C4506 Cisco Catalyst 4506 switch 
chassis

12.2(20)EU

WS-C4507R Cisco Catalyst 4507R switch 
chassis

12.2(20)EU

Cisco uMG9850 QAM 
Module

WS-X4712-UMG9850 QAM card for Cisco Catalyst 
4500 series switches 
(Annex B)

12.2(20)EU Used in Cisco Catalyst 
4506 and Cisco Catalyst 
4507R switches
1-1
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  Cisco QAM Gateway Manager Views
Cisco QAM Gateway Manager Views
Cisco QAM Gateway Manager uses a variety of views for configuration, monitoring, and 
troubleshooting:

• Chassis View

• Slot View

• All Session View

– All Session Details

• Session View

• Multicast Session View

– Multicast Session Details

• QAM Summary View

• QAM Channel View

• ASI Port View

• Ethernet Port View

• Notification History Table

A brief description of each of these views is provided in the sections that follow.
1-2
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  Cisco QAM Gateway Manager Views
Chassis View
The Chassis View (see Figure 1-1) lists for a selected device, the contents of each slot in the device, 
including the status of fan tray and power supply assemblies, and operating status. The Chassis View 
also provides the means to configure global timeouts and program-specific information (PSI) 
parameters.

Figure 1-1 Chassis View 

Note To access Chassis view for a specific Cisco Catalyst switch, highlight the switch in the navigation tree 
and choose View > Chassis.
1-3
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  Cisco QAM Gateway Manager Views
Slot View
The Slot View (see Figure 1-2) lists for a specific Cisco uMG9850 module, a summary of the QAM 
channels’ administrative and link status, and the administrative and link status of ASI and Ethernet ports. 
Also provided is information on the number of incoming sessions and outgoing programs.

The Slot View also allows configuration of slot-level timeouts, video routing, emulation mode, jitter, and 
Program Data Delivery (PDD), and provides links to the configuration of conditional access system 
(CAS) parameters, QAM parameters, and jumbo frames.

Figure 1-2 Slot View

Note To access Slot view, highlight a Cisco uMG9850 slot in the navigation tree and choose 
View > Slot.
1-4
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  Cisco QAM Gateway Manager Views
All Session View 
The All Session View (see Figure 1-3) lists session statistics for idle, inactive, and active sessions, and 
for invalid PSI states.

Figure 1-3 All Session View

Note To access All Session view, highlight a Cisco uMG9850 slot in the navigation tree and choose View > 
All Sessions, or click Detail in the All Sessions Information section of Slot view.
1-5
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  Cisco QAM Gateway Manager Views
All Session Details

All Session Details (see Figure 1-4) provides read-only values for a specific session.

Figure 1-4 All Session Details

Note To access All Session Details for a particular session, double-click on that session in All Session view.
1-6
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Chapter 1      Introduction to Cisco QAM Gateway Manager
  Cisco QAM Gateway Manager Views
Session View
Session View (see Figure 1-5) lists session statistics for active and inactive sessions, and invalid PSI 
states. 

Figure 1-5 Session View

Note To access Session view, highlight a Cisco uMG9850 slot in the navigation tree and choose 
View > Sessions.
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Multicast Session View
Multicast Session view (see Figure 1-6) lists statistics for multicast sessions.

Figure 1-6 Multicast Session View

Note To access Multicast Session view, highlight a Cisco uMG9850 slot in the navigation tree and choose
View > Multicast sessions.
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Multicast Session Details 

Multicast Session Details (see Figure 1-4) provides read-only values for a specific multicast session.

Figure 1-7 Multicast Session Details

Note To access Multicast Session Details for a particular session, double-click on that session in Multicast 
Session view.
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QAM Summary View
The QAM Summary View (see Figure 1-8) allows viewing and configuration of all QAM channels for 
all parameters except bandwidth utilization and video sessions mapping.

Figure 1-8 QAM Summary View

Note To access QAM Summary view, click Configure QAM Channels while in Slot view.
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QAM Channel View
The QAM Channel View (see Figure 1-9) lists the current configuration parameters for the selected 
QAM channel, and allows configuration of these parameters.

Figure 1-9 QAM Channel View

Note To access QAM Channel view, select a QAM port from the navigation tree and choose View > Interface.
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ASI Port View
The asynchronous serial interface (ASI) Port View (see Figure 1-10) lists the current configuration 
parameters for the ASI port and allows configuration of these parameters.

Figure 1-10 ASI Port View

Note To access the ASI Port view, highlight the ASI port on the Cisco uMG9850 module in the navigation 
tree, and choose View > Interface. 
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Ethernet Port View
The Ethernet Port View (see Figure 1-11) lists information on port configuration and status, and allows 
setting of administrative status for the port, switchport status, and VLAN number.

Figure 1-11 Ethernet Port View 

Note To access Ethernet Port view, highlight an Ethernet port on a Cisco uMG9850 module in the navigation 
tree, and choose View > Interface. 
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Notification History Table
The Notification History table (see Figure 1-12) lists statistics for a device. Each time a device threshold 
is passed or an invalid PSI data condition is detected, an entry is recorded in the table.

Figure 1-12 Notification History Table

Note To access the Notification History Table, highlight a Cisco Catalyst switch in the navigation tree. 
Right-click and choose View Notification.
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Basic Tasks
The following basic tasks are covered in subsequent chapters of this user guide:

• Installing and uninstalling Cisco QAM Gateway Manager (Chapter 2)

• Before using Cisco QAM Gateway Manager (Chapter 2)

• Launching Cisco QAM Gateway Manager (Chapter 3)

• Using Help (Chapter 3)

• Exiting Cisco QAM Gateway Manager (Chapter 3)

• Establishing communication with Cisco QAM Gateway devices (Chapter 3)

– Adding a device

– Removing a device

– Using the Telnet window

• Configuration tasks (Chapter 3)

– Loading a configuration

– Configuring SNMP parameters

– Saving a configuration to a TFTP server

– Configuring Gigabit Ethernet input ports into a VLAN

– Configuring video routing

– Setting emulation mode

– Setting output frequency and output power for the QAM channels

– Setting up, editing, and routing a video stream to QAM channels

– Setting PSI parameters

– Configuring Program Data Delivery

• Monitoring Cisco QAM Gateway devices (Chapter 4)

– Using CLI show commands

– Configuring the ASI port for QAM channel routing

– Setting and monitoring utilization thresholds

– Application display messages
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Installing Cisco QAM Gateway Manager

This chapter describes the tasks that should be performed prior to using Cisco QAM Gateway Manager.

• Minimum System Requirements, page 2-1

• Installing Cisco QAM Gateway Manager, page 2-1

• Before Using Cisco QAM Gateway Manager, page 2-2

• Removing Software, page 2-3

Minimum System Requirements
Table 2-1 lists the minimum system requirements for Cisco QAM Gateway Manager running on the 
Microsoft Windows platform.

Installing Cisco QAM Gateway Manager
Cisco QAM Gateway Manager runs in a Java environment. The application and the necessary Java 
components are bundled together and can be downloaded without charge from Cisco.com. 

Table 2-1 Microsoft Windows System Requirements

Specification Requirement

Processor 600 MHz

Operating system Microsoft Windows 2000 or XP

Available disk space 50 MB

Memory 256 MB
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Downloading and Starting Cisco QAM Gateway Manager

To download the Cisco QAM Gateway Manager application from Cisco.com:

Step 1 If you are currently running a version of Cisco QAM Gateway Manager, close the application.

Note When installing a new version of Cisco QAM Gateway Manager, any version of the application 
that is in the default directory is uninstalled automatically. If you use a directory different from 
a previous installation, an additional application is installed.

Step 2 Access the Cisco QGM installation file from the following URL:

http://www.cisco.com/cgi-bin/tablebuild.pl/qam-gateway

Step 3 Click on the executable (.exe) file. InstallShield loads and presents a welcome screen. Click Next.

Step 4 Read and accept the End User License Agreement and click Next. (If you do not agree to the terms of 
the agreement, click the non-acceptance button to end the installation.)

Step 5 Accept the default installation directory or click Browse to select another one. Click Next.

Step 6 Click the Create desktop icon button if you want a shortcut to the application to appear on your desktop. 
Click Next.

Step 7 Read the summary information and confirm by clicking Install. If the information is not accurate, click 
Back to make corrections or Cancel to stop the installation process.

Step 8 The application is installed and a successful install screen is displayed. Click Finish to complete the 
process.

Step 9 Start Cisco QAM Gateway Manager by clicking on the shortcut icon on your desktop or by choosing 
Start > Programs > Cisco Systems > Cisco QAM Gateway Manager.

Before Using Cisco QAM Gateway Manager 
This section summarizes the minimum configuration required before using Cisco QAM Gateway 
Manager. These tasks would normally be completed in advance by the network or device administrator 
using the device command line interface (CLI). 

To see the detailed steps for completing each of these tasks, refer to the Cisco Catalyst 4500 series switch 
documentation listed in Related Documentation.

Before using Cisco QAM Gateway Manager, ensure that you have the following information for each 
device to be managed:

• Telnet password

• IP address

• SNMP community string

• VLAN information:

– VLAN numbers

– IP addresses
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Telnet Password
A Telnet password should be set to control access to the device through the Telnet window in 
Cisco QAM Gateway Manager. You need to know this password to use the application’s Telnet function. 

SNMP Setup
Cisco QAM Gateway Manager uses Simple Network Management Protocol (SNMP) and a special 
management information base (MIB) to manage Cisco QAM gateway devices. The MIBs are included 
in the software releases shown in Table 1-1 on page 1-1.

Ethernet Port for SNMP Configuration

An IP address must be configured for each device for SNMP use. You must have this information when 
adding devices to the device list in Cisco QAM Gateway Manager.

SNMP Community String

The SNMP community string authenticates access to MIB objects, and functions as an embedded 
password. You must have this information when adding devices to the device list in Cisco QAM Gateway 
Manager. Cisco Catalyst switches must be configured with SNMP community strings before using 
Cisco QAM Gateway Manager to monitor or configure these devices.

Setting Up Input Video Traffic and VLAN information
Video input specifications and any required VLANs must be configured on the device before using Cisco 
QAM Gateway Manager. 

Removing Software

Removing Cisco QAM Gateway Manager from the PC
To remove Cisco QAM Gateway Manager from the PC, click Start > Settings > Control Panel > 
Add/Remove Programs and select Cisco QAM Gateway Manager.

Note When installing a new version of Cisco QAM Gateway Manager, any version of the application that is 
in the default directory is uninstalled automatically. If you use a directory different from a previous 
installation, an additional application is installed.
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Using Cisco QAM Gateway Manager

This chapter describes the steps required to launch Cisco QAM Gateway Manager and configure 
Cisco uMG9850 QAM modules installed in Cisco Catalyst switches.

• Launching Cisco QAM Gateway Manager, page 3-1

• Main Window Components, page 3-2

• Using Help, page 3-10

• Exiting Cisco QAM Gateway Manager, page 3-12

• Establishing Communication with Cisco QAM Gateway Devices, page 3-13

• Configuration Tasks, page 3-18

Launching Cisco QAM Gateway Manager
To launch Cisco QAM Gateway Manager, click on the CQGM shortcut icon on the desktop or click 
Start > Programs > Cisco Systems > Cisco QAM Gateway Manager. After displaying a splash screen, 
the Main Window appears (see Figure 3-1 on page 3-2).
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Figure 3-1 Main Window

Main Window Components
The main window (see Figure 3-1) consists of five areas:

1. Menu bar

2. Toolbar

3. Status bar

4. Navigation tree

5. Work area

Each of these areas is discussed in the following sections.

Menu Bar
The menu bar (see Figure 3-2) provides access to common application functions and tasks (see 
Table 3-1).

Figure 3-2 Menu Bar
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Table 3-1 Menu Bar Functions

Menu Function Description

File Add Device Adds Cisco Catalyst switches to the device list.

Load configuration Provides options to:

• Load a configuration file from a TFTP server to the 
startup configuration.

• Load a configuration file from a TFTP server to the 
running configuration.

• Copy startup configuration to running configuration.

• Copy running configuration to startup configuration.

Save configuration to TFTP 
server

Provides options to:

• Save the startup configuration to a TFTP server.

• Save the running configuration to a TFTP server.

Configure SNMP Parameters When “Cisco QAM Gateway Manager” (root) is selected 
in the navigation tree, configures SNMP polling 
parameters.

When a Cisco Catalyst switch is selected in the 
navigation tree, configures the SNMP community string 
for that device.

Close All Closes all open views and configuration dialog boxes.

Exit Exits Cisco QAM Gateway Manager application.

View Chassis Displays chassis statistics.

Slot Displays contents and status of the Cisco uMG9850 
modules in Cisco Catalyst switch chassis, and provides 
multiple configuration options.

All Sessions Lists both active and idle sessions.

Sessions Lists only active sessions.

Multicast Sessions Lists all multicast sessions.

Interface Displays QAM, ASI, or Ethernet interface 
configurations.

Configure Configure VLAN Assigns an IP address and optional subnet mask to a 
selected VLAN. Activates or suspends a VLAN.

Telnet Device 1 Allows selection of connected devices for Telnet 
sessions.Device n

Window various Lists all open/active views and configuration dialog 
boxes.

Help Contents Provides access to all help files by Table of Content 
heading and text search.

About Displays software version of Cisco QAM Gateway 
Manager.
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Toolbar
The toolbar (Figure 3-3) provides quick access to some commonly performed tasks (see Table 3-2).

Figure 3-3 Toolbar

Status Bar
The Status Bar (see Figure 3-4) indicates status of configuration load and refresh operations (see 
Table 3-3).

Figure 3-4 Status Bar

Table 3-2 Toolbar Functions

Tool Description

Add Device Adds Cisco Catalyst switches to the navigation 
tree.

Configure When “Cisco QAM Gateway Manager” (root) in 
the navigation tree (see Figure 3-1) is selected, 
allows configuration of SNMP polling 
parameters.

When device is selected in the navigation tree, 
configures the SNMP community string for that 
device.

Refresh Refreshes current view.

Stop Stops refresh process for current view.

Table 3-3 Status Bar Messages

Function Description

Done Function is complete.

Refreshing tree. Please wait. Navigation tree refresh in process.

Loading slot configuration. Please wait. Slot View information being loaded.

Loading Ethernet configurations. Please wait. Ethernet Port View information being loaded.

Loading QAM channel configurations. Please 
wait.

QAM Channel View information being loaded.

Loading chassis configurations. Please wait. Chassis View information being loaded.
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Navigation Tree
The Navigation Tree (see Figure 3-5) lists all added devices. Each entry expands to display its 
components. Use the scroll bar to see the full expansion.

Figure 3-5 Navigation Tree

To refresh the navigation tree, select and right-click on “Cisco QAM Gateway Manager” at the top of 
the tree and choose Refresh tree. (See Figure 3-6 on page 3-6.)

Loading session configuration. Please wait. Session View or session status information is being 
loaded.

Loading notification history. Please wait. Refreshing Notification History table.

Loading VLAN configurations. Please wait Refreshing VLAN configuration information.

Table 3-3 Status Bar Messages (continued)

Function Description
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Figure 3-6 Refresh Navigation Tree

Note Refreshing the navigation tree also collapses the navigation tree to the device level.

Work Area
The Work area (see Figure 3-7) can contain a variety of view windows and configuration dialog boxes. 
This area changes depending on the function being performed (see Table 3-4). Up to 30 of these windows 
can be open simultaneously.

Figure 3-7 Work Area

Table 3-4 on page 3-7 lists configuration, monitoring, and troubleshooting tasks that are commonly 
performed, and provides a cross-reference to the appropriate view or configuration window.

Tip Print out Table 3-4 and keep it as a quick reference tool.
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Table 3-4 Quick Reference—Work Area Navigation Map

Go To . . . For This Task. . . Or Subtask . . . Notes
Chassis View

• Contents and operating status of 
each slot in the Cisco Catalyst 
switch.

Setting Up PSI 
Parameters, page 
3-37.

Setting PMT and 
PAT Intervals for 
the Switch, page 
3-37.

Setting PMT and 
PAT Intervals for a 
QAM Channel, 
page 3-37.

Setting TSID and 
NIT-PID Values, 
page 3-38.

Setting Up, 
Editing, and 
Routing a Video 
Stream to QAM 
Channels, page 
3-32.

Statically Setting 
Session Timeouts, 
page 3-33.

Slot View

• For a specific QAM device, a 
summary of the QAM channels’ 
administrative and link status, and 
the administrative and link status 
of ASI and Ethernet ports. 

• Information on number of 
incoming sessions and outgoing 
programs.

Configuring 
Gigabit Ethernet 
Input Ports into a 
VLAN, page 3-27 
(see Notes).

Configuring Video 
Routing, page 3-29.

See also Ethernet Port View and 
Modifying a VLAN’s Address or 
Administrative Status, page 
3-28.

Setting Up, 
Editing, and 
Routing a Video 
Stream to QAM 
Channels, page 
3-32.

Configuring 
Maximum Jitter for 
a Session, page 
3-36.

Statically Setting 
Session Timeouts, 
page 3-33.

See also QAM Channel View 
and Chassis View.

Setting Emulation 
Mode, page 3-30.

Configuring 
Program Data 
Delivery, page 
3-39.

Session View

• Statistics for active sessions.
View table of all 
active sessions.

All Session View

• Statistics for both idle and active 
sessions.

View table of both 
idle and active 
sessions.

View individual 
session statistics.

Multicast Session View

• Statistics for multicast sessions.
View table for 
multicast sessions.

View individual 
session statistics.
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ASI Port View

• For a specific ASI port, lists the 
current configuration parameters 
for the ASI port.

Setting 
administrative 
status for the port

Setting Byte Gap

Select QAM 
Routed

Ethernet Port View

• For a specific Ethernet port, lists 
current status and configuration 
and allows configuration of the 
administrative status, switchport 
status, VLAN number, IP address 
and subnet mask.

Setting 
administrative 
status for the port

Setting switchport 
status

Configuring 
Gigabit Ethernet 
Input Ports into a 
VLAN, page 3-27.

Assigning the Input 
GE Port to a 
VLAN, page 3-28.

See also Ethernet Port View, 
page 3-8 and Slot View, page 
3-7.

QAM Channel View

• Lists the current configuration 
parameters for the selected QAM 
channel.

Configuring 
Gigabit Ethernet 
Input Ports into a 
VLAN, page 3-27.

Set administrative 
status for the port

Also see QAM Summary View.

Setting Up, 
Editing, and 
Routing a Video 
Stream to QAM 
Channels, page 
3-32.

Setting the 
Modulation 
Format, page 3-32.

Configuring the 
FEC Interleave 
Level and Mode, 
page 3-33.

Statically Routing a 
Range of Program 
Sessions to a QAM 
Channel (UDP Port 
Mapping), page 
3-35.

Setting the Output 
Frequency and 
Output Power of 
the QAM 
Channels, page 
3-31.

QAM Summary View

• Allows viewing and configuration 
of all QAM channels on a specific 
Cisco uMG9850 QAM module 
slot.

Table 3-4 Quick Reference—Work Area Navigation Map (continued)

Go To . . . For This Task. . . Or Subtask . . . Notes
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Choose an already opened view from the Window menu or open a new one using the View menu. To 
close all views simultaneously, choose File > Close All.

Resizing the Navigation Tree and Work Area
To hide the navigation tree and expand the work area, click on the left arrow. To hide the work area and 
expand the navigation tree, click on the right arrow. (See Figure 3-8.)

Figure 3-8 Hide Buttons

To readjust the navigation tree and work area to specific widths, place the cursor on the margin as shown 
in Figure 3-9. When it becomes a double-ended arrow, drag the margin to the left or right. 

Figure 3-9 Sizing the Navigation Tree and Work Area

Notification History

• Lists statistics for a device. Each 
time a device threshold is passed or 
an error condition is detected, an 
entry is recorded in the table.

See also Setting and Monitoring 
Utilization Thresholds, page 4-8.

Telnet Window

• Allows entry of CLI commands to 
configure Cisco Catalyst switches.

Using the Telnet 
Window, page 
3-16

Telnet—CLI show 
commands, page 
4-5.

Table 3-4 Quick Reference—Work Area Navigation Map (continued)

Go To . . . For This Task. . . Or Subtask . . . Notes
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Using Help
The help files for the Cisco QAM Gateway Manager application are provided to simplify the use of the 
application. These files can be accessed in two ways:

• Help for a specific screen can be accessed by clicking Help on that screen.

• The full help set can be accessed by choosing Help > Contents or by pressing F1.

Screen-Specific Help
Clicking Help in a window opens the help set and displays help files for that particular window. These 
files include discussions of any configuration options or read-only values present. Further navigation 
cross-references are included where necessary for greater understanding.

Full Help Set
Choose Help > Contents or press F1 to open the entire help set.

The navigation pane on the left side of the window includes three tabs: the Contents tab, the Index tab, 
and the Search tab. Navigation and printing aids are present in the help files and in the help toolbar. See 
Figure 3-10.

Figure 3-10 Help Tools and Tabs
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Contents Tab

Click the Contents tab to display a Table of Contents of all help files, which allows you to click on a 
specific subject or task for information. See Figure 3-11.

Figure 3-11 Help File Table of Contents

Index Tab

Click the Index tab and enter an index term. The index term list is searched and if found, the page is 
displayed. See Figure 3-12.

Figure 3-12 Help File Index Tab

Search Tab

Click the Search tab and enter a text search term. All help files are searched for the term, and the results 
(number of occurrences) are displayed in the left side of the window in order of significance. The page 
containing the first occurrence appears on the right. See Figure 3-13.
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Figure 3-13 Help Files Search Tab

Navigation

Table 3-5 shows the navigation buttons and describes their use.

Exiting Cisco QAM Gateway Manager
To exit the application, follow these steps:

Step 1 Do the following:

• Choose File > Exit (see Figure 3-14).

Table 3-5 Navigation Buttons

Icon Name Use

Navigation Arrows Click the arrows at the top and bottom of all help 
file text windows to step backward and forward 
sequentially through the files.

Return to Previous Use the arrows in the toolbar to return directly 
to the most recently viewed text.

Printer Functions Click the printer icons in the toolbar for direct 
printing (left icon) or page setup (right icon).
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Figure 3-14 File Exit

The Save Running Configuration dialog box appears (see Figure 3-15).

Figure 3-15 Save Running Configuration

Step 2 Click Cancel to keep the application active and return to configuration tasks, click Save All and Quit 
to save all configurations applied during this session to the startup configuration, or click Save None 
and Quit to exit without saving any configurations applied during this session. All active windows are 
closed and the Cisco QAM Gateway Manager session ends. 

Note If the Save all configurations to startup configuration? check box is selected in the Add Device or 
Configure SNMP Parameters dialog box (see “Adding a Device” section on page 3-13 and “Configuring 
SNMP Parameters” section on page 3-21), configuration changes are automatically saved to the startup 
configuration each time Apply is clicked, independently of Save All and Quit or Save None and Quit 
selections.

Establishing Communication with Cisco QAM Gateway Devices
• Adding a Device

• Removing a Device

• Using the Telnet Window

Adding a Device
To configure and monitor Cisco QAM Gateway devices, you must first add Cisco Catalyst switches to 
the device list. Up to 20 devices can be managed by Cisco QAM Gateway Manager. 
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To add a device:

Step 1 Select Add Device using one of the following methods:

• Choose File > Add device (see Figure 3-16).

Figure 3-16 Add Device Using File Menu

• Click the Add Device tool (see Figure 3-17).

Figure 3-17 Add Device Using Add Device Button

• In the navigation tree, select, then right-click “Cisco QAM Gateway Manager” (see Figure 3-18).

Figure 3-18 Add Device Using Right Mouse Click

Step 2 In the Add Device dialog box, enter the IP Address and Community String of the device (see 
Figure 3-19). 

Note Entering the SNMP community string does not change the value on the device. It authenticates access 
to the device. The community string must be defined before adding the device to the list. See Before 
Using Cisco QAM Gateway Manager, page 2-2.
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If you want to automatically save all configurations to the startup configuration, click the check box. 
When the check box is selected, any change made to a device using Cisco QAM Gateway Manager is 
automatically saved to both the running and startup configuration files of that device. If the check box 
is not selected, configuration changes are saved only to the running configuration.

Figure 3-19 Add Device Dialog Box

Note When using the option to automatically save all changed configuration information to the startup 
configuration file, you can make a backup of the existing startup configuration to a TFTP server before 
changing configurations. Choose File > Save configuration to TFTP server. This backup can be used 
in case it is necessary to restore the original startup configuration after a device reload. (See Saving a 
Configuration to a TFTP Server, page 3-25.)

Step 3 Click OK. The device name and its IP address are displayed in the navigation tree (see Figure 3-20).

Figure 3-20 Navigation Tree with Device Added

Removing a Device
To remove a Cisco Catalyst switch from the list:

Step 1 In the navigation tree, select the switch to remove, then right-click. (see Figure 3-21).
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Figure 3-21 Selecting Remove

Step 2 Choose Remove. A confirmation window appears.

Step 3 Click Yes.

Using the Telnet Window
Use the Telnet window to enter command-line interface (CLI) commands such as show commands, or 
perform other configuration tasks on Cisco Catalyst switches listed in the navigation tree. 

Note For further information regarding CLI commands refer to Configuring the Cisco uMG9850 QAM 
Module, the Cisco Catalyst 4500 Series IOS Software Configuration Guide, and the Catalyst 4500 Series 
Switch Cisco IOS Command Reference.

Commonly used show commands are summarized in Chapter 4, “Monitoring”.

To access a Cisco Catalyst switch using the Telnet window:

Step 1 Choose the switch using one of the following methods:

• Choose Telnet > device name from the menu bar (see Figure 3-22).

Figure 3-22 Telnet to Cisco Catalyst Switch

• Right-click on the Cisco Catalyst switch in the navigation tree and choose Telnet (see Figure 3-23).
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Figure 3-23 Telnet to Device Using Right-Click

The Telnet window appears (see Figure 3-24).

Figure 3-24 Telnet Window 

Step 2 Enter the Telnet password for the switch and press Enter (see Figure 3-25). 
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Figure 3-25 Logged on to the Switch

Step 3 Enter the required CLI commands.

Step 4 To terminate the Telnet session, type exit (see Figure 3-26), or choose File > Exit in the Telnet window 
menu bar.

Figure 3-26 Exiting Telnet Session

Step 5 To close the Telnet window, click the X in the upper right of the window.

Configuration Tasks
The following configuration tasks can be accomplished using Cisco QAM Gateway Manager. 
Instructions for each are provided in the subsections that follow.

• Loading a Configuration

• Configuring SNMP Parameters

• Saving a Configuration to a TFTP Server

• Configuring Gigabit Ethernet Input Ports into a VLAN

• Configuring Video Routing

• Setting Emulation Mode

• Setting the Output Frequency and Output Power of the QAM Channels

• Setting Up, Editing, and Routing a Video Stream to QAM Channels

• Setting Up PSI Parameters

• Configuring Program Data Delivery
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Loading a Configuration
You can copy the Cisco Catalyst switch startup configuration to the running configuration, copy the 
running configuration to the startup configuration, or load a configuration file from a TFTP server to the 
running configuration or the startup configuration of the switch.

Copying the Startup Configuration to Running Configuration

To copy the switch startup configuration to the running configuration:

Step 1 Select the Cisco Catalyst switch in the navigation tree, and choose File > Load configuration 
(see Figure 3-27). 

Figure 3-27 Load Configuration

Step 2 In the Load Configuration dialog box, click the Startup configuration button (see Figure 3-28).

Figure 3-28 Startup Configuration Button

Step 3 Click OK to start the copy. A confirmation message appears.

Step 4 Click Yes to confirm and start the copy, or click No or Cancel to cancel the copy.
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Copying the Running Configuration to Startup Configuration

To copy the switch running configuration to the startup configuration:

Step 1 Select the Cisco Catalyst switch in the navigation tree, and choose File > Load configuration (see 
Figure 3-29). 

Figure 3-29 Load Configuration

Step 2 In the Load Configuration dialog box, click the Running configuration button (see Figure 3-30).

Figure 3-30 Running Configuration Button

Step 3 Click OK to start the copy. A confirmation message appears.

Step 4 Click Yes to confirm and start the copy, or click No or Cancel to cancel the copy.

Loading a Configuration from a TFTP Server

To load a startup configuration or a running configuration from a TFTP server to the Cisco Catalyst 
switch:

Step 1 Select the device and choose File > Load configuration (see Figure 3-31).
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Figure 3-31 Load Configuration

Step 2 Click the TFTP server button (see Figure 3-32).

Figure 3-32 TFTP Server Button

Step 3 Enter the IP address and filename of the TFTP server.

Step 4 Choose the destination file (either Startup configuration or Running configuration) from the 
Destination file name pull-down menu.

Step 5 Click OK to start the load. A confirmation message appears.

Step 6 Click Yes to confirm and start the load, or click No or Cancel to cancel the load.

Note The switch must be reloaded for the startup configuration to take effect. Changes to the running 
configuration take effect immediately.

Configuring SNMP Parameters
Cisco QAM Gateway Manager uses Simple Network Management Protocol (SNMP) and a special 
management information base (MIB) to manage Cisco QAM Gateway devices. Two SNMP parameters, 
Polling Interval and SNMP Community String, can be set using Cisco QAM Gateway Manager as 
described in the following sections.
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Setting SNMP Polling Interval

The polling interval determines how frequently Cisco QAM Gateway Manager requests status 
information from each of the managed devices. 

To set the SNMP polling parameters for all devices:

Step 1 Select “Cisco QAM Gateway Manager” in the navigation tree, then set the polling parameters using one 
of the following methods:

• Choose File > Configure SNMP Parameters (see Figure 3-33).

Figure 3-33 Using File Menu

• Right-click on “Cisco QAM Gateway Manager” and choose Configure SNMP (see Figure 3-34).

Figure 3-34 Using Right Click

• Click the Configure button in the tool bar (see Figure 3-35).

Figure 3-35 Using the Tool Bar

Step 2 The default is 180 seconds. To change this value, enter a new polling interval from 180 to 3600 seconds 
(see Figure 3-36).
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Figure 3-36 Polling Interval Configuration Dialog Box

Step 3 Click OK to save the configuration, or click Cancel to close the dialog box and discard any changes.

Setting the SNMP Community String

If the system administrator changes the community string on the Cisco Catalyst switch, use this function 
to set the new SNMP community string for that switch in Cisco QAM Gateway Manager.

To set the community string:

Step 1 Select a Cisco Catalyst switch in the navigation tree, then set the SNMP community string using one of 
the following methods:

• Choose File > Configure SNMP Parameters (see Figure 3-37).

Figure 3-37 Using File Menu

• In the navigation tree, right-click on the Cisco Catalyst switch and choose Configure SNMP (see 
Figure 3-38).
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Figure 3-38 Using Right Click

• Select the Cisco Catalyst switch in the navigation tree and click Configure in the toolbar (see 
Figure 3-39).

Figure 3-39 Using Configure Button 

Step 2 Enter the new SNMP community string and, if there has been a requirement change since first adding 
the device, select or deselect the Save all configurations to startup configuration? box (see Figure 3-40).

Figure 3-40 Configure SNMP Parameters Dialog Box

Step 3 Click OK to save the configuration, or click Cancel to close the dialog box and discard any changes.
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Saving a Configuration to a TFTP Server
The startup configuration or the running configuration of a Cisco Catalyst switch can be saved to a TFTP 
server.

Saving the Startup Configuration to a TFTP Server

To save the startup configuration to a TFTP server:

Step 1 Do one of the following:

• Select the Cisco Catalyst switch on the navigation tree and choose File > Save configuration to 
TFTP server (see Figure 3-41).

Figure 3-41 Save Configuration to TFTP Server

• In the navigation tree, right click on the desired Cisco Catalyst switch in the navigation tree and 
choose Save configuration to TFTP server (see Figure 3-42).

Figure 3-42 Save Configuration to TFTP Server Using Right-Click

Step 2 Choose Startup configuration from the Source file type pull-down menu (see Figure 3-43).
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Figure 3-43 Startup Configuration

Step 3 Enter the IP address and filename of the TFTP server.

Step 4 Click OK. A confirmation box appears.

Step 5 Click Yes to start the save process, or click No or Cancel to cancel the operation.

Saving the Running Configuration to a TFTP Server

To save the running configuration to a TFTP server:

Step 1 Do one of the following:

• Select the Cisco Catalyst switch on the navigation tree and choose File > Save configuration to 
TFTP server (see Figure 3-44).

Figure 3-44 Save Configuration to TFTP Server

• Right click on the Cisco Catalyst switch in the navigation tree and choose Save configuration to 
TFTP server (see Figure 3-45).
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Figure 3-45 Save Configuration to TFTP Server Using Right-Click

Step 2 Choose Running configuration from the Source file type pull-down menu (see Figure 3-46).

Figure 3-46 Running Configuration

Step 3 Enter the TFTP server’s IP address and filename.

Step 4 Click OK. A confirmation box appears.

Step 5 Click Yes to start the save process, or click No or Cancel to cancel the operation.

Configuring Gigabit Ethernet Input Ports into a VLAN
Video streams on inbound GE interfaces are included in single VLANs to use network addresses more 
efficiently. The IP addresses and subnet masks configured for each VLAN interface populate the IP 
switching table on the switch with the forwarding information needed to forward the video packets to 
their destination. The number and use of VLANs varies according to the programming and management 
needs of the system operator.

Note Though optional, the use of VLANs for dedicated video traffic is recommended. For a detailed 
discussion, refer to Configuring the Cisco uMG9850 QAM Module.
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Do the following to create a VLAN interface, assign an IP address to the incoming (video source) 
interface, and assign input Gigabit Ethernet (GE) ports to the VLAN. 

Note When it is necessary to create a new VLAN, use the Telnet window to create and enable the VLAN using 
commands found in Cisco Catalyst 4500 Series IOS Software Configuration Guide.

Modifying a VLAN’s Address or Administrative Status

Step 1 Select a Cisco Catalyst switch in the navigation tree and choose Configure > Configure VLAN 
(see Figure 3-47).

Figure 3-47 Configure VLAN Menu

The Configure VLAN dialog box appears (see Figure 3-48).

Figure 3-48 Configure VLAN Dialog Box

Step 2 Choose an existing VLAN from the pull-down menu. If necessary, enter a different IP address and subnet 
mask, or change the Administrative Status using the pull-down menu and choosing up to enable the 
VLAN or down to disable it.

Assigning the Input GE Port to a VLAN

To assign the input gigabit Ethernet (GE) port to a VLAN:

Step 1 Go to Ethernet Port View for a specific GE interface and assign the GE interface of the incoming video 
stream to be included in the VLAN.

Step 2 Set switchport status to switchport by clicking on the check box (see Figure 3-49). Choose no 
switchport by deselecting the switchport check box.

Note Switchport status must be set to switchport mode when LANs are used.
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Figure 3-49 Selecting Switchport

Step 3 Select the VLAN from the VLAN pull-down menu (see Figure 3-50).

Figure 3-50 Selecting the VLAN

Step 4 Click Apply to save all changes and keep the window open, click OK to save the changes and close the 
window, or click Cancel to close the window and discard any changes.

Configuring Video Routing
This configuration task sets up the routing of UDP/IP (video) packets to the Cisco uMG9850. Acting as 
the IP host, the supervisor engine in the switch generally receives video traffic on the IP address 
configured on a VLAN. When the IP address of the selected VLAN is configured as the destination IP 
address of the video packets, any video packet destined for this IP address—and whose destination port 
number matches the UDP range specified for video—is routed to the selected Cisco uMG9850. For 
further discussion of this process, refer to Configuring the Cisco uMG9850 QAM Module.

Step 1 Go to the Video Routing section of Slot View (see Figure 3-51).

Figure 3-51 Configure Video Routing
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Step 2 Select a VLAN and assign an IP address in the same subnet as that assigned to the VLAN in Step 1 in 
the Assigning the Input GE Port to a VLAN section.

Step 3 Specify a minimum and maximum UDP port range or accept the default range.

Note To remove the routing configuration for the module, click the Clear Video Route? selection box.

Step 4 Click Apply to save all changes and keep the window open, click OK to save the changes and close the 
window, or click Cancel to close the window and discard any changes.

Step 5 Repeat these steps for additional VLAN and GE interfaces, as required.

Setting Emulation Mode
You can configure the Cisco uMG9850 to emulate the UDP port mapping of third-party QAM gateways 
that accommodate fixed QAM-channel groups of 8 or 24 channels each. Up to three 8-channel gateways 
or one 24-channel gateway can be emulated. The user’s mappings are converted to the scheme used by 
the Cisco uMG9850, and then are reconverted to the user’s mapping scheme.

To set emulation mode:

Step 1 Go to Slot View, Emulation Mode Section (see Figure 3-52).

Figure 3-52 Emulation Mode Section

Step 2 Select the emulation mode from the pull-down menu (see Figure 3-53). 

Figure 3-53 Selecting Emulation Mode

Values are:

• none—no emulation

• bitwise—for a third-party eight-channel QAM gateway that uses bitwise mapping

• 8-qam-number—for a third-party 8-channel QAM gateway that uses bytewise mapping

• 24-qam-number—for a third-party 24-channel QAM gateway that uses bytewise mapping
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Step 3 Enter the number of IP addresses:

• Bitwise emulation mode supports up to three IP addresses.

• 8-qam-number supports up to three IP addresses.

• 24-qam-number supports only one IP address.

Step 4 Click Apply to save all changes and keep the window open, click OK to save the changes and close the 
window, or click Cancel to close the window and discard any changes.

Setting the Output Frequency and Output Power of the QAM Channels
Each F-connector (QAM port) provides two QAM channels, and the frequency and output power are 
configured for both channels simultaneously. Setting frequency and power for one QAM channel 
automatically sets the appropriate values for the other channel in the same interface.

The Frequency value configures the frequency for the upconverter connected to a QAM port. 
Configuring the frequency for one QAM channel automatically configures the correct frequency for the 
other QAM channel in its upconverter group. The frequency bandwidth of each QAM upconverter block 
is 12 MHz. Consequently, if slot/port.1 is set to frequency f1, then slot/port.2 is automatically set to 
frequency f1 + 6 MHz. Similarly, if slot/port.2 is set to frequency f2, then slot/port.1 is automatically 
set to frequency f2 – 6 MHz.

The power value configures the power level for the upconverter connected to a QAM channel. 
Configuring the output power for one QAM channel automatically configures the same power level for 
the other QAM channel in its upconverter group. If both QAM channels are up, RF power is configured 
to dBmV + 3 dBmV. If only one channel is up, RF power is configured to dBmV. If no channel is up, RF 
power is not configured.

Setting the Output Frequency

To set the output frequency of the QAM channel:

Step 1 Go to QAM Channel View, Channel Information section (see Figure 3-54).

Figure 3-54 Setting the QAM Channel Frequency and Output Power in QAM Channel View

Step 2 Enter the frequency for the selected channel. The frequency range for QAM channel 1 is 50000000 to 
854000000 Hz, and for QAM channel 2 is 56000000 to 860000000.

Step 3 Click Apply to save all changes and keep the window open, click OK to save the changes and close the 
window, or click Cancel to close the window and discard any changes.
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Note For further information regarding the setting of QAM channel frequency and power, refer to Configuring 
the Cisco uMG9850 QAM Module.

Setting the Output Power

To set the QAM channel output power:

Step 1 Go to QAM Channel View, Channel Information section (see Figure 3-54).

Step 2 Enter the QAM channel power. If both QAM channels in an RF port are enabled, the power range is 42 
to 55 dBmV. If only one QAM channel is enabled, the allowed range is 45 to 58 dBmV. The default is 
50 dBmV.

Step 3 Click Apply to save all changes and keep the window open, click OK to save the changes and close the 
window, or click Cancel to close the window and discard any changes.

Setting Up, Editing, and Routing a Video Stream to QAM Channels

Setting the Modulation Format

Each Cisco uMG9850 has six modulator groups, yielding a total of 24 channels per module. Setting the 
modulation format on one QAM channel applies the same format to all four QAM channels in a 
modulator group. For example, QAM channels 5/1.1, 5/1.2, 5/2.1, and 5/2.2.

To set the modulation format for the QAM channel:

Step 1 Go to QAM Channel View, Channel Information section (see Figure 3-54 on page 3-31).

Step 2 Set the modulation format to either qam64 or qam256. The default is qam256.

Note If the FEC interleave level is set to 1, the value 256 is not valid. See the “Configuring the FEC Interleave 
Level and Mode” section that follows.

Step 3 Click Apply to save all changes and keep the window open, click OK to save the changes and close the 
window, or click Cancel to close the window and discard any changes.

Note If level 1 is already selected and it is necessary to change to qam256, first change the FEC Interleave 
level to 2, then click Apply and wait for the configuration change to take effect. Select qam256.
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Configuring the FEC Interleave Level and Mode

The FEC interleave settings set the Reed-Solomon forward error correction (FEC) interleave level and 
mode on a QAM port. Forward error correction reduces bit error rate (BER) in data transmission by 
correcting recovered bit errors in the demodulator. Interleaving is a technique that reorders (in time) 
individual code-word bits with other code-word bits to spread error bursts over many different code 
words. The technique used is compliant with ITU J.83, Annex B.

Setting the interleave level and mode on any of the 12 QAM interfaces (ports) sets the QAM symbol rate 
on that port only. If the interleave level and mode is set on one QAM channel, the same value is applied 
to all four QAM channels in a modulator group. 

Caution The default settings should be satisfactory. Varying the settings can result in an increase in packet 
latency. Always monitor new settings to ensure that resulting BERs are acceptable.

To configure the FEC interleave level and mode:

Step 1 Go to QAM Channel View, Interleave parameters section (see Figure 3-55).

Figure 3-55 Setting the FEC Interleave Level and Mode

Step 2 Choose the interleave level. FEC interleave level can be level1 or level2. The default is level2.

Note If the FEC interleave level is set to level1, the modulation format option of qam256 (256 QAM) is not 
valid. (See the “Setting the Modulation Format” section on page 3-32.)

Step 3 Select the value for FEC interleave mode. The default is 6-FEC-I-128-J-4.

Note The interleave mode can be set only when the interleave level is set to level2 (default).

Step 4 Click Apply to save all changes and keep the window open, click OK to save the changes and close the 
window, or click Cancel to close the window and discard any changes.

Statically Setting Session Timeouts

You can statically set a session timeout for a single Cisco uMG9850 QAM module or for the entire 
Cisco Catalyst switch to determine when the session is closed once packets no longer come into the 
session. You can also set the time following the absence of packets, at which a loss of signal is reported. 
Use global timeouts to address the entire switch or QAM gateway, and slot-level timeouts to address 
an entire module in a given slot. The options and parameters are the same in both cases.
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Note When a session is closed, this means that the Cisco uMG9850 has not received any video packets for the 
given session’s UDP port for the period determined by the module-level or switch-level session close 
timeout. The session no longer exists. 

When a session is inactive, this means that the Cisco uMG9850 or has not received any video packets 
for the given session’s User Datagram Protocol (UDP) port for the period determined by the global or 
slot-level timeout signal-loss. The session still exists, and is listed following a show command. If packets 
start arriving before the timer set by slot-level session-close timeout or global session-close timeout 
counts down, the session becomes active. 

The value for slot-level timeout signal-loss or global timeout signal-loss should always be larger than 
the value configured for jitter. See Configuring Maximum Jitter for a Session, page 3-36.

To configure global timeouts:

Step 1 Go to Chassis View, Global Timers section. (See Figure 3-56.)

Figure 3-56 Setting Global Timers

Step 2 The default value for the Session Close Timeout timer is 10 minutes. To change the setting, enter a new 
value from 1 to 1440 minutes.

Step 3 The default value for the Signal Loss Timeout timer is 5000 milliseconds. To change the setting, enter a 
new value from 200 to 10000 milliseconds.

Step 4 Click Apply to save all changes and keep the window open, click OK to save the changes and close the 
window, or click Cancel to close the window and discard any changes.

To configure slot-level timeouts:

Step 1 Go to Slot View, Slot Level Timeouts section (see Figure 3-57).

Figure 3-57 Setting Slot-Level Timers

Step 2 The default for Session Close Timeout is 10 minutes. To change Session Close Timeout, enter a new 
value from 1 to 1440 minutes.
3-34
Cisco QAM Gateway Manager User Guide, Release 1.1

OL-5763-02



  

Chapter 3      Using Cisco QAM Gateway Manager
  Configuration Tasks
Step 3 The default for Signal Loss timeout is 5000 milliseconds. To change Signal Loss Timeout, enter a new 
value from 200 to 10000 milliseconds.

Step 4 Click Apply to save all changes and keep the window open, click OK to save the changes and close the 
window, or click Cancel to close the window and discard any changes.

Statically Routing a Range of Program Sessions to a QAM Channel (UDP Port Mapping)

The UDP port number of each program session allows each session to be routed to a designated QAM 
channel by default. You can overwrite the default routing (which is signaled by the port number) and 
route a range of program sessions to a QAM channel. 

To route a range of program sessions to a QAM channel:

Step 1 Go to QAM Channel View, Video Sessions Mapping section (see Figure 3-58).

Figure 3-58 Statically Routing a Range of Program Sessions to a QAM Channel

Note Figure 3-58 displays the default values, indicating that the device is using default UDP port 
mapping. If you want to use default port mapping, do not change these values. If you want to 
create a static port map, proceed to Step 2.

Step 2 Enter the maximum number of sessions for this UDP port mapping. The range is 2 to 25. The default is 1.

Step 3 Enter the starting UDP port number to be mapped. The range is 256 to 65535. The default starting port 
number is 0.

Step 4 Enter the starting output program number to be mapped. The range is 1 to 255.

Step 5 To use only even UDP port numbers, reserving odd numbers for Real-Time Control Protocol (RTCP) for 
other purposes, set the value to true. The default is false.

Step 6 To clear video session mapping and revert to the session defaults, click the Clear Video Session 
Mapping check box.

Note This returns the device to default port mapping mode. See Configuring the Cisco uMG9850 
QAM Module for additional information on default port mapping.

Step 7 Click Apply to save all changes and keep the window open, click OK to save the changes and close the 
window, or click Cancel to close the window and discard any changes.
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Note Active video sessions must be stopped while the port map settings are changed. Stop the video sessions 
by temporarily disabling the VLAN bringing video into the switch. After port maps are changed, the 
VLAN can be enabled to allow active video streams.

Video session mapping cannot be changed if the Cisco uMG9850 is set to emulation mode.

Configuring Maximum Jitter for a Session

You can set the maximum allowable network jitter (packet latency variation) for a specified UDP port 
session. This global video setting affects the overall packet latency (at the buffer level) within an entire 
Cisco uMG9850.

Note The jitter option sets the size of a dejittering buffer that absorbs the input jitter. This buffer introduces 
system delay (the time for a packet to enter and leave the Cisco uMG9850). The greater the value of jitter, 
the greater the delay introduced to the output stream. You can change the size of the dejitter buffer at 
either the slot or the session level. Changing it at the slot level changes the default value for jitter. 
(Consequently, for all sessions having the default value for jitter, the jitter value is changed to the new 
value. For sessions that have nondefault jitter values, their current jitter value is maintained.)

To configure maximum jitter:

Step 1 Go to Slot View, Jitter section (see Figure 3-59).

Figure 3-59 Setting the Jitter Specification 

Step 2 The default for jitter is 100 milliseconds. To change the jitter setting, enter a new value from 1 to 300 
milliseconds.

Tip When setting the jitter value (the size of the dejitter buffer), take into consideration the network jitter 
(the inherent jitter introduced at the input of the Cisco uMG9850), and allow for clock tracking. Leave 
approximately 50 milliseconds for clock tracking. For example, if peak-to-peak network jitter is 100 
milliseconds, set the jitter value to 150 milliseconds.

The value for global timeout signal loss or slot-level timeout signal loss should always be larger than the 
value configured for jitter.

Step 3 Click Apply to save all changes and keep the window open, click OK to save the changes and close the 
window, or click Cancel to close the window and discard any changes.
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Setting Up PSI Parameters
You can set up various program-specific information (PSI) parameters, either globally (for the entire 
switch) or on an individual QAM channel.

Note If any sessions are active in the switch, new global Program Association Table (PAT) and Program Map 
Table (PMT) settings are rejected. Active sessions can be suspended while PAT and PMT variables are 
updated by disabling either the VLAN bringing video into the switch or the Ethernet port assigned to 
that VLAN.

Setting PMT and PAT Intervals for the Switch

The Program Association Table (PAT) interval sets the interval at which the PAT is distributed for all 
Cisco uMG9850 modules in the switch. Changing the default rate in this configuration mode overwrites 
the rate for the switch.

The Program Mapping Table (PMT) interval sets the interval at which the PMT is distributed to all 
Cisco uMG9850 modules in the switch. Changing the default rate in this configuration mode overwrites 
the rate for the switch.

To set PMT and PAT intervals for the switch:

Step 1 Go to Chassis View, Global Timers section (see Figure 3-60).

Figure 3-60 Setting PSI Parameters (Switch) in Chassis View

Step 2 The default for the PAT interval is 100 milliseconds. To change the setting, enter a value from 50 to 450 
milliseconds.

Step 3 The default for the PMT interval is 100 milliseconds. To change the setting, enter a value from 50 to 450 
milliseconds.

Step 4 Click Apply to save all changes and keep the window open, click OK to save the changes and close the 
window, or click Cancel to close the window and discard any changes.

Setting PMT and PAT Intervals for a QAM Channel

These parameters set the intervals at which an individual QAM channel distributes the PAT and PMT.

To set these parameters:

Step 1 Go to QAM Channel View, Timers section. (See Figure 3-61)
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Figure 3-61 Setting PSI Parameters

Step 2 The default for the PAT interval is 100 milliseconds. To change the setting, enter a value from 50 to 450 
milliseconds.

Step 3 The default for the PMT interval is 100 milliseconds. To change the setting, enter a value from 50 to 450 
milliseconds.

Step 4 Click Apply to save all changes and keep the window open, click OK to save the changes and close the 
window, or click Cancel to close the window and discard any changes.

Setting TSID and NIT-PID Values

At each hub, each QAM channel must have a unique transport stream ID (TSID). The software checks 
for and guarantees the uniqueness of a TSID within a chassis only. These identifiers specify the TSID 
used to identify transport stream packets sent on the QAM channel and the packet ID (PID) used to 
identify Network Information Table (NIT) packets sent on a QAM port.

Caution It is the responsibility of the operator to avoid TSID conflicts among switches. To see all the TSIDs 
within a switch, look at the QAM Summary View.

The PID for the network information table, or NIT-PID, can be configured from the QAM interface. If 
the NIT-PID is already used as a video, audio, or data PID, the configuration is rejected.

For the transport stream that is to be transmitted over a QAM channel, you must configure the TSID and 
NIT-PID values for that channel.

To set these parameters:

Step 1 Go to QAM Channel View, Identifiers section (see Figure 3-62 on page 3-38).

Figure 3-62 Setting TSID and NIT-PID Values (in QAM Channel View)

Step 2 Set the value of the Transport Stream ID for the QAM channel. The range is 1 to 65535. By default, 
nonconflicting TSIDs are assigned to all modules in a chassis.

Step 3 The default value for the NIT-PID is 16. To change the NIT-PID number, enter a new value from 16 to 
8191.

Step 4 Click Apply to save all changes and keep the window open, click OK to save the changes and close the 
window, or click Cancel to close the window and discard any changes.
3-38
Cisco QAM Gateway Manager User Guide, Release 1.1

OL-5763-02



  

Chapter 3      Using Cisco QAM Gateway Manager
  Configuration Tasks
Configuring Program Data Delivery
The Program Data Delivery (PDD) support provided by the Cisco uMG9850 and QAM module makes 
possible the delivery of electronic program guide (EPG) data, other client data, and navigation data to a 
client application running on the set-top box (STB), enabling the subscriber to browse and select content 
for viewing. (PDD applies to both broadcast video and video on demand.) Program data can be delivered 
to the STB either in-band (on a shared QAM channel with digital video services) or out-of-band (on a 
DOCSIS or QPSK channel). When delivered in-band, the program data is typically delivered as private 
data in a low-bitrate MPEG program with multiple PIDS. Most cable systems deliver such data through 
one or more in-band carousels to which the client tunes at startup, as well as during program navigation, 
as needed.

Caution Keep in mind that the Cisco uMG9850 remaps the PIDs of incoming sessions to ensure uniqueness in 
the outgoing MPTS (except for pass-through sessions, where PID remapping is not necessary). When 
PIDs are remapped, any references to PID values in PDD streams become invalid. 

Program-related information is streamed from a server, and can be delivered to subscribers in-band 
through the Cisco uMG9850. The data is encapsulated as SPTS MPEG-2 streams delivered by means of 
IP/UDP, as regular sessions are. However, program data, unlike a normal SPTS, can be delivered by 
means of multicast or unicast.

To maximize the efficiency of the IP network, a single copy of a program data stream is sent to a 
Cisco uMG9850 QAM channel, where the stream can be cloned to one, several, or all QAM channels. 
Also, the program data stream may contain program clock references (PCRs), or may be a pure data 
stream without timing information. To support PDD and similar functionality, the Cisco uMG9850 
remaps the PID, either by using the default map or a user-specified configuration.

Caution You must disable any traffic being routed to the Cisco uMG9850 QAM module before creating or 
changing any cloned multicast or unicast sessions. You cannot make changes if sessions are active. For 
unicast traffic, temporarily disable the VLAN before making changes. For multicast traffic, temporarily 
disable the GE port before making changes.

For additional PDD information, refer to “Configuring Program Data Delivery (PDD) Features” in 
Configuring the Cisco uMG9850 QAM Module.

Cloning a Unicast UDP Session to One, Several, or All QAM Channels on a Module (PDD)

You can clone (map) a unicast input UDP session to one, several, or all QAM channels on a 
Cisco uMG9850 with a specified output-program number. Program numbers can vary. 

Caution You must disable any traffic being routed to the Cisco uMG9850 QAM module before creating or 
changing any cloned unicast sessions. You cannot make changes if sessions are active. For unicast traffic, 
temporarily disable the VLAN before making changes. 

Note To clone default UDP ports, you must use program 26 and above.

Step 1 Go to Slot View, All Session Information section.
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Step 2 Click Create. The Create Session dialog box appears. (See Figure 3-63.)

Figure 3-63 Create Session Dialog Box

Step 3 Perform the following.

Cloning a Single Copy to a Specified QAM Channel

Caution You must disable any traffic being routed to the Cisco uMG9850 QAM module before creating or 
changing any cloned unicast sessions. You cannot make changes if sessions are active. For unicast traffic, 
temporarily disable the VLAN before making changes.

To clone a single copy of a PDD stream or unicast session to a specified QAM channel on a 
Cisco uMG9850, with a specified output-program number:

Step 1 Ensure that the Unicast button is selected.

Step 2 Select the QAM channel and select the Clone check box for that channel (see Figure 3-64 on page 3-41).
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Figure 3-64 Selecting the QAM Channel

Step 3 In the Create Clonable Session box (see Figure 3-65), enter the output program number. The range is 
1 to 255.

Figure 3-65 Output Program Number

Step 4 In the Unicast box (see Figure 3-66), either select a UDP port number from the pull-down menu or enter 
a new UDP port number. The range is 49152 to 65535.

Figure 3-66 UDP Port Number

Step 5 If necessary, repeat steps 1 and 2 for each additional session and program to be mapped.
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Step 6 Click Apply to save all changes and keep the window open, click OK to save the changes and close the 
window, or click Cancel to close the window and discard any changes.

Cloning a Single Copy to All 24 QAM Channels

Caution You must disable any traffic being routed to the Cisco uMG9850 QAM module before creating or 
changing any cloned unicast sessions. You cannot make changes if sessions are active. For unicast traffic, 
temporarily disable the VLAN before making changes.

To clone a single copy of a PDD stream or unicast session to all 24 QAM channels on a Cisco uMG9850 
with a specified output program number, do the following:

Step 1 Ensure that the Unicast button is selected.

Step 2 Click the All QAMs check box.

Figure 3-67 All QAMs Check Box

Step 3 In the Create Clonable Session box (see Figure 3-65), enter the output program number. The range is 
1 to 255.

Figure 3-68 Output Program Number

Step 4 In the Unicast box (see Figure 3-66), either select a UDP port number from the pull-down menu or enter 
a new UDP port number. The range is 49152 to 65535.
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Figure 3-69 UDP Port Number

Step 5 Click Apply to save all changes and keep the window open, click OK to save the changes and close the 
window, or click Cancel to close the window and discard any changes.

Modifying or Deleting a Unicast Session

Caution You must disable any traffic being routed to the Cisco uMG9850 QAM module before creating or 
changing any cloned unicast sessions. You cannot make changes if sessions are active. For unicast traffic, 
temporarily disable the VLAN before making changes. 

To modify a unicast session:

Step 1 Select the unicast entry you want to modify by selecting the UDP port number from the pull-down menu.

Step 2 Make any changes necessary. (To remove a QAM, deselect that QAM in the QAM list.)

Step 3 Click Apply.

To delete a unicast session:

Step 1 Deselect all the selected QAMs.

Step 2 Click Apply.

Cloning a PDD Stream or Multicast UDP Session to one, Several, or All QAM Channels on a Module

You can clone a PDD stream or multicast session to one, several, or all QAM channels on a Cisco 
uMG9850. It as assumed that the multicast source is on one VLAN, and the Cisco uMG9850 is on 
another VLAN.

Caution You must disable any traffic being routed to the Cisco uMG9850 QAM module before creating or 
changing any cloned multicast sessions. You cannot make changes if sessions are active. For multicast 
traffic, temporarily disable the GE port before making changes.

Do the following:
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Step 1 Click Create in the All Sessions Information section of Slot View. The Create Clonable Session dialog 
appears (see Figure 3-63 on page 3-40).

Step 2 Click the Multicast button (see Figure 3-70).

Figure 3-70 Create Clonable Session—Multicast

Step 3 In the Multicast box, select or enter the source IP address and multicast destination IP address (see 
Figure 3-71).

Note The range of multicast addresses is 224.0.0.0 to 239.255.255.255.

Figure 3-71 Source and Destination IP Address

Step 4 Select one or more output QAM channels (see Figure 3-64 on page 3-41), or click All QAMs to select 
all QAM channels.

Step 5 Click Apply to save all changes and keep the window open, click OK to save the changes and close the 
window, or click Cancel to close the window and discard any changes.

Modifying or Deleting a Multicast Session

Caution You must disable any traffic being routed to the Cisco uMG9850 QAM module before creating or 
changing any cloned multicast sessions. You cannot make changes if sessions are active. For multicast 
traffic, temporarily disable the GE port before making changes.
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To modify a multicast session

Step 1 Select the multicast entry you want to modify by selecting the source and destination IP addresses from 
the pull-down menu.

Step 2 Make any changes necessary. (To remove a QAM, deselect that QAM in the QAM list.)

Step 3 Click Apply.

To delete a multicast session:

Step 1 Deselect all the selected QAMs.

Step 2 Click Apply.

Setting MPTS Passthrough

Digital broadcast programs are typically delivered in a multiple program transport stream (MPTS) from 
a statistical multiplexer (or other video source) to the Cisco uMG9850. The Cisco uMG9850 passes the 
MPTS through to the set-top boxes without remultiplexing the video streams. The Cisco uMG9850 may 
update the PCR or TSID information in the MPTS as necessary to output a valid transport stream. The 
Cisco uMG9850 outputs the MPTS on one or more QAM channels based on the UDP port map (for 
unicast sessions) or multicast group address (for multicast sessions) of the incoming stream.

To enable MPTS passthrough on a selected Cisco uMG9850, click the Passthrough selection box (see 
Figure 3-72). This causes an MPTS multicast session to be passed through to the selected QAM 
channels. To disable MPTS passthrough, click the Passthrough selection box to remove the check mark, 
then click Apply.

Figure 3-72 Selecting MPTS Pass-Through

In the QAM to Clone section (see Figure 3-64), click to select the QAM channels to allow passthrough. 
To disallow passthrough, deselect the QAM channels, then click Apply.
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Setting No-Snoop

Operators can inject externally generated service information (SI) packets onto an output QAM channel. 
When the Cisco uMG9850 is so configured, it does not snoop (no snoop) or modify any of the incoming 
packets. Rather, it simply takes each packet and inserts it into the outgoing channel along with the other 
VoD programs.

Note The No Snoop setting is not available for channels configured for MPTS pass-through.

To enable or disable No Snoop, click the No Snoop selection box (see Figure 3-73 on page 3-46).

Figure 3-73 Selecting No Snoop

Emulation Mode

The Emulation Mode section (see Figure 3-74) is read-only and can be used for reference. To change 
these values, go to Slot View.

Figure 3-74 Emulation Mode (Read-Only)
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Monitoring

This chapter provides information on the monitoring of configured Cisco uMG9850 modules, and the 
Cisco Catalyst switches in which they are installed, to ensure proper operation of the network. 
Information can be displayed using Cisco QAM Gateway Manager views and by using the command line 
interface within the application’s Telnet window.

• Navigation Tree, page 4-1

• Chassis View, page 4-2

• Slot View, page 4-3

• QAM Channel Summary View, page 4-4

• Telnet—CLI show commands, page 4-5

• Configuring the ASI Port for QAM Channel Routing, page 4-7

• Notification History Table, page 4-8

• Application Display Messages, page 4-10

Navigation Tree
Using the navigation tree, you can observe the status of all QAM, Ethernet, and ASI ports (see Figure 4-1 
on page 4-2). When a port’s administrative or operating status is down, an X appears on the icon 
representing that port. To see the details for a specific port, double-click on the port. The detail QAM, 
Ethernet, or ASI port view will appear.
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Figure 4-1 Navigation Tree

Chassis View
The Chassis Status section of the Chassis View displays the components of the device. For each device, 
each slot number is listed along with the name of the card in that slot, the card type, and the operating 
status. Power supplies and fan tray information also is included in the component list. (See Figure 4-2.)

Figure 4-2 Chassis Status
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Slot View
Using the Slot View QAM Channels Summary Status Table (see Figure 4-3 on page 4-3), you can 
monitor the status of all the QAM channels in a specific slot. For each QAM channel, the administrative 
and link status (green for up and red for down), and the number of sessions on that channel are listed.

Figure 4-3 Slot View QAM Channels Summary Status

The Ethernet Ports and ASI Port Summary Status Table lists the administrative and link status for 
Ethernet and ASI ports on the slot—green for up and red for down. (See Figure 4-4.) Double-click on 
the Ethernet or ASI ports to access the Ethernet or ASI port views.
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Figure 4-4 Slot View Ethernet Ports and ASI Port Summary Status

QAM Channel Summary View
The QAM Summary View (see Figure 4-5) shows on one screen the current configurations for all QAMs 
in a slot for the following parameters:

• Administrative status

• RF frequency

• Power

• Modulation format

• Interleaver level

• Interleaver mode

• TSID

• PAT interval

• PMT interval

Figure 4-5 QAM Channel Summary View
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Note This view also can be used to configure these parameters. 

Tip Right-click on a field to copy a value to all other fields in that column.

Telnet—CLI show commands
A variety of show commands provides additional information about the configuration and operation of 
the Cisco Catalyst switches managed by Cisco QAM Gateway Manager. These commands can be entered 
using the CLI in the Telnet window. For instructions on how to use the Telnet window, see the “Using 
the Telnet Window” section on page 3-16. For further information regarding the command-line interface 
and the commands themselves, including sample output, refer to Configuring the uMG9850 QAM 
Module, and Cisco Catalyst switch documentation listed in the “Related Documentation” section on 
page ix.

Table 4-1 describes common show commands for the Cisco Catalyst switch that can be useful for 
determining status of the switch related to video configuration and operation.

Table 4-1 Cisco Catalyst Switch Show Commands

Show Command Description

show interface asi interface video View information about a single QAM channel routed to the output 
ASI interface:

• Port status 

• QAM channel routed to the ASI interface

• Program details (if available).

show interface qam interface video View video information about both channels on an output QAM 
interface: 

• Number of active QAMs and QAM status (up/down)

• QAM modulator group number

• TSID, NIT PID, and PSI interface values

• Upconverter frequency and power, and QAM modulation type

• Port error status

show interface qam interface.qam video View video information about a single QAM channel:

• Number of programs and active sessions

• TSID and NIT-PID information

• Packets per second and bit rate through the channel

• Active trick modes

• Video and audio format for each session

• QAM error status (such as oversubscribed, underflow)
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show interface qam interface.qam video portmap View information about the UDP portmaps on an output QAM 
interface:

• UDP port number, in decimal and hexadecimal

• Output program number

show video slot View information related to the modulator groups, including frequency 
and power:

• Active modulator groups

• Upconverter frequency and power for each channel

show video slot psi session View program-specific information (PSI) related to the input for a 
selected Cisco uMG9850:

• UDP port number and session status

• PSI parameters

• Source program

• Streams and stream types

show video slot psi session multicast 
source-address src-ip dest-address dst-ip

View multicast program-specific information (PSI) related to the input 
for a selected Cisco uMG9850.

show video slot route View video route information related to the input for a selected Cisco 
uMG9850:

• VLAN number and ip-address

show video slot session multicast View a variety of video details related to sessions for a selected Cisco 
uMG9850:

• For all sessions:

– All session information

– Input errors

– CC errors

– Sync loss

– Sender information (source IP address and UDP for each 
session)

• For a specified session:

– Session start time

– Source IP address

– Input CC errors

– Jitter (peak, average)

– Source data rate

show video slot ts_table View the transport stream ID (TSID) table for each QAM channel for 
a selected Cisco uMG9850:

• TSID for each QAM channel

Table 4-1 Cisco Catalyst Switch Show Commands (continued)

Show Command Description
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Configuring the ASI Port for QAM Channel Routing
Using the Asynchronous serial interface (ASI) port, you can set or change the gap spacing of data bytes 
in the ASI port output and route the input of a single QAM channel to the ASI port to monitor the 
channel. 

Note Routing the input of a QAM channel to the ASI port does not disrupt the RF output.

Setting the Byte-Gap Value (S-Rate) of the ASI Port
You can change the gap spacing of the data bytes in the output of the ASI port. The S-rate is the spacing 
of data bytes (the number of ASI transport null bytes between the data bytes) within the output transport 
stream. If there is not a sufficient number of data bytes in the stream, padding the stream with null bytes 
maintains the signal voltage and integrity. 

To set byte gap:

Step 1 Go to ASI Port View. (See Figure 4-6.)

Figure 4-6 Setting the Byte-Gap Value

Step 2 Enter a value for byte gap. Values are 1 to 4.

Step 3 Click Apply to save all changes and keep the window open, click OK to save the changes and close the 
window, or click Cancel to close the window without any changes.

show video slot version View software and hardware version information for a selected 
Cisco uMG9850:

• Hardware details

• Software details

show {running-config | startup-config} View running configuration or startup configuration for the device.

Table 4-1 Cisco Catalyst Switch Show Commands (continued)

Show Command Description
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Routing the Output of a QAM Channel to the ASI Port
You can route the output of a QAM channel (a single program) to the asynchronous serial interface (ASI) 
port (in ASI signaling format), to monitor the output of the channel. Use a video decoder to view the 
selected program. 

Note For Cisco uMG9850 QAM modules, the ASI port is always addressed as slot/15.

To configure this parameter:

Step 1 Go to ASI Port View (see Figure 4-6).

Step 2 In the QAM Routed menu, choose the QAM whose output you want directed to the ASI port.

Step 3 Click Apply to save all changes and keep the window open, click OK to save the changes and close the 
window, or click Cancel to close the window without any changes.

Notification History Table

Setting and Monitoring Utilization Thresholds
It is possible that a given QAM channel can be either overwhelmed or underutilized. To monitor and 
correct for this, you can set both minimum and maximum bandwidth-utilization thresholds for video 
streams over a QAM channel. If the percentage of QAM bandwidth being used is below the value for the 
low utilization threshold, then the QAM channel is being underutilized. If the percentage of QAM 
bandwidth being used is above the value for high utilization threshold, then the QAM channel is being 
overutilized.

Note The high utilization threshold must be greater than the low utilization threshold.

To specify the high and low utilization thresholds for video streams:

Step 1 Go to QAM Channel View, Utilization section (see Figure 4-7).

Figure 4-7 Low and High Threshold Utilization Settings

Step 2 Set the Low Utilization Threshold. The default is 0%. To change the setting, enter a new value from 
0 to 95%.

Step 3 Set the high Utilization Threshold. The default is 75%. To change the setting, enter a new value from 
5 to 95%.
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Step 4 Click Apply to save all changes and keep the window open, click OK to close the window and save all 
changes, or click Cancel to close the window and discard all changes.

If the percentage of QAM bandwidth being used drops below the low threshold or climbs above the high 
threshold, or invalid PSI data is detected, an entry appears in the Notification History table (see 
Figure 4-8).

Figure 4-8 Notification History Table

Warning Messages in the Notification History Table

Error Message The video session nnnn has invalid PSI data

Explanation Data arriving at a VoD-enabled port does not conform to standard MPEG data. MPEG 
data must have PSI tables embedded within it for a receiver to correctly map the contents.

Error Message Utilization has gone above the higher threshold value

Explanation The QAM channel is being overutilized.

Error Message Utilization has fallen below the lower threshold value.

Explanation The QAM channel is being underutilized.
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Application Display Messages
The following is a list of typical error messages that Cisco QAM Gateway Manager may display. The 
exact wording of some messages may vary, and messages may appear that are not shown below.

Apply changes?

Configuration changes have been made. Do you want to copy them to the running configuration?

An unknown error occurred while configuring parameter on device at ip-address

An error has occurred while configuring the named parameter. Be sure the values entered are correct 
and try the operation again.

Cannot change PMT rate, programs are present.

The Program Mapping Table (PMT) can be set using the Chassis view, but cannot be changed while 
there are active video sessions being sent to that module. Disable the video session by disabling the 
GE port used by the VLAN assigned to the video route. Make the necessary changes, then re-enable 
the GE port.

Cisco QAM Gateway Manager is already running.

You have launched more than one instance of the application. Ensure that all but one instance has 
been closed.

Configuration loaded to device at ip-address

The configuration load operation has completed successfully.

Configuration loaded to device at ip-address from TFTP server ip-address.

The configuration from the specified TFTP server has successfully loaded to the device at the 
specified IP address.

Configuration successful.

The configuration has been copied to the running configuration of the device.

Device ip-address has changed. All open screens except chassis view will be closed for the device.

Since the information for the device has changed, all open screens may be invalid. Reopen the 
screens to see the updated information.

Device ip-address is not reachable or has timed out.

Cisco QAM Gateway Manager is unable to access the device at the specified address. This could be 
due to a reload taking place or the device is off-line. Contact your system administrator.

Device at ip-address inaccessible. Continue refreshing?

A device in the history file is not accessible, or the device is not reachable during a refresh. Do you 
want to keep trying to refresh this device?

Device at ip-address inaccessible. Keep in navigation tree?

Select Yes to keep the device in the Navigation Tree and mark it as offline. Select No to remove it 
from the Navigation Tree.

Device at ip-address has timed out. Continue refreshing?

The device has timed out during a refresh. Do you want to keep trying to refresh this device?

Enter file name.

There was an error while loading a configuration from the TFTP server. File name is required.
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Enter value between lower value and upper value.

An out of range value has been entered. Enter a new value between these two.

error at ip-address. Unable to load configuration from TFTP server at ip-address

Cisco QAM Gateway Manager cannot load a configuration from the IP address specified in the Load 
Configuration dialog box. Verify that the address of the TFTP server is correct and that the file that 
you want to load is present.

Error while copying configuration from TFTP Server ip-address.

Error while copying configuration to TFTP Server.

Cisco QAM Gateway Manager cannot successfully copy a file from the TFTP server at the specified 
IP address. Verify that the IP address is correct and that the file to be loaded is in the TFTP server 
directory.

Integer value expected, Refer to the help!

A non-integer value has been entered in an integer field. Click Help and review the valid entries for 
the field.

Invalid session close timeout value.

An invalid value has been entered for Session Close Timeout. Enter a value from 1 to 1440 minutes.

Invalid Signal loss timeout value.

An invalid value has been entered for Signal Loss Timeout. Enter a value from 200 to 10000 
milliseconds.

Invalid IP address/ host name or community string.

Device is being added and Cisco QAM Gateway Manager cannot make an SNMP query to the 
device.

Multicast Session Source ip-address destination ip-address is active. Shutdown VLAN before 
removing this session.

Self-explanatory.

No video session map available to clear!

You have already cleared the video route or no video route was configured.

Number of active sessions have changed in device at ip-address. Sessions will be rediscovered.

The number of active sessions has changed in the device at the specified address. The sessions will 
be re-evaluated.

Number of sessions have changed in device at ip-address. Sessions will be rediscovered.

The number of sessions has changed in the device at the specified address. The sessions will be 
re-evaluated.

parameter-name value is out of range for qam Channel.

An invalid parameter value has been entered. Click Help and review valid parameter ranges.

port-value UDP port is already in use in ip-address

A UDP port is already in use for one line card. Look in the CLI configuration for commands that 
use UDP port numbers. Look for conflicts and disable the unneeded ones.
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Route IP ip-address overlays with Slot slot-number IP ip-address

The IP address might be in use by another VLAN. Make sure that the IP address is not being used 
by another VLAN or video route command.

Running configuration of device at ip-address saved.

The running configuration of the specified device was successfully saved to a TFTP server.

Running configuration saved to startup configuration for device at ip-address.

The running configuration of the specified device was successfully saved to the device’s startup 
configuration.

Select a QAM gateway from the navigation tree.

View > Chassis was chosen before a device was selected in the navigation tree.

Select a device.

File > Load Configuration or File > Save Configuration to TFTP server was chosen before a 
device was selected in the navigation tree.

Select a Cisco Catalyst switch in navigation tree.

This function requires selection of a Cisco Catalyst Switch.

Select a uMG9850 slot.

View > Slot or View > All Sessions was chosen before a slot was selected in the navigation tree.

Select a uMG9850 module to launch the session view.

View > Sessions or View > Multicast sessions was chosen before a slot was selected in the 
navigation tree.

Session close timeout value out of range!

An invalid value has been entered for Session Close Timeout. Enter a value from 1 to 1440 minutes.

Signal loss timeout value out of range!

An invalid value has been entered for Signal Loss Timeout. Enter a value from 200 to 10000 
milliseconds.

SNMP error occurred while configuring parameter on device at ip-address. Reason: reason

An SNMP error has occurred during configuration. Possible reasons are:

Request timed out.

SNMP response exceeds size limitation.

Variable name not found in MIB.

MIB object/instance is read-only.

Object value cannot be retrieved.

Invalid community string or access credentials.

Value/type mismatch.

Value length exceeded.

Wrong encoding for object.

Value not compatible with MIB.

Trying to create or set a nonexistent variable.

MIB variable may be in inconsistent state, not accepting set requests.
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System resources unavailable for set/get operations.

Set commit has failed.

Set operation has failed, agent unable to roll back.

SNMP command cannot be authenticated, or incorrect community string found.

MIB object not responding to set operations: read-only access or incorrect community string.

Set operation failed: variable in inconsistent state.

SNMP Error: Unknown host.

The host is not recognized.

SNMP Query timed out, check the community string of the device!

The device cannot be added to the navigation tree, possibly because of an invalid community string. 
Check the community string and try the operation again.

SNMP polling interval configured successfully.

The polling interval for the managed devices has been successfully set.

Some fields are empty. Please fill the missing values and try again.

The configuration fields have not all been completed. Click Help to determine which fields must be 
completed as well as the ranges and default values for those fields.

Startup configuration of device at ip-address saved to TFTP server ip-address.

The startup configuration of the specified device was successfully saved to the specified TFTP 
server.

The device at address is not a uMG9800 device.

The device being added is not a Cisco Catalyst switch with a Cisco uMG9850 installed. Only those 
devices can be manager by Cisco QAM Gateway Manager.

There are no changes in screen to be updated.

An update has been requested but there have been no changes made.

Too many views open. Please close unneeded views.

The maximum number of simultaneously open views has been reached. In order to open additional 
views, some of the currently unneeded views must be closed.

Unable to load configuration from TFTP server on device ip-address from ip-address

The Load Configuration from TFTP server operation has failed. Check ip addresses for the device 
and the TFTP server and try the operation again.

Unable to save running configuration to startup configuration for device ip-address. Reason: 
SNMP Timeout or Invalid access error.

The save operation has failed. Be sure that the proper privilege levels are in effect and try the 
operation again.

Unable to save startup config of ip-address to ip-address (TFTP server). Reason: error string

An error has occurred while the startup configuration was being saved to the TFTP server. When 
possible, correct the error and try the operation again.

Unknown error occurred while refreshing device at ip-address. Continue refreshing?

An undetermined error occurred while refreshing the named device. Do you want to keep trying to 
refresh this device?
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Unknown error occurred while refreshing device at ip-address inaccessible. Continue refreshing?

An unknown error has occurred during a refresh, and the device is currently inaccessible. Do you 
want to keep trying to refresh this device?

uMG9850 is in emulation mode; sessions cannot be mapped.

The uMG9850 is running in emulation mode. Video sessions mapping cannot be done in emulation 
mode.

Unknown Error–Device ip-address is inaccessible. Keep in the Navigation Tree?

Select Yes to keep the device in the Navigation Tree and mark it as offline. Select No to remove it 
from the Navigation Tree.

Value out of range. Refer to the help!

The value entered is not within the specified range. Click Help to review valid entries for this 
function.

Video Route VLAN vlan number overlays with Slot slot number’s VLAN.

In a video route configuration, an attempt was made to assign an IP address or VLAN number 
already in use. The IP address and the VLAN must be unique for each video route configuration.
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