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About This Guide

This guide provides the necessary information to help you use Cisco QAM Gateway Manager 
(Cisco QGM) to configure and monitor Cisco uMG9820 QAM gateways and Cisco uMG9850 QAM 
modules in Cisco Catalyst 4500 series switches.

This section discusses the following major topics:

• Document Audience

• Document Organization

• Document Conventions

• Related Documentation

• Obtaining Documentation

• Documentation Feedback

• Obtaining Technical Assistance

• Obtaining Additional Publications and Information
vii
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About This Guide
Document Audience
Document Audience
This guide is a reference resource for network managers, system administrators responsible for 
managing the video network, and network analysts responsible for configuring the network.

Document Organization
This document is organized as shown in Table 1.

Document Conventions
The following conventions are used in this document:

Table 1 Document Organization

Chapter/Appendix Title Description

Chapter 1, “Introduction to Cisco QAM Gateway 
Manager”

Provides a product overview and describes basic 
concepts and tasks.

Chapter 2, “Installing Cisco QAM Gateway 
Manager”

Outlines minimum system requirements and 
set-up requirements.

Chapter 3, “Using Cisco QAM Gateway 
Manager”

Describes the use of Cisco QAM Gateway 
Manager for configuration of Cisco QAM 
Gateway devices.

Chapter 4, “Monitoring Cisco QAM Gateway 
Devices”

Provides information on monitoring configured 
devices and lists application display messages.

Convention Description

boldface font Commands and keywords are in boldface.

italic font Arguments for which you supply values are in italics.

[ ] Elements in square brackets are optional.

{x | y | z} Alternative, mutually exclusive, keywords are grouped in braces and separated 
by vertical bars.

[x | y | z] Optional alternative keywords are grouped in brackets and separated by 
vertical bars.

string A nonquoted set of characters. Do not use quotation marks around the string or 
the string will include the quotation marks.

screen font Terminal sessions and information the system displays are in screen font.

boldface screen 

font
Information you must enter is in boldface screen font.

italic screen font Arguments for which you supply values are in italic screen font.
viii
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About This Guide
Related Documentation
Tip Means the following information might help you solve a problem.

Note Means reader take note. Notes contain helpful suggestions or references to material not covered in the 
publication.

Caution Means reader be careful. In this situation, you might do something that could result in corruption of data.

Related Documentation
The following documentation provides information relating to the installation, configuration, and 
operation of the Cisco uMG9820 QAM Gateway, Cisco uMG9850 QAM Module, Cisco Catalyst 4500 
series switches, and Cisco QAM Gateway Manager.

Cisco uMG9820 QAM Gateway
• Cisco uMG9820 QAM Gateway Installation and Configuration Guide for Release 2.2

http://www.cisco.com/univercd/cc/td/doc/product/cable/vod/umg9820/9820icg2/index.htm

• Release Notes for Cisco uMG9820 QAM Gateway, Release 2.2

http://www.cisco.com/univercd/cc/td/doc/product/cable/vod/umg9820/9820rn20.htm

• Cisco uMG9820 QAM Gateway Regulatory Compliance and Safety Information

http://www.cisco.com/univercd/cc/td/doc/product/cable/vod/umg9820/9820rcsi.htm

• Quick Start Guide—Rack-Mounting the Cisco uMG9820 QAM Gateway

http://www.cisco.com/univercd/cc/td/doc/product/cable/vod/umg9820/9820rkmt.pdf

• Quick Start Guide—Removing and Replacing a Fan Assembly in the Cisco uMG9820 QAM Gateway

http://www.cisco.com/univercd/cc/td/doc/product/cable/vod/umg9820/20fanfru.pdf

• Quick Start Guide—Removing and Replacing a Processor Card in the Cisco uMG9820 QAM 
Gateway

http://www.cisco.com/univercd/cc/td/doc/product/cable/vod/umg9820/20profru.pdf

^ The symbol ^ represents the key labeled Control—for example, the key 
combination ^D in a screen display means hold down the Control key while 
you press the D key.

< > Nonprinting characters, such as passwords, are in angle brackets in contexts 
where italics are not available. Angle brackets are also used for variables.

[ ] Default responses to system prompts are in square brackets.

!, # An exclamation point (!) or a pound sign (#) at the beginning of a line of code 
indicates a comment line.

Convention Description
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About This Guide
Related Documentation
• Quick Start Guide—Removing and Replacing a Power Supply in the Cisco uMG9820 QAM Gateway

http://www.cisco.com/univercd/cc/td/doc/product/cable/vod/umg9820/20pwrfru.pdf

• Quick Start Guide—Removing and Replacing a QAM Card in the Cisco uMG9820 QAM Gateway

http://www.cisco.com/univercd/cc/td/doc/product/cable/vod/umg9820/20qamfru.pdf

Cisco uMG9850 QAM Module
• Quick Start Guide—Installing the Cisco uMG9850 QAM Module

http://www.cisco.com/univercd/cc/td/doc/product/cable/vod/umg9850/9850qsg.htm

• Configuring the Cisco uMG9850 QAM Module

http://www.cisco.com/univercd/cc/td/doc/product/cable/vod/umg9850/9850fm.htm

• Release Notes for the Cisco uMG9850 QAM Module, Cisco IOS Release 12.1(20)EU1

http://www.cisco.com/univercd/cc/td/doc/product/cable/vod/umg9850/9850rn11.htm

• Cisco uMG9850 QAM Module Compatibility Matrix

http://www.cisco.com/univercd/cc/td/doc/product/cable/vod/umg9850/9850cmx1.htm

Cisco Catalyst 4500 Series Switches
• Catalyst 4500 Series Installation Guide

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat4000/hw_doc/4500inst/index.htm

• Catalyst 4500 Series Module Installation Guide

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat4000/hw_doc/mod_inst/index.htm

• Catalyst 4500 Series Regulatory Compliance and Safety Information

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat4000/hw_doc/78_13233.htm

• Catalyst 4500 Series Supervisor Engines and Switching Modules Installation Note

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat4000/inst_nts/gmdcf_nt.htm

• Installation and Configuration Note for the Catalyst 4500 Series Supervisor Engine IV

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat4000/inst_nts/78_14496.htm

• Installation Note for Fan Tray Assemblies in Catalyst 4500 Series Switches

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat4000/inst_nts/78_15335.htm

• Catalyst 4500 Series Switch Cisco IOS Command Reference, 12.1(20)EW

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat4000/12_1_20/cmdref/index.htm

• Catalyst 4500 Series Switch Cisco IOS Software Configuration Guide, 12.1(20)EW

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat4000/12_1_20/config/index.htm

• Catalyst 4500 Series Switch Cisco IOS System Message Guide, 12.1(20)EW

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat4000/12_1_20/message/index.htm

• Release Notes for the Catalyst 4500 Series Switch, Cisco IOS, 12.1(20)EW

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat4000/relnotes/ol_2170.htm
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Obtaining Documentation
Cisco QAM Gateway Manager
• Release Notes for Cisco QAM Gateway Manager, Release 1.0

http://://www.cisco.com/univercd/cc/td/doc/product/cable/vod/cqgm/cqmrn.htm

Obtaining Documentation
Cisco documentation and additional literature are available on Cisco.com. Cisco also provides several 
ways to obtain technical assistance and other technical resources. These sections explain how to obtain 
technical information from Cisco Systems.

Cisco.com
You can access the most current Cisco documentation at this URL:

http://www.cisco.com/univercd/home/home.htm

You can access the Cisco website at this URL:

http://www.cisco.com

You can access international Cisco websites at this URL:

http://www.cisco.com/public/countries_languages.shtml

Ordering Documentation
You can find instructions for ordering documentation at this URL:

http://www.cisco.com/univercd/cc/td/doc/es_inpck/pdi.htm

You can order Cisco documentation in these ways:

• Registered Cisco.com users (Cisco direct customers) can order Cisco product documentation from 
the Ordering tool:

http://www.cisco.com/en/US/partner/ordering/index.shtml

• Nonregistered Cisco.com users can order documentation through a local account representative by 
calling Cisco Systems Corporate Headquarters (California, USA) at 408 526-7208 or, elsewhere in 
North America, by calling 800 553-NETS (6387).

Documentation Feedback
You can send comments about technical documentation to bug-doc@cisco.com.
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About This Guide
Obtaining Technical Assistance
You can submit comments by using the response card (if present) behind the front cover of your 
document or by writing to the following address:

Cisco Systems
Attn: Customer Document Ordering
170 West Tasman Drive
San Jose, CA 95134-9883

We appreciate your comments.

Obtaining Technical Assistance
For all customers, partners, resellers, and distributors who hold valid Cisco service contracts, Cisco 
Technical Support provides 24-hour-a-day, award-winning technical assistance. The Cisco Technical 
Support Website on Cisco.com features extensive online support resources. In addition, Cisco Technical 
Assistance Center (TAC) engineers provide telephone support. If you do not hold a valid Cisco service 
contract, contact your reseller.

Cisco Technical Support Website
The Cisco Technical Support Website provides online documents and tools for troubleshooting and 
resolving technical issues with Cisco products and technologies. The website is available 24 hours a day, 
365 days a year at this URL:

http://www.cisco.com/techsupport

Access to all tools on the Cisco Technical Support Website requires a Cisco.com user ID and password. 
If you have a valid service contract but do not have a user ID or password, you can register at this URL:

http://tools.cisco.com/RPF/register/register.do

Submitting a Service Request
Using the online TAC Service Request Tool is the fastest way to open S3 and S4 service requests. (S3 
and S4 service requests are those in which your network is minimally impaired or for which you require 
product information.) After you describe your situation, the TAC Service Request Tool automatically 
provides recommended solutions. If your issue is not resolved using the recommended resources, your 
service request will be assigned to a Cisco TAC engineer. The TAC Service Request Tool is located at 
this URL:

http://www.cisco.com/techsupport/servicerequest

For S1 or S2 service requests or if you do not have Internet access, contact the Cisco TAC by telephone. 
(S1 or S2 service requests are those in which your production network is down or severely degraded.) 
Cisco TAC engineers are assigned immediately to S1 and S2 service requests to help keep your business 
operations running smoothly.

To open a service request by telephone, use one of the following numbers:

Asia-Pacific: +61 2 8446 7411 (Australia: 1 800 805 227)
EMEA: +32 2 704 55 55
USA: 1 800 553 2447
xii
Cisco QAM Gateway Manager User Guide, Release 1.0

OL-5763-01

http://www.cisco.com/techsupport
http://tools.cisco.com/RPF/register/register.do
http://www.cisco.com/techsupport/servicerequest


  

About This Guide
Obtaining Additional Publications and Information
For a complete list of Cisco TAC contacts, go to this URL:

http://www.cisco.com/techsupport/contacts

Definitions of Service Request Severity
To ensure that all service requests are reported in a standard format, Cisco has established severity 
definitions.

Severity 1 (S1)—Your network is “down,” or there is a critical impact to your business operations. You 
and Cisco will commit all necessary resources around the clock to resolve the situation. 

Severity 2 (S2)—Operation of an existing network is severely degraded, or significant aspects of your 
business operation are negatively affected by inadequate performance of Cisco products. You and Cisco 
will commit full-time resources during normal business hours to resolve the situation.

Severity 3 (S3)—Operational performance of your network is impaired, but most business operations 
remain functional. You and Cisco will commit resources during normal business hours to restore service 
to satisfactory levels.

Severity 4 (S4)—You require information or assistance with Cisco product capabilities, installation, or 
configuration. There is little or no effect on your business operations.

Obtaining Additional Publications and Information
Information about Cisco products, technologies, and network solutions is available from various online 
and printed sources.

• Cisco Marketplace provides a variety of Cisco books, reference guides, and logo merchandise. Visit 
Cisco Marketplace, the company store, at this URL:

http://www.cisco.com/go/marketplace/

• The Cisco Product Catalog describes the networking products offered by Cisco Systems, as well as 
ordering and customer support services. Access the Cisco Product Catalog at this URL:

http://cisco.com/univercd/cc/td/doc/pcat/

• Cisco Press publishes a wide range of general networking, training and certification titles. Both new 
and experienced users will benefit from these publications. For current Cisco Press titles and other 
information, go to Cisco Press at this URL:

http://www.ciscopress.com

• Packet magazine is the Cisco Systems technical user magazine for maximizing Internet and 
networking investments. Each quarter, Packet delivers coverage of the latest industry trends, 
technology breakthroughs, and Cisco products and solutions, as well as network deployment and 
troubleshooting tips, configuration examples, customer case studies, certification and training 
information, and links to scores of in-depth online resources. You can access Packet magazine at this 
URL:

http://www.cisco.com/packet
xiii
Cisco QAM Gateway Manager User Guide, Release 1.0

OL-5763-01

http://www.cisco.com/techsupport/contacts
http://www.cisco.com/go/marketplace/
http://cisco.com/univercd/cc/td/doc/pcat/
http://www.ciscopress.com
http://www.cisco.com/packet


  

About This Guide
Obtaining Additional Publications and Information
• iQ Magazine is the quarterly publication from Cisco Systems designed to help growing companies 
learn how they can use technology to increase revenue, streamline their business, and expand 
services. The publication identifies the challenges facing these companies and the technologies to 
help solve them, using real-world case studies and business strategies to help readers make sound 
technology investment decisions. You can access iQ Magazine at this URL:

http://www.cisco.com/go/iqmagazine

• Internet Protocol Journal is a quarterly journal published by Cisco Systems for engineering 
professionals involved in designing, developing, and operating public and private internets and 
intranets. You can access the Internet Protocol Journal at this URL:

http://www.cisco.com/ipj

• World-class networking training is available from Cisco. You can view current offerings at 
this URL:

http://www.cisco.com/en/US/learning/index.html
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C H A P T E R 1

Introduction to Cisco QAM Gateway Manager

This chapter provides basic information about Cisco QAM Gateway Manager (Cisco QGM) and 
includes the following sections:

• Overview, page 1-1

• Cisco QAM Gateway Manager Views, page 1-2

• Basic Tasks, page 1-16

Overview
Cisco QAM Gateway Manager is a PC-based graphical user interface (GUI) element management 
application to be used with Cisco uMG980 series QAM gateway products, the Cisco uMG9820 QAM 
Gateway and the Cisco uMG9850 QAM Module. The SNMP-based Java application is used for basic 
configuration, monitoring, and troubleshooting, and also includes hierarchical views of devices and their 
components, as well as a Telnet interface to the managed devices.

Hardware and Software Supported
Table 1-1 lists Cisco hardware supported by Cisco QAM Gateway Manager, along with the minimum 
software release required for each.

Table 1-1 Supported Hardware and Software

Product Number Description

Minimum 
Software 
Release Notes

Cisco Catalyst 
Switches

WS-C4506 Cisco Catalyst 4506 switch 
chassis

12.1(20)EU1

WS-C4507R Cisco Catalyst 4507R switch 
chassis

12.1(20)EU1

Cisco uMG9850 QAM 
Module

WS-X4712-UMG9850 QAM card for Cisco Catalyst 
4500 series switches

12.1(20)EU1 Used in Cisco Catalyst 
4506 and Cisco Catalyst 
4507R switches

Cisco uMG9820 QAM 
Gateway

uMG9820-SYS-AC Cisco QAM Gateway system Release 2.2
1-1
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  Cisco QAM Gateway Manager Views
Cisco QAM Gateway Manager Views
Cisco QAM Gateway Manager uses a variety of views for configuration, monitoring, and 
troubleshooting:

• Chassis View

• Slot View

• All Sessions View

– All Session Details

• Sessions View

• QAM Summary View

• QAM Channel View

• ASI Port View

• Ethernet Port View

• Notification History table

Each of these views are described in the following sections. Differences between the views for the 
Cisco uMG9820 QAM Gateway and the Cisco uMG9850 QAM modules in Cisco Catalyst switches are 
noted.
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Chassis View
The Chassis View (see Figure 1-1 and Figure 1-2) lists for a selected device, the contents of each slot in 
the device, including the status of fan tray and power supply assemblies. For Cisco Catalyst switches, 
operating status is also displayed.

The Chassis View also provides the means to configure global timeouts and, for Cisco Catalyst switches, 
program-specific information (PSI) parameters.

Figure 1-1 Chassis View (Cisco uMG9820)

Note To access Chassis view, highlight the device in the navigation tree and choose View > Chassis.
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Figure 1-2 Chassis View (Cisco Catalyst Switch with Cisco uMG9850 QAM Module)

Note To access Chassis view, highlight the device in the navigation tree and choose View > Chassis.
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Slot View
The Slot View (see Figure 1-3 and Figure 1-4) lists for a specific device, a summary of the QAM 
channels’ administrative and link status, and, for Cisco Catalyst switches, the administrative and link 
status of ASI and Ethernet ports. Also provided is information on the number of incoming sessions and 
outgoing programs.

For Cisco Catalyst switches, the Slot View also provided the means to configure slot-level timeouts, 
slot-level addressing, and jitter.

Figure 1-3 Slot View (Cisco uMG9820)

Note To access Slot view, highlight a QAM slot in the navigation tree and choose View > Slot.
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Figure 1-4 Slot View (Cisco Catalyst Switch with Cisco uMG9850 QAM Module)

Note To access Slot view, highlight a QAM slot in the navigation tree and choose View > Slot.
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All Sessions View 
(Cisco Catalyst switches only) The All Sessions View (see Figure 1-5) lists session statistics for idle, 
inactive, and active sessions, and for invalid PSI states.

Figure 1-5 All Sessions View (Cisco Catalyst Switch with Cisco uMG9850 QAM Module)

Note To access All Sessions view, highlight the desired Cisco uMG9850 slot in the navigation tree and choose 
View > All Sessions.
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All Session Details

(Cisco Catalyst switches only) All Session Details (see Figure 1-6) provides read-only values for a 
specific session.

Figure 1-6 All Session Details (Cisco Catalyst Switch with Cisco uMG9850 QAM Module)

Note To access All Session Details for a particular session, double-click on that session on in the All Sessions 
view.
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Sessions View
Sessions View (see Figure 1-7 and Figure 1-8) lists session statistics for active and inactive sessions, and 
invalid PSI states. 

Note Video module address is shown for Cisco uMG9850 modules only.

Figure 1-7 Sessions View (Cisco uMG9820 QAM Gateway)

Note To access Sessions view, highlight a Cisco uMG9820 slot in the navigation tree and choose View > 
Sessions.
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Figure 1-8 Sessions View (Cisco Catalyst Switch with Cisco uMG9850 QAM Module)

Note To access Sessions view, highlight a Cisco uMG950 slot in the navigation tree and choose View > 
Sessions.
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QAM Summary View
For both devices, the QAM Summary View (see Figure 1-9) allows viewing and configuration of all 
QAM channels for all parameters except bandwidth utilization and video sessions mapping.

Figure 1-9 QAM Summary View (Cisco Catalyst Switch with Cisco uMG9850 QAM Module Shown)

Note To access QAM Summary view, click Configure QAM Channels while in Slot view.
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QAM Channel View
For both devices, the QAM Channel View (see Figure 1-10) lists the current configuration parameters 
for the selected QAM channel, and allows configuration of these parameters.

Figure 1-10 QAM Channel View (Cisco Catalyst Switch with Cisco uMG9850 QAM Module Shown)

Note To access QAM Channel view, select a QAM port from the navigation tree and choose View > Interface.
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ASI Port View
For both types of devices, the asynchronous serial interface (ASI) Port View (see Figure 1-11) lists the 
current configuration parameters for the ASI port and allows configuration of these parameters.

Figure 1-11 ASI Port View (Cisco Catalyst Switch with Cisco uMG9850 QAM Module Shown)

Note To access the ASI Port view for Cisco uMG9820, highlight the ASI port on Cisco uMG9820 processor 
card in the navigation tree and choose View > Interface. 

For Cisco Catalyst switches, highlight the ASI port on the Cisco uMG9850 module in the navigation tree, 
and choose View > Interface. 
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Ethernet Port View
The Ethernet Port View (see Figure 1-12) lists information on port configuration and status, and allows 
setting of administrative status for the port and, for Cisco Catalyst switches only, switchport status and 
VLAN number.

Figure 1-12 Ethernet Port View (Cisco Catalyst Switch with Cisco uMG9850 QAM Module Shown)

Note To access the Ethernet Port view for Cisco uMG9820, highlight an Ethernet port on Cisco uMG9820 
processor card in the navigation tree and choose View > Interface. 

For Cisco Catalyst switches, highlight an Ethernet port on the Cisco uMG9850 module in the navigation 
tree, and choose View > Interface. 
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Notification History Table
For both types of devices, the Notification History table (see Figure 1-13 on page 1-15) lists statistics 
for a device. Each time a device threshold is passed or an invalid PSI data condition is detected, an entry 
is recorded in the table.

Figure 1-13 Notification History Table (Cisco Catalyst Switch with Cisco uMG9850 QAM Module 

Shown)

Note To access the Notification History Table, highlight a device in the navigation tree. Right-click and 
choose View Notification.
1-15
Cisco QAM Gateway Manager User Guide, Release 1.0

OL-5763-01



  

Chapter 1      Introduction to Cisco QAM Gateway Manager
  Basic Tasks
Basic Tasks
The following basic tasks are covered in subsequent chapters of this user guide:

• Installing Java Web Start (Chapter 2)

• Installing and uninstalling Cisco QAM Gateway Manager (Chapter 2)

• Before using Cisco QAM Gateway Manager (Chapter 2)

– Setting up SNMP

– Setting up input video traffic

– Configuring a VLAN

• Launching Cisco QAM Gateway Manager (Chapter 3)

• Configuration tasks (Chapter 3)

– Establishing communication with Cisco QAM Gateway devices

– Loading configurations from a TFTP server

– Configuring SNMP parameters

– Setting output frequency and power for the QAM channels

– Setting up, editing, and routing a video stream to a QAM channel

– Setting up PSI parameters

– Enabling or disabling ports or QAM channels

• Exiting Cisco QAM Gateway Manager (Chapter 3)

• Monitoring Cisco QAM Gateway devices (Chapter 4)

– Configuring the ASI port for QAM channel routing

– CLI show commands

– Setting and monitoring utilization thresholds

– Application display messages
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Installing Cisco QAM Gateway Manager

This chapter describes the tasks that should be performed prior to using Cisco QAM Gateway Manager 
(Cisco QGM).

• Minimum System Requirements, page 2-1

• Installing Software, page 2-2

• Before Using Cisco QAM Gateway Manager, page 2-4

• Removing Software, page 2-5

Minimum System Requirements
Table 2-1 lists the minimum system requirements for Cisco QGM running on the Microsoft Windows 
platform. Table 2-2 lists Java system requirements.

Table 2-1 Microsoft Windows System Requirements

Specification Requirement

Processor 600 MHz

Operating system Microsoft Windows 2000

Available disk space 10 MB

Memory 256 MB

Additional software Zip/unzip utility

Table 2-2 Java System Requirements

Specification Requirement

Java 2 Platform Standard Edition, V.1.4.2 (Includes Java Web 
Start 1.2)

Available disk space required for Java software 70 MB
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Installing Software
Cisco QGM uses the Java Runtime Environment (JRE). Both Cisco QGM and JRE can be downloaded 
without charge from the Internet. 

This section presents the following tasks: 

• Downloading and Starting Cisco QAM Gateway Manager

• Downloading and Installing the Java Runtime Environment (JRE)

Note The following instructions assume the use of Microsoft Internet Explorer.

Downloading and Starting Cisco QAM Gateway Manager

To download the Cisco QAM Gateway Manager application from Cisco.com:

Step 1 Access the Cisco QGM installation file.

a. Go to the following URL:

http://www.cisco.com/cgi-bin/tablebuild.pl/qam-gateway

b. Click on the following file:

CQM1.0.zip

The unzip window appears.

Step 2 Select all files by choosing Actions > Select All.

Step 3 Click Extract

Step 4 Enter a destination drive and directory where you want the files to be located, for example, 
C:\cqm_install.

Step 5 Click Extract.

To install and start Cisco QAM Gateway Manager:

Step 1 Ensure that the appropriate Java software is installed on the PC. (See Downloading and Installing the 
Java Runtime Environment (JRE), page 2-3.) Cisco QGM cannot be used until the Java software is 
installed.

Step 2 Use Windows Explorer to find and open the C:\cqm_install directory.

Step 3 Click on the cqm.bat file.

The Cisco QGM application is installed and started.
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Note Start the application each time by clicking on cqm.bat in the C:\cqm_install directory.

If you prefer to launch Cisco QGM from the desktop, copy the cqm.bat file from the directory by 
right-clicking on the file and choosing Copy, then right-clicking on the desktop and choosing Paste 
Shortcut.

Downloading and Installing the Java Runtime Environment (JRE)

Before using Cisco QAM Gateway Manager, you must have Java Standard Edition, version 1.4.2 
installed. 

Step 1 Confirm whether your PC already has Java installed, and if so, which version.

a. Open a command prompt window (Start > Programs > Accessories > Command Prompt) and enter 
the following:

java -version

b. Confirm that the following appears:

java version "1.4.2_05"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_05-b04)
Java HotSpot(TM) Client VM (build 1.4.2_05-b04, mixed mode)

c. If the above appears, you have the correct version of Java. Proceed to Downloading and Starting 
Cisco QAM Gateway Manager, page 2-2.

d. If the above does not appear, or a different version of Java is listed, proceed to Step 2, below.

Step 2 Access the appropriate JRE file.

Note You may be prompted by multiple security warnings. Choose Yes when prompted.

a. Go to the following URL:

http://java.sun.com/j2se/1.4.2/download.html

b. Choose Download J2SE JRE.

c. Accept the License Agreement.

The download options appear.

d. In the Microsoft Windows platform section choose Windows Installation, Multi-Language.

The File Download window appears.

Step 3 Download the Java JRE software.

a. Choose Save this program to disk.

b. For convenience, save the file to your desktop.

Step 4 Install the Java software.

a. Double-click the file you saved in Step 3b above. The name of the file is 
j2re-1_4_2_05-windows-i586-p-iftw.exe.
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An installer window appears. 

b. Accept the defaults and choose Typical Install.

Before Using Cisco QAM Gateway Manager 
This section summarizes the minimum configuration required before using Cisco QGM. These tasks 
would normally be completed in advance by the network or device administrator using the device 
command line interface (CLI). 

To see the detailed steps for completing each of these tasks, refer to the Cisco uMG9820 QAM Gateway 
or Cisco Catalyst 4500 series switch documentation listed in Related Documentation.

Before using Cisco QGM, ensure you have the following information for each device to be managed:

• Telnet password

• IP address

• SNMP community string

• (Cisco Catalyst switches only) VLAN information:

– VLAN numbers

– IP addresses

Telnet Password
A Telnet password should be set to control access to the device through the Telnet window in 
Cisco QAM Gateway Manager. You will need to know this password to use the application’s Telnet 
function. 

SNMP Setup
Cisco QAM Gateway Manager uses Simple Network Management Protocol (SNMP) and a special 
management information base (MIB) to manage Cisco QAM gateway devices. The MIBs are included 
in the software releases shown in Table 1-1 on page 1-1.

Ethernet Port for SNMP Configuration

An IP address must be configured for each device for SNMP use. You must have this information when 
adding devices to the device list in Cisco QAM Gateway Manager.

SNMP Community String

The SNMP community string authenticates access to MIB objects, and functions as an embedded 
password. You must have this information when adding devices to the device list in Cisco QAM Gateway 
Manager. Cisco uMG9820 QAM Gateways and Cisco Catalyst switches must be configured with SNMP 
community strings before using Cisco QAM Gateway Manager to monitor or configure these devices.
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Setting Up Input Video Traffic
Video input specifications must be set and, for Cisco Catalyst switches, any required VLANs must be 
configured on the device before using Cisco QAM Gateway Manager. 

Removing Software

Removing Cisco QAM Gateway Manager from the PC
To remove Cisco QAM Gateway Manager from the PC, use Windows Explorer to find and delete the 
C:\cqm_install directory.

Removing Java Software from the PC
To remove the Java software from the PC, choose Start > Settings > Control Panel > Add/Remove 
Programs and select the Java application.
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Using Cisco QAM Gateway Manager

This chapter describes the steps required to launch Cisco QAM Gateway Manager (Cisco QGM) and 
configure Cisco Catalyst switches and Cisco QAM gateways.

• Launching Cisco QAM Gateway Manager, page 3-1

• Main Window Components, page 3-2

• Using Help, page 3-10

• Exiting Cisco QAM Gateway Manager, page 3-13

• Establishing Communication with Cisco QAM Gateway Devices, page 3-14

• Configuration Steps, page 3-22

Launching Cisco QAM Gateway Manager
To launch Cisco QGM, click on cqm.bat in the C:\cqm_install directory on the desktop. The Main 
Window appears (see Figure 3-1).
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Figure 3-1 Main Window

Main Window Components
The main window (see Figure 3-1) consists of five areas:

1. Menu bar

2. Toolbar

3. Status bar

4. Navigation tree

5. Work area

Each of these areas is discussed in the following sections.

Menu Bar
The menu bar (see Figure 3-2) provides access to common application functions and tasks (see 
Table 3-1).

Figure 3-2 Menu Bar
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Toolbar
The toolbar (Figure 3-3) provides quick access to some commonly performed tasks (see Table 3-2 on 
page 3-4).

Figure 3-3 Toolbar

Table 3-1 Menu Bar Functions

Menu Function Description

File Add Device Adds a Cisco Catalyst switch or Cisco uMG9820 QAM 
Gateway to the device list.

Load Configuration Loads a configuration file from a TFTP server.

Save Startup to TFTP Saves the startup configuration to a TFTP server.

Configure SNMP Parameters When “Cisco QAM Gateway Manager” (root) selected in 
the navigation tree, configures SNMP polling 
parameters.

When device selected in the navigation tree, configures 
the Community String SNMP parameter for that device.

Close All Closes all open views and configuration dialog boxes.

Exit Exits Cisco QAM Gateway Manager application.

View Chassis Displays chassis statistics.

Slot Displays contents of slots in chassis.

All Sessions Lists both active and idle sessions.

Sessions Lists only active sessions.

Interface Displays ASI or Ethernet interface configurations.

Configure Configure VLAN Assigns an IP address and optional subnet mask to a 
selected VLAN. Activates or suspends a VLAN.

Telnet Device 1 Allows selection of connected devices for Telnet 
sessions.Device n

Window various Lists all open/active views and configuration dialog 
boxes.

Help Contents Provides access to all help files by Table of Content 
heading and text search.

About Displays software version of Cisco QGM.
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Status Bar
The Status Bar (Figure 3-4) indicates status of configuration load and refresh operations (see Table 3-3).

Figure 3-4 Status Bar

Navigation Tree
The Navigation Tree (see Figure 3-5) lists all added devices. Each entry expands to display its 
components. Use the scroll bar to see the full expansion.

Table 3-2 Toolbar Functions

Tool Description

Add Device Adds Cisco Catalyst switches and 
Cisco uMG9820 QAM Gateways to the 
navigation tree.

Configure When “Cisco QAM Gateway Manager” (root) in 
the navigation tree (see Figure 3-1) is selected, 
allows configuration of SNMP polling 
parameters.

When device is selected in the navigation tree, 
configures the Community String SNMP 
parameter for that device.

Refresh Refreshes current view.

Stop Stops refresh process for current view.

Table 3-3 Status Bar Messages

Function Description

Done Function is complete.

Refreshing tree. Please wait. Navigation tree refresh in process.

Loading slot configuration. Please wait. Slot View information being loaded.

Loading Ethernet configurations. Please wait. Ethernet Port View information being loaded.

Loading QAM channel configurations. Please 
wait.

QAM Channel View information being loaded.

Loading chassis configurations. Please wait. Chassis View information being loaded.

Loading session configuration. Please wait. Session View or session status information is being 
loaded.

Loading notification history. Please wait. Refreshing Notification History table.
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Figure 3-5 Navigation Tree (Cisco Catalyst Switch Shown)

To refresh the navigation tree, select and right-click on “Cisco QAM Gateway Manager” at the top of 
the tree and choose Refresh tree. (See Figure 3-6.)

Figure 3-6 Refresh Navigation Tree

Note Refreshing the navigation tree also collapses the navigation tree to the device level.

Work Area
The Work area (see Figure 3-7) can contain a variety of view windows and configuration dialog boxes. 
This area changes depending on the function being performed (see Table 3-4). Up to 30 of these windows 
can be open simultaneously.
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Figure 3-7 Work Area (Cisco Catalyst Switch Chassis View Shown)

Table 3-4 on page 3-7 lists configuration, monitoring, and troubleshooting tasks that are commonly 
performed, and provides a cross-reference to the appropriate view or configuration window.

Tip Print out Table 3-4 and keep it as a quick reference tool.
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Table 3-4 Quick Reference—Work Area Navigation Map

Go To . . . For This Task. . . Or Subtask . . . Notes
Chassis View

• Contents of each slot in the device.

• For Cisco Catalyst switches, the 
operating status. 

Setting Up PSI 
Parameters, page 
3-31 (see Notes).

Setting PMT and 
PAT Intervals for 
the Switch, page 
3-31.

Cisco Catalyst switches only.

Setting PMT and 
PAT Intervals for a 
QAM Channel, 
page 3-32.

Setting TSID and 
NIT-PID Values, 
page 3-32

Setting Up, 
Editing, and 
Routing a Video 
Stream to a QAM 
Channel, page 
3-26.

Statically Setting 
Session Timeouts.

Slot View

• For a specific QAM device, a 
summary of the QAM channels’ 
administrative and link status. 

• For Cisco Catalyst switches, the 
administrative and link status of 
ASI and Ethernet ports.

Configuring 
Gigabit Ethernet 
Input and Output 
Ports into a 
VLAN, page 3-22 
(see Notes).

Assigning the 
Output GE ports to 
a VLAN.

Cisco Catalyst switches only.

See also Interface View 
(Ethernet) and Configure VLAN 
Dialog.

Setting Up, 
Editing, and 
Routing a Video 
Stream to a QAM 
Channel, page 
3-26.

Configuring 
Maximum Jitter for 
a Session.

See also QAM Channel View 
and Chassis View.

Session View

• Statistics for active sessions.
View table of all 
active sessions.

All Session View

• Statistics for both idle and active 
sessions.

View table of both 
idle and active 
sessions.

Check individual 
session Statistics 
(See Notes).

Idle sessions not shown for 
Cisco uMG9820.

Session Details available on 
Cisco Catalyst switches only.

Interface View (ASI)

• For a specific ASI port, lists the 
current configuration parameters 
for the ASI port and allows 
configuration of the administrative 
status, byte gap, and the QAM 
from which the stream is routed.

Enabling or 
Disabling Ports 
and QAM 
Channels, page 
3-33.
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Interface View (Ethernet)

• For a specific Ethernet port, lists 
current status and configuration 
and allows configuration of the 
administrative status, switchport 
status, VLAN number, IP address 
and subnet mask.

Enabling or 
Disabling Ports 
and QAM 
Channels, page 
3-33.

Configuring 
Gigabit Ethernet 
Input and Output 
Ports into a 
VLAN, page 3-22.

Assigning the Input 
GE Port to a 
VLAN.

See also Interface View 
(Ethernet) and Slot View.

QAM Channel View

• Lists the current configuration 
parameters for the selected QAM 
channel, and allows configuration 
of these parameters.

Setting the Output 
Frequency and 
Output Power of 
the QAM 
Channels, page 
3-25.

Also see QAM Summary View.

Setting Up, 
Editing, and 
Routing a Video 
Stream to a QAM 
Channel, page 
3-26.

Setting the 
Modulation 
Format.

Configuring the 
FEC Interleave 
Level and Mode.

Statically Routing a 
Range of Program 
Sessions to a QAM 
Channel (UDP Port 
Mapping).

Enabling or 
Disabling Ports 
and QAM 
Channels, page 
3-33.

Setting the Output 
Frequency and 
Output Power of 
the QAM 
Channels, page 
3-25.

Setting the Output 
Frequency.

Setting the Output 
Power.

QAM Summary View

• Allows viewing and configuration 
of all QAM channels on a specific 
Cisco uMG9850 QAM module slot 
or Cisco uMG9820 QAM Gateway 
QAM slot.

Table 3-4 Quick Reference—Work Area Navigation Map (continued)

Go To . . . For This Task. . . Or Subtask . . . Notes
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Choose an already opened view from the Window menu or open a new one using the View menu. To 
close all views simultaneously, choose File > Close All.

Resizing the Navigation Tree and Work Area
To hide the navigation tree and expand the work area, click on the left arrow. To hide the work area and 
expand the navigation tree, click on the right arrow. (See Figure 3-8.)

Figure 3-8 Hide Buttons

To readjust the navigation tree and work area to specific widths, place the cursor on the margin as shown 
in Figure 3-9. When it becomes a double-ended arrow, drag the margin to the left or right. 

Figure 3-9 Sizing the Navigation Tree and Work Area

Notification History

• Lists statistics for a device. Each 
time a device threshold is passed or 
an error condition is detected, an 
entry is recorded in the table.

Configure VLAN Dialog Configuring 
Gigabit Ethernet 
Input and Output 
Ports into a 
VLAN, page 3-22.

Selecting a VLAN 
Interface.

See also Interface View 
(Ethernet) and Slot View.

Telnet Window Using the Telnet 
Window, page 
3-17.

Table 3-4 Quick Reference—Work Area Navigation Map (continued)

Go To . . . For This Task. . . Or Subtask . . . Notes
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Using Help
The help files for the Cisco QAM Gateway Manager application are provided to simplify the use of the 
application. These files can be accessed in two ways:

• Help for a specific screen can be accessed by clicking Help on that screen.

• The full help set can be accessed by choosing Help > Contents or by pressing F1.

Screen-Specific Help
Clicking Help in a window opens the help set and displays help files for that particular window. These 
files include discussions of any configuration options or read-only values present. Further navigation 
cross-references are included where necessary for greater understanding.

Full Help Set
Choose Help > Contents or press F1 to open the entire help set.

The navigation pane on the left side of the window includes two tabs: the Contents tab and the Search 
tab. Navigation and printing aids are present in the help files and in the help toolbar. See Figure 3-10.

Figure 3-10 Help Tools and Tabs

Contents Tab

Click the Contents tab to display a Table of Contents of all help files, which allows you to click on a 
specific subject or task for information. See Figure 3-11.
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Figure 3-11 Help File Table of Contents

Search Tab

Click the Search tab and enter a text search term. All help files are searched for the term, and the results 
(number of occurrences) are displayed in the left side of the window in order of significance. The page 
containing the first occurrence appears on the right. See Figure 3-12.

Figure 3-12 Help Files Search Tab
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Navigation

Click the Home icon in the toolbar (see Figure 3-13) to return to the top file in the Table of Contents.

Figure 3-13 Home Icon

Click the arrows at the top and bottom of all the help file text windows (see Figure 3-14) to step 
backward and forward sequentially through the files. 

Figure 3-14 Navigation Arrows

Use the arrows in the toolbar (see Figure 3-15) to return directly to the previous position in a text 
window.

Figure 3-15 Return to Previous

Printing

Click the printer icons in the toolbar (see Figure 3-16) for page setup or to print help text.

Figure 3-16 Print Icon

Reload

Click the reload icon in the toolbar (see Figure 3-17) to reload the current help page.

Figure 3-17 Reload Icon
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Exiting Cisco QAM Gateway Manager
To exit the application, follow these steps:

Step 1 Do one of the following:

• Choose File > Exit (see Figure 3-18).

Figure 3-18 File Exit

• Click the X in the upper-right corner of the Main Window (see Figure 3-19).

Figure 3-19 Exit Using X in Main Window

The Save Running Configuration dialog box appears. (see Figure 3-20).

Figure 3-20 Save Running Configuration

Step 2 Click Cancel to keep the application active and return to configuration tasks. Click Save All and Quit 
to save all configuration changes to the startup configuration. Click Save None and Quit to disregard 
all configuration changes. All active windows are closed and the Cisco QAM Gateway Manager session 
ends. 
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Note If the Save all configurations to startup configuration? check box is selected in the Add Device or 
Configure SNMP Parameters dialog box (see “Adding a Device” section on page 3-14 and “Configuring 
SNMP Parameters” section on page 3-20), configuration changes are automatically saved to the startup 
configuration each time Apply is clicked, independently of Save All and Quit or Save None and Quit 
selections.

Establishing Communication with Cisco QAM Gateway Devices
• Adding a Device

• Removing a Device

• Using the Telnet Window

Adding a Device
To configure and monitor Cisco QAM Gateway devices, you must first add Cisco Catalyst switches and 
Cisco uMG9820 QAM Gateways to the device list. Up to 20 devices can be managed by Cisco QAM 
Gateway Manager. To add a device:

Step 1 Select Add Device using one of the following methods:

• Choose File > Add Device (see Figure 3-21).

Figure 3-21 Add Device Using File Menu

• Click the Add Device tool (see Figure 3-22).

Figure 3-22 Add Device Using Add Device Button

• In the navigation tree, select, then right-click “Cisco QAM Gateway Manager” (see Figure 3-23).
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Figure 3-23 Add Device Using Right Mouse Click

Step 2 In the Add Device dialog box, enter the IP Address and Community String of the device (see 
Figure 3-24). 

Note Entering the SNMP community string does not change the value on the device. It authenticates access 
to the device. The community string must be defined before adding the device to the list. See Before 
Using Cisco QAM Gateway Manager, page 2-4.

If you want to automatically save all configurations to the startup configuration, select the check box. 
When the check box is selected, any change made to a device using Cisco QAM Gateway Manager is 
automatically saved to both the running and startup configuration files of that device. If the check box 
is not selected, configuration changes are saved only to the running configuration.

Figure 3-24 Add Device Dialog Box

Note When using the option to automatically save all changed configuration information to the startup 
configuration file, you can make a backup of the existing startup configuration to a TFTP server before 
changing configurations. Choose File > Save Startup to TFTP (see Figure 3-25 on page 3-16). This 
backup can be used in case it is necessary to restore the original startup configuration after a device 
reload.
3-15
Cisco QAM Gateway Manager User Guide, Release 1.0

OL-5763-01



  

Chapter 3      Using Cisco QAM Gateway Manager
  Establishing Communication with Cisco QAM Gateway Devices
Figure 3-25 Save Startup to TFTP

Step 3 Click OK. The device name and its IP address are displayed in the navigation tree (see Figure 3-26).

Figure 3-26 Navigation Tree with Device Added

Removing a Device
To remove a device from the list, do the following:

Step 1 In the Navigation Tree, select the device to remove, then right-click. (see Figure 3-27).

Figure 3-27 Selecting Remove

Step 2 Choose Remove. When the confirmation screen appears, click Yes.
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Using the Telnet Window
Use the Telnet window to enter command-line interface (CLI) commands such as show commands, or 
perform configuration tasks on the devices listed in the navigation tree that cannot be achieved using the 
GUI interface. 

Note For further information regarding CLI commands refer to Cisco uMG9820 QAM Gateway Installation 
and Configuration Guide, Configuring the Cisco uMG9850 QAM Module, and Cisco Catalyst 4500 
Series IOS Software Configuration Guide.

Commonly used show commands are summarized in Chapter 4, “Monitoring Cisco QAM Gateway 
Devices”.

To access a device using the Telnet window:

Step 1 Choose the device using the Telnet menu (see Figure 3-28).

Figure 3-28 Telnet to Device

The Telnet window appears (see Figure 3-29).
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Figure 3-29 Telnet Window 

Step 2 Enter the Telnet password for the device and press Enter (see Figure 3-30). 

Figure 3-30 Logged on to Device

Step 3 Enter any desired CLI commands.

Step 4 To terminate the Telnet session, type exit (see Figure 3-31), or choose File > Exit in the Telnet window 
menu bar.
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Figure 3-31 Exiting Telnet Session

Step 5 To close the Telnet window, click the X in the upper right of the window.

Loading a Configuration from a TFTP Server
An existing configuration of a Cisco Catalyst Switch or Cisco uMG9820 QAM Gateway can be 
downloaded from a TFTP server and sent to the running configuration or startup configuration of a 
device.

To load a configuration from a TFTP server:

Step 1 Highlight the device and choose File > Load Configuration.

Figure 3-32 Choosing Load Configuration from the File Menu.

Step 2 Enter the TFTP server filename and IP address.

Figure 3-33 TFTP Server IP Address and Filename

Step 3 Select the Destination filename—either Startup configuration or Running configuration.

Step 4 Click OK to load the configuration. Click Cancel to close the window without loading a configuration.
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Note The device must be reloaded for the startup configuration to take effect. Changes to the running 
configuration take effect immediately.

Configuring SNMP Parameters

Setting SNMP Polling Interval

The polling interval determines how frequently Cisco QAM Gateway Manager requests status 
information from each of the managed devices. To set the SNMP polling parameters for all devices:

Step 1 Highlight “Cisco QAM Gateway Manager” in the navigation tree.

Step 2 Select Set SNMP Parameters using one of the following methods:

• Choose File > Configure SNMP Parameters (see Figure 3-34).

Figure 3-34 Using File Menu

• Right-click on “Cisco QAM Gateway Manager (see Figure 3-35).

Figure 3-35 Using Right Click

Step 3 Enter the polling interval (see Figure 3-36). The range of values is 180 to 3600 seconds. The default 
value is 180 seconds.
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Figure 3-36 Polling Interval Configuration Dialog Box

Step 4 Click OK to save the configuration. Click Cancel to close the dialog box and discard any changes.

Setting the SNMP Community String

If the system administrator changes the community string on the device, use this function to set the new 
SNMP community string for that device in Cisco QGM:

Step 1 Highlight a device in the navigation tree.

Step 2 Select Set SNMP Parameters using one of the following methods:

• Choose File > Configure SNMP Parameters (see Figure 3-37).

Figure 3-37 Using File Menu

• Right-click on the device and choose Configure SNMP (see Figure 3-38).

Figure 3-38 Using Right Click
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• Click Configure in the toolbar (see Figure 3-39).

Figure 3-39 Using Configure Button

Step 3 Enter the new SNMP community string and, if there has been a requirement change since first adding 
the device, select or deselect the Save all configurations to startup configuration? box (see Figure 3-40).

Figure 3-40 Configure SNMP Parameters Dialog Box

Step 4 Click OK to save the configuration. Click Cancel to close the dialog box and discard any changes

Configuration Steps

Initial Configuration

Configuring Gigabit Ethernet Input and Output Ports into a VLAN

Note This procedure applies to Cisco Catalyst switches only. It does not apply to the Cisco uMG9820 QAM 
Gateway.

Outbound interfaces are included in single VLANs to use network addresses more efficiently. The IP 
addresses and subnet masks configured for each VLAN interface populate the IP switching table on the 
switch with the forwarding information needed to forward the video packets to their destination. The 
number and use of VLANs varies according to the programming and management needs of the system 
operator.
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Do the following to select a VLAN interface, assign an IP address to the incoming (video source) 
interface, and assign input and output Gigabit Ethernet (GE) ports to the VLAN. This routes the 
incoming video to the appropriate output ports on the Cisco uMG9850 QAM module.

Selecting a VLAN Interface

Step 1 Choose Configure > Configure VLAN (see Figure 3-41).

Figure 3-41 Configure VLAN Menu

The Configure VLAN dialog box appears (see Figure 3-42).

Figure 3-42 Configure VLAN Dialog Box

Step 2 Choose an existing VLAN from the drop-down menu and, if necessary, enter its IP address and subnet 
mask. 

Note If it is necessary to create a new VLAN, use the Telnet window and create the VLAN using commands 
found in Cisco Catalyst 4500 Series IOS Software Configuration Guide.

Assigning the Input GE Port to a VLAN

Step 1 Go to Ethernet Port View (see Table 3-4) and assign the GE interface of the incoming video stream to be 
included in the VLAN by entering the IP address and optional subnet mask of the interface. This is the 
interface of an incoming video stream (see Figure 3-43.)
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Figure 3-43 Interface IP Address and Subnet Mask

Step 2 When assigning a VLAN to an Ethernet port, switchport status must be set to switchport using the 
Switchport Status drop-down menu (see Figure 3-44).

Figure 3-44 Setting Switchport Status

Step 3 Click Apply to save all changes and keep the window open. Click OK to save the changes and close the 
window. Click Cancel to close the window and discard any changes.

Step 4 Return to the Configure VLAN dialog box and set Administrative Status to up.

Step 5 Click Apply to save all changes and keep the window open. Click OK to save the changes and close the 
window. Click Cancel to close the window and discard any changes.

Assigning the Output GE ports to a VLAN

Step 1 Go to Slot View, Video Routing section and assign an IP address in the same subnet as that assigned to 
the VLAN in Step 2. This allows video packets to be switched from the input GE port to the output GE 
port. 

Note To remove the video stream from the VLAN, click the Clear Video Route? box.

Figure 3-45 Setting the GE Port 

Step 2 Click Apply to save all changes and keep the window open. Click OK to save the changes and close the 
window. Click Cancel to close the window and discard any changes.

Repeat these steps for additional VLAN and GE interfaces, as required.
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Setting the Output Frequency and Output Power of the QAM Channels

Each F-connector (QAM port) provides two QAM channels, and the frequency and output power are 
configured for both channels simultaneously. Setting frequency and power for one QAM channel 
automatically sets the appropriate values for the other channel in the same interface.

The Frequency value configures the frequency for the upconverter connected to a QAM port. 
Configuring the frequency for one QAM channel automatically configures the correct frequency for the 
other QAM channel in its upconverter group. The frequency bandwidth of each QAM upconverter block 
is 6 MHz. Consequently, if QAM channel 1 is set to frequency f1, then the other QAM channel is 
automatically set to frequency f1 + 6 MHz. Similarly, if QAM channel 2 is set to frequency f2, then QAM 
channel 1 is automatically set to frequency f2 – 6 MHz.

The power value configures the power level for the upconverter connected to a QAM channel. 
Configuring the output power for one QAM channel automatically configures the same power level for 
the other QAM channel in its upconverter group. 

Setting the Output Frequency

To set the output frequency of the QAM channel:

Step 1 Go to QAM Channel View, Channel Information section (see Figure 3-46).

Note For a map to this and all tasks, see Table 3-4 on page 3-7.

Figure 3-46 Setting the QAM Channel Frequency and Output Power in QAM Channel View 

(Cisco uMG9850 Shown)

Step 2 Enter the frequency for the selected channel.

Note For the Cisco uMG9850, the frequency range for QAM channel 1 is 50000000 to 854000000 Hz, and for 
QAM channel 2 is 56000000 to 860000000.

For the Cisco uMG9820, the frequency range for QAM channel 1 is 222000000 to 897000000 Hz, and 
for QAM channel 2 is 228000000 to 903000000 Hz. 

Step 3 Click Apply to save all changes and keep the window open. Click OK to save the changes and close the 
window. Click Cancel to close the window and discard any changes.
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Note For further information regarding the setting of QAM channel frequency and power, refer to 
Cisco uMG9820 QAM Gateway Installation and Configuration Guide and Configuring the 
Cisco uMG9850 QAM Module.

Setting the Output Power

To set the QAM channel output power:

Step 1 Go to QAM Channel View, Channel Information section (see Figure 3-46).

Step 2 Enter the desired QAM channel power.

Note For the Cisco uMG9850, if both QAM channels in an RF port are enabled, the power range is 42 to 55 
dBmV. The default value is 50 dBmV.

For the Cisco uMG9820, when you configure a power value for one QAM channel in a port, the other 
QAM in the port is assigned the same value. The power range is 44 to 60 dBmV. The default value is 50 
dBmV.

Step 3 Click Apply to save all changes and keep the window open. Click OK to save the changes and close the 
window. Click Cancel to close the window and discard any changes.

Setting Up, Editing, and Routing a Video Stream to a QAM Channel

Basic Tasks

Setting the Modulation Format

Each Cisco uMG9850 has six modulator groups, yielding a total of 24 channels per module. Setting the 
modulation format on one QAM channel applies the same format to all four QAM channels in a 
modulator group. For example, QAM channels 5/1.1, 5/1.2, 5/2.1, and 5/2.2

To set the modulation format for the QAM channel:

Step 1 Go to QAM Channel View, Channel Information section (see Figure 3-46 on page 3-25).

Step 2 Set the modulation format to either qam64 or qam256. The default value is qam256.

Note If the FEC interleave level is set to 1, the value 256 is not valid. See the “Configuring the FEC Interleave 
Level and Mode” section that follows.

Step 3 Click Apply to save all changes and keep the window open. Click OK to save the changes and close the 
window. Click Cancel to close the window and discard any changes.
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Note If level 1 is already selected and it is necessary to change to qam256, first change the FEC Interleave 
level to 2, then click Apply and wait for the configuration change to take effect. Select qam256.

Configuring the FEC Interleave Level and Mode

The FEC interleave settings set the Reed-Solomon forward error correction (FEC) interleave level and 
mode on a QAM port. Forward error correction reduces bit error rate (BER) in data transmission by 
correcting recovered bit errors in the demodulator. Interleaving is a technique that reorders (in time) 
individual code-word bits with other code-word bits to spread error bursts over many different code 
words. The technique used is compliant with ITU J.83, Annex B.

Setting the interleave level and mode on any of the 12 QAM interfaces (ports) sets the QAM symbol rate 
on that port only. If the interleave level and mode is set on one QAM channel, the same value is applied 
to all four QAM channels in a modulator group. 

Caution The default settings should be satisfactory. Realize that varying the settings can result in an increase in 
packet latency. Always monitor new settings to ensure that resulting BERs are acceptable.

To configure the FEC interleave level and mode:

Step 1 Go to QAM Channel View, Interleave parameters section (see Figure 3-47).

Figure 3-47 Setting the FEC Interleave Level and Mode

Step 2 Choose the interleave level.

Values for the FEC interleave level can be level1 or level2. The default value is level2.

Note If the FEC interleave level is set to level1, the modulation format option of qam256 (256 QAM) is not 
valid. (See the “Setting the Modulation Format” section on page 3-26.)

Step 3 Select the value for FEC interleave mode. The default is 6-FEC-I-128-J-4.

Note The interleave mode can be set only then the interleave level is set to level2 (default).

Note The Cisco uMG9820 does not support modes 8-FEC-I-128-J-5 and 10-FEC-I-128-J-6.

Step 4 Click Apply to save all changes and keep the window open. Click OK to save the changes and close the 
window. Click Cancel to close the window and discard any changes.
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Statically Setting Session Timeouts

You can statically set a session timeout for the a single Cisco uMG9850 QAM module, for the entire 
Cisco Catalyst switch, or for the Cisco uMG9820 QAM Gateway to determine when the session is closed 
once packets no longer come into the session. You can also set the time, following the absence of packets, 
at which a loss of signal is reported. Use global timeouts to address the entire switch or QAM gateway, 
and slot-level timeouts (Cisco Catalyst switches only) to address an entire module in a given slot. The 
options and parameters are the same in both cases.

Note When a session is closed, this means that the Cisco uMG9850 has not received any video packets for the 
given session’s UDP port for the period determined by the module-level or switch-level session close 
timeout. The session no longer exists. 

When a session is inactive, this means that the Cisco uMG9850 has not received any video packets for 
the given session’s User Datagram Protocol (UDP) port for the period determined by the global or 
slot-level timeout signal-loss. The session still exists, and is listed following a show command. If packets 
start arriving before the timer set by slot-level session-close timeout or global session-close timeout 
counts down, the session becomes active. 

The value for slot-level timeout signal-loss or global timeout signal-loss should always be larger than 
the value configured for jitter. See Configuring Maximum Jitter for a Session, page 3-30.

To configure global timeouts:

Step 1 Go to Chassis View, Global Timers section. (See Figure 3-48.)

Figure 3-48 Setting Global Timers (Cisco Catalyst Switch Chassis View Shown)

Step 2 Enter a value for Session Close Timeout. The range of values is 1 to 1440 minutes. The default value is 
10 minutes.

Step 3 Enter a value for Signal Loss Timeout. 

Note For the Cisco Catalyst switch, the range of values is 200 to 10000 milliseconds. The default value is 5000 
milliseconds.

For the Cisco uMG9820, the range of values is 500 to10000 milliseconds. The default value is 5000 
milliseconds.

Step 4 Click Apply to save all changes and keep the window open. Click OK to save the changes and close the 
window. Click Cancel to close the window and discard any changes.
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To configure slot-level timeouts:

Note This procedure applies to Cisco Catalyst switches only. It does not apply to the Cisco uMG9820 QAM 
Gateway.

Step 1 Go to Slot View, Slot Level Timeouts section (see Figure 3-49).

Figure 3-49 Setting Slot-Level Timers

Step 2 Enter a value for Session Close Timeout. The range of values is 1 to 1440 minutes. The default value is 
10 minutes.

Step 3 Enter a value for Signal Loss Timeout. The range of values is 200 to 10000 milliseconds. The default 
value is 5000 milliseconds.

Step 4 Click Apply to save all changes and keep the window open. Click OK to save the changes and close the 
window. Click Cancel to close the window and discard any changes.

Statically Routing a Range of Program Sessions to a QAM Channel (UDP Port Mapping)

The UDP port number of each program session allows each session to be routed to a designated QAM 
channel by default. You can overwrite the default routing (which is signaled by the port number) and 
route a range of program sessions to a QAM channel. 

To route a range of program sessions to a QAM channel:

Step 1 Go to QAM Channel View, Video Sessions Mapping section (see Figure 3-50).

Figure 3-50 Statically Routing a Range of Program Sessions to a QAM Channel

Note Figure 3-50 displays the default values, indicating that the device is using default UDP port 
mapping. If you want to use default port mapping, do not change these values. If you want to 
create a static port map, proceed to Step 2.

Step 2 Enter maximum number of sessions for this UDP port mapping. The range of values is 2 to 25. 

Step 3 Enter the starting UDP port number to be mapped. The range of values is 256 to 65535. 
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Step 4 Enter the starting output program number to be mapped. The range is 1 to 255.

Step 5 To use only even UDP port numbers, reserving odd numbers for Real-Time Control Protocol (RTCP) for 
other purposes, set the value to true. False is the default.

Step 6 To clear video session mapping and revert to the session defaults, click on the Clear Video Session 
Mapping check box.

Note This returns the device to default port mapping mode. See Configuring the Cisco uMG9850 
QAM Module and Cisco uMG9820 QAM Gateway Installation and Configuration Guide for 
additional infomation on default port mapping.

Step 7 Click Apply to save all changes and keep the window open. Click OK to save the changes and close the 
window. Click Cancel to close the window and discard any changes.

Note (Cisco Catalyst switches only) Active video sessions must be stopped while the port map settings are 
changed. Stop the video sessions by temporarily disabling the VLAN bringing video into the switch. 
After port maps are changed, the VLAN can be enabled to allow active video streams.

Video session mapping cannot be changed if the Cisco uMG9850 is set to emulation mode.

Advanced Tasks

Configuring Maximum Jitter for a Session

(Cisco Catalyst switches only) You can set the maximum allowable network jitter (packet latency 
variation) for a specified UDP port session. This global video setting affects the overall packet latency 
(at the buffer level) within an entire Cisco uMG9850.

Note The jitter option sets the size of a dejittering buffer that absorbs the input jitter. This buffer introduces 
system delay (the time for a packet to enter and leave the Cisco uMG9850). The greater the value of jitter, 
the greater the delay introduced to the output stream. You can change the size of the dejitter buffer at 
either the slot or the session level. Changing it at the slot level changes the default value for jitter. 
(Consequently, for all sessions having the default value for jitter, the jitter value is changed to the new 
value. For sessions that have nondefault jitter values, their current jitter value is maintained.)

To configure maximum jitter:

Step 1 Go to Slot View, Jitter section (see Figure 3-51 on page 3-30).

Figure 3-51 Setting the Jitter Specification 

Step 2 Set the jitter. The range of values is 0 to 300 milliseconds. The default value is 100 milliseconds.
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Tip When setting the jitter value (the size of the dejitter buffer), take into consideration the network jitter 
(the inherent jitter introduced at the input of the Cisco uMG9850), and allow for clock tracking. Leave 
approximately 50 milliseconds for clock tracking. For example, if peak-to-peak network jitter is 100 
milliseconds, set the jitter value to 150 milliseconds.

The value for global timeout signal loss or slot-level timeout signal loss should always be larger than the 
value configured for jitter.

Step 3 Click Apply to save all changes and keep the window open. Click OK to save the changes and close the 
window. Click Cancel to close the window and discard any changes.

Setting Up PSI Parameters

You can set up various program-specific information (PSI) parameters, either globally (for the entire 
switch) or on an individual QAM channel.

Note If any sessions are active in the switch, new global Program Association Table (PAT) and Program Map 
Table (PMT) settings are rejected. Active sessions can be suspended while PAT and PMT variables are 
updated by disabling either the VLAN bringing video into the switch or the Ethernet port assigned to 
that VLAN.

Setting PMT and PAT Intervals for the Switch

Note This procedure applies to Cisco Catalyst switches only. It does not apply to the Cisco uMG9820 QAM 
Gateway.

The Program Association Table (PAT) interval sets the interval at which the PAT is distributed for all 
Cisco uMG9850 modules in the switch. Changing the default rate in this configuration mode overwrites 
the rate for the switch.

The Program Mapping Table (PMT) interval sets the interval at which the PMT is distributed to all 
Cisco uMG9850 modules in the switch. Changing the default rate in this configuration mode overwrites 
the rate for the switch.

To set PMT and PAT intervals for the switch:

Step 1 Go to Chassis View, Global Timers section (see Figure 3-52 on page 3-31).

Figure 3-52 Setting PSI Parameters (Switch) in Chassis View
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Step 2 Enter a value for the PAT interval. The range of values is 50 to 450 milliseconds. The default value is 
100 milliseconds.

Step 3 Enter a value for the PMT interval. The range of values is 50 to 450 milliseconds. The default value is 
100 milliseconds.

Step 4 Click Apply to save all changes and keep the window open. Click OK to save the changes and close the 
window. Click Cancel to close the window and discard any changes.

Setting PMT and PAT Intervals for a QAM Channel

These parameters set the intervals at which an individual QAM channel distributes the PAT and PMT.

To set these parameters:

Step 1 Go to QAM Channel View, Timers section. (See Figure 3-53)

Figure 3-53 Setting PSI Parameters

Step 2 Enter a value for the PAT interval. The range of values is 50 to 450 milliseconds. The default value is 
100 milliseconds.

Step 3 Enter a value for the PMT interval. The range of values is 50 to 450 milliseconds. The default value is 
100 milliseconds.

Step 4 Click Apply to save all changes and keep the window open. Click OK to save the changes and close the 
window. Click Cancel to close the window and discard any changes.

Setting TSID and NIT-PID Values

At each hub, each QAM channel must have a unique transport stream ID (TSID). The software checks 
for and guarantees the uniqueness of a TSID within a chassis only. These identifiers specify the TSID 
used to identify transport stream packets sent on the QAM channel and the packet ID (PID) used to 
identify Network Information Table (NIT) packets sent on a QAM port.

Caution It is the responsibility of the operator to avoid TSID conflicts among switches. To see all the TSIDs 
within a switch, look at the QAM Summary View.

The PID for the network information table, or NIT-PID, can be configured from the QAM interface. If 
the NIT-PID is already used as a video, audio, or data PID, the configuration is rejected.

For the transport stream that is to be transmitted over a QAM channel, you must configure the TSID and 
NIT-PID (network information table packet ID) values for that channel.

To set these parameters:

Step 1 Go to QAM Channel View, Identifiers section (see Figure 3-54 on page 3-33).
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Figure 3-54 Setting TSID and NIT-PID Values (in QAM Channel View)

Step 2 Set the value of the Transport Stream ID for the QAM channel. The range of values is 16 to 65535. By 
default, nonconflicting TSIDs are assigned to all modules in a chassis.

Step 3 Set the value of the Network Information Table packet ID for the QAM channel. The range in values is 
from 16 to 65536. The default value is 16.

Step 4 Click Apply to save all changes and keep the window open. Click OK to save the changes and close the 
window. Click Cancel to close the window and discard any changes.

Enabling or Disabling Ports and QAM Channels
Ports and QAM channels are enabled or disabled by setting the administrative status to up or down, 
respectively. To activate an Ethernet port, ASI port, or QAM channel, you must set the administrative 
status to up. If it is necessary to shut down a port or channel, set the administrative Status to down.

• For all types of Ethernet ports, use Ethernet Port View. 

• For ASI ports, use ASI Port View. 

• For QAM Ports, use QAM Channel View

Figure 3-55 Setting the Administrative Status in ASI Port View
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C H A P T E R 4

Monitoring Cisco QAM Gateway Devices

This chapter provides information on the monitoring of configured Cisco QAM Gateway devices to 
ensure proper operation of the network, including information that can be displayed with Cisco QAM 
Gateway Manager views and by using the command line interface within the application’s Telnet 
window.

• Navigation Tree, page 4-1

• Chassis View, page 4-2

• Slot View, page 4-3

• QAM Channel Summary View, page 4-5

• Telnet - CLI show commands, page 4-6

• Configuring the ASI Port for QAM Channel Routing, page 4-10

• Notification History Table, page 4-11

• Application Display Messages, page 4-13

Navigation Tree
Using the navigation tree, you can observe the status of all QAM, Ethernet, and ASI ports (see Figure 4-1 
on page 4-2). When administrative or operating status is down, an X will appear on the icon representing 
that port. To see the details for a specific port, double-click on the port. The detail QAM, Ethernet, or 
ASI port view will appear.
4-1
teway Manager User Guide, Release 1.0



  

Chapter 4      Monitoring Cisco QAM Gateway Devices
  Chassis View
Figure 4-1 Navigation Tree

Chassis View
The Chassis Status section of the Chassis View displays the components of the device. For each device, 
each slot number is listed along with the name of the card in that slot, the card type and, for 
Cisco Catalyst switches, the operating status. Power supplies and fan tray information also is included 
in the component list. (See Figure 4-2 and Figure 4-3 on page 4-3.)
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Figure 4-2 Chassis Status (Cisco Catalyst Switch)

Figure 4-3 Chassis Status (Cisco uMG9820)

Slot View
Using the Slot View QAM Channels Summary Status Table (see Figure 4-4 on page 4-4), you can 
monitor the status of all the QAM channels in a specific slot. For each QAM channel, the administrative 
and link status (green for up and red for down), and the number of sessions on that channel are listed.
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Figure 4-4 Slot View QAM Channels Summary Status

For Cisco Catalyst switches only, the Ethernet Ports and ASI Port Summary Status Table lists the 
administrative and link status for Ethernet and ASI ports on the slot—green for up and red for down. 
(See Figure 4-5.) Double-click on the Ethernet or ASI ports to access the Ethernet or ASI port views.

Figure 4-5 Slot View Ethernet Ports and ASI Port Summary Status

Note For the Cisco uMG9820, double-click on a processor card in the navigation tree to access ASI and 
Ethernet ports.
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QAM Channel Summary View
The QAM Summary View (see Figure 4-6 on page 4-5) shows on one screen the current configurations 
for all QAMs in a slot for the following parameters:

• Administrative status

• RF frequency

• Power

• Modulation format

• Interleaver level

• Interleaver mode

• TSID

• PAT interval

• PMT interval

Figure 4-6 QAM Channel Summary View

Note This view also can be used to configure these parameters. 

Tip Right-click on a field to copy a value to all other fields in that column.
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Telnet - CLI show commands
A variety of show commands provides additional information about the configuration and operation of 
the devices managed by Cisco QAM Gateway Manager. These commands can be entered using the CLI 
in the Telnet window. For instructions on how to use the Telnet window, see the “Using the Telnet 
Window” section on page 3-17. For further information regarding the command-line interface and the 
commands themselves, including sample output, refer to Configuring the uMG9850 QAM Module, Cisco 
Catalyst switch documentation listed in the “Related Documentation” section on page ix, or the Cisco 
uMG9820 QAM Gateway Installation and Configuration Guide.

Cisco Catalyst Switches
Table 4-1 describes common show commands for the Cisco Catalyst switch that can be useful for 
determining status of the switch related to video configuration and operation.

Table 4-1 Cisco Catalyst Switch Show Commands

Show Command Description

show interface asi interface video View information about a single QAM channel routed to the output 
ASI interface:

• Port status 

• QAM channel routed to the ASI interface

• Program details (if available).

show interface qam interface video View video information about both channels on an output QAM 
interface: 

• Number of active QAMs and QAM status (up/down)

• QAM modulator group number

• TSID, NIT PID, and PSI interface values

• Upconverter frequency and power, and QAM modulation type

• Port error status

show interface qam interface.qam video View video information about a single QAM channel:

• Number of programs and active sessions

• TSID and NIT-PID information

• Packets per second and bit rate through the channel

• Active trick modes

• Video and audio format for each session

• QAM error status (such as oversubscribed, underflow)

show interface qam interface.qam video portmap View information about the UDP portmaps on an output QAM 
interface:

• UDP port number, in decimal and hexadecimal

• Output program number
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show video slot View information related to the modulator groups, including frequency 
and power:

• Active modulator groups

• Upconverter frequency and power for each channel

show video slot psi session View program-specific information (PSI) related to the input for a 
selected Cisco uMG9850:

• UDP port number and session status

• PSI parameters

• Source program

• Streams and stream types

show video slot route View video route information related to the input for a selected Cisco 
uMG9850:

• VLAN number and ip-address

show video slot session View a variety of video details related to sessions for a selected Cisco 
uMG9850:

• For all sessions:

– All session information

– Input errors

– CC errors

– Sync loss

– Sender information (source IP address and UDP for each 
session)

• For a specified session:

– Session start time

– Source IP address

– Input CC errors

– Jitter (peak, average)

– Source data rate

show video slot ts_table View the transport stream ID (TSID) table for each QAM channel for 
a selected Cisco uMG9850:

• TSID for each QAM channel

show video slot version View software and hardware version information for a selected 
Cisco uMG9850:

• Hardware details

• Software details

show {running-config | startup-config} View running configuration or startup configuration for the device.

Table 4-1 Cisco Catalyst Switch Show Commands (continued)

Show Command Description
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Cisco uMG9820 QAM Gateway
Table 4-2 describes common show commands for the Cisco uMG9820 QAM Gateway that can be useful 
for determining configuration and status of the uMG9820.

Table 4-2 Cisco uMG9820 QAM Gateway Show Commands

Show Command Description

show interface asi slot/port View interface statistics for the ASI port:

• Port status

• Input packets

• Input bytes

show interface gigabitethernet slot/port View packet and buffer statistics for the specified GE port:

• Port status

• Hardware address

• MTU

• Bandwidth

• Encapsulation

• Duplex

• Flow control status

• ARP type

• Input and output rate

show ip interface gigabitethernet slot/port View the status of the specified GE port:

• Link status (up or down)

• Packet and buffer counters

show interface gigabitethernet slot/port video 
[session UDP-port-number]

View all session information:

• User-defined session parameters

• Session status (inactive, active, invalid program specific 
information (PSI)

• Jitter buffer status (underflow and overflow count) and average 
fullness

• Continuity count errors

show interface gigabitethernet slot/port video psi 
[session UDP-port-number]

View all PSI information:

• Program number

• elementary stream ID

• PIDs

show interface fastethernet slot/port View statistics for the specified FE port:

• Packet statistics

• Buffer statistics
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show ip interface fastethernet slot/port View port status:

• Link status (up or down)

• Packet and buffer counters

show interface qam slot/port.qam View QAM statistics for a specified QAM channel:

• Output frequency

• Output RF power level

• QAM mode

• Interleaver depth

• Alarm codes

show interface qam slot/port.qam video View video program data for a specified QAM channel:

• Transport stream ID (TSID) and NIT PID

• PAT and PMT interval

• Bitrate through this QAM

• PSI data for each program

show video session {active | all UDP-port-number} View video session information for all active sessions, for all sessions 
(active and inactive) or a specified UDP session:

• State

• Source IP

• Destination UDP

• Maps to QAM

show {running-config | startup-config} View running configuration or startup configuration for the device.

show env temperature View environmental statistics related to temperature

• PCB temperature

• CPU temperature

• GE temperature

• Midplane temperature

• PCR FPGA temperature

show env fan View environmental statistics related to the fan:

• RPM for each fan

show env power View environmental statistics related to the power:

• Processor card voltage

• CPU voltage

• FPGA voltage

• Battery voltage

show env all View all environmental statistics for temperature, fan, and power.

show env alarms View environmental alarms (if any). 

Table 4-2 Cisco uMG9820 QAM Gateway Show Commands (continued)

Show Command Description
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Configuring the ASI Port for QAM Channel Routing
Using the Asynchronous serial interface (ASI) port, you can set or change the gap spacing of data bytes 
in the ASI port output and route the input of a single QAM channel to the ASI port to monitor the 
channel. 

Note Routing the input of a QAM channel to the ASI port does not disrupt the RF output.

Setting the Byte-Gap Value (S-Rate) of the ASI Port
(Cisco Catalyst switches only) You can change the gap spacing of the data bytes in the output of the ASI 
port. The S-rate is the spacing of data bytes (the number of ASI transport null bytes between the data 
bytes) within the output transport stream. If there is not a sufficient number of data bytes in the stream, 
padding the stream with null bytes maintains the signal voltage and integrity. 

To set byte gap:

Step 1 Go to ASI Port View. (See Figure 4-7.)

Figure 4-7 Setting the Byte-Gap Value

Step 2 Enter a value for byte gap.

show version View software component version numbers.

Show umg9820 View hardware component statistics, including:

• Hardware revision numbers

• System serial numbers, model numbers and part numbers

• MAC addresses

• Component model numbers, CLEI numbers, serial numbers, and 
part numbers

Table 4-2 Cisco uMG9820 QAM Gateway Show Commands (continued)

Show Command Description
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Step 3 Click Apply to save all changes and keep the window open. Click OK to save the changes and close the 
window. Click Cancel to close the window without any changes.

Routing the Output of a QAM Channel to the ASI Port
You can route the output of a QAM channel (a single program) to the asynchronous serial interface (ASI) 
port (in ASI signaling format), to monitor the output of the channel. Use a video decoder to view the 
selected program. 

Note For Cisco uMG9850 QAM modules, the ASI port is always addressed as slot/15.

To configure this parameter:

Step 1 Go to ASI Port View (see Figure 4-7).

Step 2 In the QAM Routed menu, choose the QAM whose output you want directed to the ASI port.

Step 3 Click Apply to save all changes and keep the window open. Click OK to save the changes and close the 
window. Click Cancel to close the window without any changes.

Notification History Table

Setting and Monitoring Utilization Thresholds
It is possible that a given QAM channel can be either overwhelmed or underutilized. To monitor and 
correct for this, you can set both minimum and maximum bandwidth-utilization thresholds for video 
streams over a QAM channel. If the percentage of QAM bandwidth being used is below the value for the 
low utilization threshold, then the QAM channel is being underutilized. If the percentage of QAM 
bandwidth being used is above the value for high utilization threshold, then the QAM channel is being 
overutilized.

Note The high utilization threshold must be greater than the low utilization threshold.

To specify the high and low utilization thresholds for video streams, do the following:

Step 1 Go to QAM Channel Configuration View, Utilization section (see Figure 4-8).

Figure 4-8 Low and High Threshold Utilization Settings
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Step 2 Set the Low Utilization Threshold. The range of values is 0 to 95%. The default value is 0%.

Step 3 Set the high Utilization Threshold. The range of values is 5 to 95%. The default value is 75%.

Step 4 Click Apply to save all changes and keep the window open. Click OK to close the window and save all 
changes. Click Cancel to close the window and discard all changes.

If the percentage of QAM bandwidth being used drops below the low threshold or climbs above the high 
threshold, an entry appears in the Notification History table (see Figure 4-9).

Figure 4-9 Notification History Table
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Warning Messages in Notification History Table

Error Message The video session nnnn has invalid PSI data

Explanation Data arriving at a VoD-enabled port does not conform to standard MPEG data. MPEG 
data must have PSI tables embedded within it for a receiver to correctly map the contents.

Error Message Utilization has gone above the higher threshold value

Explanation The QAM channel is being overutilized.

Error Message Utilization has fallen below the lower threshold value.

Explanation The QAM channel is being underutilized.

Recommended Action TBD

Application Display Messages
Cisco QAM Gateway Manager is already running.

You have launched more than one instance of the application. Ensure that all but one instance has 
been closed.

Apply changes?

Configuration changes have been made. Do you want to copy them to the running configuration?

Configuration successful.

The configuration has been copied to the running configuration of the device.

Configuration loaded to device at ip-address from TFTP server tftp-server-ip-address.

The configuration from the specified TFTP server has successfully loaded to the device at the 
specified IP address.

Startup configuration of device at ip-address saved to TFTP server ip-address.

The startup configuration of the specified device was successfully saved to the specified TFTP 
server.

Running configuration of device at ip-address saved.

The running configuration of the specified device was successfully saved to a TFTP server.

Running configuration saved to startup configuration for device at ip-address.

The running configuration of the specified device was successfully saved to the device’s startup 
configuration.

Too many views open. Please close unneeded views.

The maximum number of simultaneously open views has been reached. In order to open additional 
views, some of the currently unneeded views must be closed.
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Number of active sessions in device at ip-address has changed. Sessions will be rediscovered.

The number of active sessions has changed in the device at the specified address. The sessions will 
be re-evaluated.

Enter value between lower value and upper value.

An out of range value has been entered. Enter a new value between these two.

SNMP error occurred while configuring parameter on device at ip-address. Reason: reason

An SNMP error has occurred during configuration. Possible reasons are:

Request timed out.

SNMP response exceeds size limitation.

Variable name not found in MIB.

MIB object/instance is read-only.

Object value cannot be retrieved.

Invalid community string or access credentials.

Value/type mismatch.

Value length exceeded.

Wrong encoding for object.

Value not compatible with MIB.

Trying to create or set a nonexistent variable.

MIB variable may be in inconsistent state, not accepting set requests.

System resources unavailable for set/get operations.

Set commit has failed.

Set operation has failed, agent unable to roll back.

SNMP command cannot be authenticated, or incorrect community string found.

MIB object not responding to set operations: read-only access or incorrect community string.

Set operation failed: variable in inconsistent state.

SNMP Error: Unknown host.

The host is not recognized.

Select Cisco QAM Gateway Manager or QAM gateway from navigation tree.

Attempting to configure SNMP parameters, but neither the root (Cisco QAM Gateway Manager) nor 
a device is selected in the navigation tree. Select the root to configure polling interval or the device 
to configure SNMP parameters IP address and community string.

Invalid IP address/ host name or community string.

Device is being added and Cisco QAM Gateway Manager cannot make an SNMP query to the 
device.

Select a QAM gateway from the navigation tree.

View > Chassis was chosen before a device was selected in the navigation tree.

Select a uMG9850 slot or a uMG9820 QAM card slot.

View > Slot or View > Sessions was chosen before a slot was selected in the navigation tree.

All Sessions view not supported for uMG9820.
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View > All Sessions is chosen for the uMG9820 slot. Either select View > Sessions, or select a 
uMG9850 slot.

Select a device.

File > Load Configuration or File > Save Configuration was chosen before a device was selected 
in the navigation tree.

Unable to load configuration from TFTP server at ip-address. Please enter file name.

There was an error while loading a configuration from the TFTP server. File name is required.

Unknown error occurred while refreshing device at ip-address. Continue refreshing?

An undetermined error occurred while refreshing the named device. Do you want to keep trying to 
refresh this device?

Device at ip-address inaccessible. Continue refreshing?

A device in the history file is not accessible, or the device is not reachable during a refresh. Do you 
want to keep trying to refresh this device?

Device at ip-address has timed out. Continue refreshing?

The device has timed out during a refresh. Do you want to keep trying to refresh this device?

ASI byte-gap value out of range.

The value entered is out of range. Enter a value from 1 to 4.

VLANs not applicable to uMG9820.

Configure VLAN has been chosen while a uMG9820 is selected in the navigation tree. VLANs only 
can be configured for Cisco Catalyst switches.

Select a Cisco Catalyst switch in navigation tree.

This function requires selection of a Cisco Catalyst Switch.

uMG9850 is in emulation mode; sessions cannot be mapped.

The uMG9850 is running in emulation mode. Video sessions mapping cannot be done in emulation 
mode.
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