Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
More options
HP.com home
HP-UX Virtual Partitions Administrator’s Guide > Chapter 5 vPars Monitor and Shell Commands

Other Boot Modes

» 

Technical documentation

Complete book in PDF
» Feedback
Content starts here

 » Table of Contents

 » Glossary

 » Index

In the same way you can boot a virtual partition into single-user mode (see “Single-User Mode”), you can boot a partition using other boot options. The general syntax is:

From MON>

MON> vparload -p <target_partition> <boot_options>

or

From HP-UX shell prompt

<active_partition># vparboot -p <target_partition> -o "<boot_options>"

Examples, including using maintenance mode with LVM and overriding quorum with Mirror-UX, are shown below. For more information on all the boot options, see the manpage hpux(1M).

Maintenance Mode

When troubleshooting LVM, you may need to enter into maintenance mode using the -lm option. For more information on maintenance mode, see the manual Managing Systems and Workgroups (11.11, 11.23) or HP-UX Systems Administrator’s Guide: Logical Volume Management (11.31), available at http://docs.hp.com.

On a non-vPars server, you would boot the server into maintenance mode by executing the following:

ISL> hpux -lm

On a vPars server, you specify the same -lm option but as an argument to either the vPars Monitor vparload command or as a -o option to the shell vparboot command.

For example, if the partition winona2 is down, to boot winona2 into maintenance mode:

From MON>

From the vPars Monitor prompt:

MON> vparload -p winona2 -o "-lm"

From HP-UX shell prompt

From the running partition winona1:

winona1# vparboot -p winona2 -o "-lm"

Overriding Quorum

In LVM, when the root disk is mirrored, the server can only activate the root volume group, which contains the OS instance, when the majority of the physical volumes in a root volume group are present at boot time. This is called establishing a quorum. Sometimes, you may want to boot an OS instance regardless of whether a quorum is established. You can override the quorum requirement by using the -lq option. For more information on quorum requirements, see the manual Managing Systems and Workgroups (11.11, 11.23) or HP-UX Systems Administrator’s Guide: Logical Volume Management (11.31),.

On a non-vPars server, you would boot overriding quorum using:

hpux -lq

On a vPars server, you can execute either of the following:

From MON>

From the vPars Monitor prompt, to boot winona2 overriding the quorum requirement:

MON> vparload -p winona2 -o "-lq"

From HP-UX shell prompt

From the running virtual partition winona1, to boot winona2 overriding the quorum requirement:

winona1# vparboot -p winona2 -o "-lq"

NOTE: Specifying the boot options from the command line only affects the current boot.

On a non-vPars server, to have a server permanently boot with the -lq option, you would put "hpux -lq" (PA-RISC) or "boot vmunix -lq" (Integrity) in the LIF AUTO file. On a vPars server, to have a partition boot with the -lq option, you would simulate the AUTO file usage by entering the -lq option into the partition database. See “The AUTO File on a Virtual Partition”.

Changing the LVM Boot Device Hardware Path for a Virtual Partition

Example

Below are the steps to move the root disk of a single virtual partition.

Verification

These instructions require that the virtual partition be constrained in the following way: the logical volume used for the primary swap device must be on the boot device; in other words, boot and swap must be on the same disk device.

This can be verified by the following steps:

  1. Run lvlnboot.

    lvlnboot -v /dev/vg00

  2. Examine the output to identify the “Boot” and “Swap” logical volumes. For example:

    Boot: lvol1 on: /dev/dsk/c1t6d0 Swap: lvol2 on: /dev/dsk/c1t6d0
  3. Make sure that the boot and swap logical volumes are on the same device.

    CAUTION: If the boot and swap logical volumes are not on the same device, do not proceed with these instructions. You will need to contact HP for assistance.

Preparation

Before changing the hardware path of the boot device:

  1. Create a mapfile for the root volume group. Keep the mapfile in the root (/) directory, so that it is accessible during single user mode boot.

    vgexport -p -m /mapfile.vg00 /dev/vg00

  2. Get a list of physical volumes (PVs) in the root volume group. Keep the PV list file in the root (/) directory, so that it is accessible during single user mode boot.

    vgexport -p -f /pvs.vg00 /dev/vg00

  3. You may now shutdown the virtual partition and physically move the disk.

Change the boot device hardware path

  1. From another virtual partition, change the target virtual partition attributes

    vparmodify -p partition_name -a io:new_path:boot -B manual vparmodify -p partition_name -d io:old_path

    where

    • partition_name is the target virtual partition

    • new_path is the new hardware path of the disk

    • old_path is the old hardware path of the disk

  2. Verify the attributes

    vparstatus -v -p partition_name

Boot into LVM maintenance mode

  • Boot the target virtual partition into LVM maintenance mode. For example, at the vPars Monitor prompt:

    MON> vparload -o -lm -p partition_name

LVM maintenance mode steps

  1. Once the partition comes up in LVM maintenance mode, run ioscan to get the device filename of the boot device

    ioscan -fnkCdisk

    If the device filename (/dev/dsk/file) is new, use insf to install the special files in/dev directory.

  2. Run vgscan to get the device filenames grouped with the boot device.

    vgscan

  3. Remove the old information about root volume group.

    vgexport /dev/vg00

    You may have to remove/etc/lvmtab.

  4. Prepare to import the root volume group (vg00).

    mkdir /dev/vg00 mknod /dev/vg00/group c 64 0x000000
  5. Import the root volume group (vg00). For example:

    vgimport -m /mapfile.vg00 /dev/vg00 /dev/dsk/c1t1d0 /dev/dsk/c1t1d1

    where the device filenames are obtained from the ioscan and vgscan above

  6. Activate the root volume group (vg00):

    vgchange -a y /dev/vg00

    You may also have to cleanup and prepare LVM logical volume to be root, boot, primary swap, or dump volume as follows:

    lvrmboot -r /dev/vg00 lvlnboot -b /dev/vg00/lvol1 lvlnboot -r /dev/vg00/lvol3 lvlnboot -s /dev/vg00/lvol2 lvlnboot -d /dev/vg00/lvol2 mount
  7. Verify that the hardware path for the boot device matches the primary boot path.

    lvlnboot -v /dev/vg00

  8. If the hardware path has not changed to the primary boot path, change it by running lvlnboot with the recovery (-R) option. This step is normally not necessary.

    lvlnboot -R /dev/vg00

  9. Reboot the target virtual partition.

Printable version
Privacy statement Using this site means you accept its terms Feedback to webmaster
© 2008 Hewlett-Packard Development Company, L.P.