Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
More options
HP.com home
HP-UX Reference > V

vgchange(1M)

HP-UX 11i Version 3: February 2007
» 

Technical documentation

» Feedback
Content starts here

 » Table of Contents

 » Index

NAME

vgchange — set LVM volume group availability

SYNOPSIS

Activate volume group

/usr/sbin/vgchange -a availability [-l] [-p] [-q quorum] [-s] [-P resync_daemon_count] [vg_name...]

Set volume group high-availability cluster attributes

/usr/sbin/vgchange -c cluster [-S sharable] vg_name

Change activation mode of sharable volume group

/usr/sbin/vgchange -a availability -x {vg_name...}

Quiesce an active volume group

/usr/sbin/vgchange -Q quiesce_mode [-t quiesce_time] vg_name

Resume a quiesced volume group

/usr/sbin/vgchange -R vg_name

Remarks

MC/ServiceGuard cluster operations require the installation of the optional MC/ServiceGuard software, which is not included in the standard HP-UX operating system.

Mirrored disk operations require the installation of the optional HP MirrorDisk/UX software, which is not included in the standard HP-UX operating system.

DESCRIPTION

The vgchange command with the -a option activates or deactivates one or more volume groups.

For volume groups that are used in a high availability cluster, when the -a option is specified together with the -x option, the vgchange command allows cross-activation, changing the activation mode of an active sharable volume group directly to the specified activation mode, without first having to deactivate the volume group.

The vgchange command with the -c specifies whether the indicated volume group(s) can be used in a high availability cluster, optionally the -S option can also be specified to configure whether the volume group is sharable (or is for exclusive activation only).

The vgchange command without the -P resync_daemon_count option (default) will spawn one nomwcsyncd process for each volume group containing NOMWC logical volumes, and this can degrade system performance when many of these volume groups are activated at the same time. The -P resync_daemon_count option provides a way to control the number of concurrent nomwcsyncd processes spawned. This parameter is advisory, LVM may use a different value internally as necessary.

The -Q option allows quiescing an active volume group to facilitate creating a consistent disk snapshot copy of all the physical volumes in the volume group. Metadata on the physical volumes is brought current and remains unchanged until normal operation is resumed using the -R option (or when the optionally specified -t quiesce_time time has expired). Specifying -Q rw when quiescing the volume group quiesces application reads and writes to the volume group. This mode is suitable for most situations. Specifying -Q w when quiescing the volume group quiesces application writes to the volume group while allowing reads to proceed as usual. This mode provides improved access to the data when used with applications that are capable of quiescing updates while allowing queries. See the Quiesced Volume Groups section for a more complete description of quiesced volume groups.

vg_name must be defined as a volume group in the file /etc/lvmtab. If vg_name is omitted, all volume groups defined in /etc/lvmtab are affected, except when the -c -x -Q or -R options are specified. Only a single volume group can be provided with these options.

High Availability Cluster Overview

Volume groups can be defined on disk volumes that are accessible by more than one system in a high availability cluster. This situation has a high potential for data corruption unless higher level cluster software services are used to coordinate shared access to the same volume group by all systems.

A volume group can be marked as part of a cluster. When such a group is activated in exclusive mode, it can be accessed for exclusive read-write activity by only one of the systems at a time; the other systems can have read-only access to the data. When the volume group is also marked as sharable, it may be activated in shared mode for read-write access by all the nodes in the cluster.

The configuration of a shared volume group can be changed only if it is activated in exclusive mode. Cross-activation between shared and exclusive modes of shared volume groups is possible with the -x option to vgchange.

Simultaneously quiescing a volume group on all the systems sharing the volume group can be accomplished by invoking vgchange with the -Q option from any node in the cluster. A ServiceGuard cluster-lock volume group cannot be quiesced, because initializing or updating the cluster-lock requires writing to the disk.

Options and Arguments

vgchange recognizes the following options and arguments:

vg_name

The path name of a volume group.

-a availability

Set volume group availability. availability can have one of the following values:

y

Activate each specified volume group and all associated physical and logical volumes for read-write access. If a volume group is marked as part of a high availability cluster, it is activated in exclusive read-write mode, as for the -a e option.

e

Activate each specified volume group and all associated physical and logical volumes for exclusive read-write access. The volume group must be marked as part of a high availability cluster, and the availability software must be running on the system; otherwise, the volume group is not activated.

With the -x option, the activation mode of a shared volume group is changed to exclusive. The volume group will remain active during the operation. The operation will not be performed if the volume group is active in more than one node, or if it is not currently in shared mode.

s

Activate each specified volume group and all associated physical and logical volume for shared read-write access. The volume group must be marked as part of a high availability cluster and marked sharable; otherwise, the volume group is not activated.

Please note HP MirrorDisk/UX software is only supported in a clustered environment with a maximum of two nodes configured.

With the -x option, the activation mode of a shared volume group is changed to shared. The volume group will remain active during the operation. The operation will only be performed if the current activation mode of the volume group is exclusive.

If the -a y or -a e option is executed on a currently active volume group, without the -x option, vgchange attempts to include any physical volumes that were previously listed as missing. This is useful if a physical volume has come back online. However, no automatic synchronization of any mirrored logical volumes is done. If synchronization is required, execute the vgsync command (see vgsync(1M)).

r

Activate each specified volume group and all associated physical and logical volumes for read-only access. This option is ignored for a volume group that is already activated.

If a volume group is marked as part of a high availability cluster, the high availability software must be running on the system; otherwise, the volume group is not activated.

n

Deactivate each specified volume group and its associated logical volumes. You must close the logical volumes prior to executing this option. For example, if the logical volume contains a file system, the file system must be unmounted.

-c cluster

Control the membership of volume groups in a high availability cluster. cluster can have one of the following values:

y

Mark each specified volume group as a member of a high availability cluster. The high availability software must be running; otherwise, the volume group is not marked. Needs to be done on one node only. -S may be optionally specified with the -c option to indicate whether the VG is sharable, and when the -c option is used without -S the VG is marked not sharable.

n

Remove each specified volume group from membership in the high availability cluster. The high availability software does not have to be running to perform this operation.

The volume group must be deactivated with the -a n option before a -c y|n option can be executed.

-l

Disable the opening of logical volumes that belong to each specified volume group. If the -l option is set, later attempts to open the logical volumes will fail. To allow an opening of these logical volumes to succeed, execute lvchange -a y.

-p

Activate each specified volume group only if all of the physical volumes that belong to it are available.

-q quorum

Set the quorum enforcement for each specified volume group. quorum can have one of the following values:

y

Enforce the quorum requirement. This is the default.

n

Ignore the quorum requirement.

The -q n option can be used to activate the volume group when the disk quorum is not maintained because too many disks were lost. Since it ensures the integrity of the LVM configuration information, it is normally not advisable to override the quorum.

-s

Disable the synchronization of stale physical extents within the volume group specified by vg_name. This option is only effective when used with the -a y or -a e option.

-t quiesce_time

Automatically resume normal read/write access to the volume group once the specified quiesce_time (in seconds) has expired. This option should be used when quiescing a volume group that contains critical resources (e.g., root or swap logical volume) that are necessary for normal operation of the system, or other circumstances where manually executing the vgchange -R may not be possible once the volume group is quiesced. The quiesce_time can be any value from 1 to 2^31-1. This option is only valid when used with the -Q option.

-x

Cross-activate a active sharable volume group, changing the activation mode to the specified activation mode. This option is only valid when used with the -a availability option. Cross-activation can only be used to change the activation mode from shared mode to exclusive mode, or from exclusive mode to shared mode.

-P resync_daemon_count

specify the advisory count to control the number of nomwcsyncd threads spawned for NOMWC processing when activating the volume group(s). Specifying a resync_daemon_count of 0 causes a reasonable number of threads to be spawned (currently defined to be 4).

-Q quiesce_mode

Quiesce an active volume group to guarantee that the LVM metadata is consistent. This allows a system administrator to perform a snapshot of all the disks in the volume group. The volume group remains quiesced until it is resumed again using the -R option or automatically after the optionally specified quiesce_time (given using the -t option) has expired. See the Quiesced Volume Groups section for a more complete description of quiesced volume groups. The quiesce_mode can have one of the following values:

rw

Quiesce both reads and writes to the volume group.

w

Quiesce writes to the volume group. Applications may open and read from logical volumes belonging to the volume group.

-R

Resume a previously quiesced volume group. I/O that was quiesced is allowed to complete. LVM commands and resync operations are enabled. See the Quiesced Volume Groups section for a more complete description of quiesced volume groups.

-S sharable

Control the sharability of volume groups in a high availability cluster. sharable can have one of the following values:

y

Mark each specified volume group as sharable. The high availability software must be running; otherwise, the volume group is not marked. This only has to be done from one node of the cluster.

n

Remove the shared attribute from the volume group. The high availability software does not have to be running to perform this operation.

The volume group must be deactivated with the -a n option before a -S y|n option can be executed.

Mirrored Disk Activation

When the optional HP MirrorDisk/UX software is running and a volume group is activated, LVM performs the necessary mirror consistency recovery for each logical volume in the volume group based on the state of Mirror Write Cache and Mirror Consistency Recovery (see the Consistency Recovery section of lvdisplay(1M)). In a non-shared environment, LVM supports MWC, NOMWC and the NONE recovery. But in shared environment, LVM only supports NOMWC and the NONE recovery.

MWC

Recover mirror consistency by using the Mirror Write Cache and Mirror Consistency Record. This mode implies that the Mirror Write Cache is on.

NOMWC

Recover mirror consistency by searching all logical extents and copying data from a non-stale copy to all the other mirror copies. This mode implies that the Mirror Write Cache is off.

NONE

Do not recover mirror consistency during volume group activation on this logical volume following a system crash. This mode implies that the Mirror Write Cache is off.

Once mirror consistency is recovered using the configured policy, the mirrors are resynchronized (any stale extents made current) by copying data from a non-stale copy to the stale mirror copies. If the -s option is specified on the command line, mirror synchronization does not occur. However, for those logical volumes that have Mirror Write Cache turned off, mirror synchronization is done independently of whether the -s option appears on the command line.

General Activation

If vgchange cannot access a physical volume, it lists the volume's status as missing. If too many physical volumes in the volume group are missing, vgchange reports that the group does not have a quorum and cannot be activated. The lack of a quorum can be overridden with the -q n option.

Quiesced Volume Groups

A quiesced volume group presents a stable and consistent disk image suitable for creating snapshot copies of the disks in the volume group.

Quiesced volume groups have the following characteristics:

  • The physical volumes in the volume group appear as though the logical volumes were closed and the volume group was deactivated. They remain unchanged until the vgchange -R command is issued to resume access to the VG or until the optionally specified quiesce_time has expired.

  • When -Q rw is specified, reads and writes are queued until the volume group is resumed. When -Q w is specified, reads proceed as usual, but writes are queued until the volume group is resumed. In the latter case, reading from the volume group will return the last data written before the volume group was quiesced.

  • LVM display commands are allowed to proceed as usual.

  • LVM mirror resynchronization and configuration commands are rejected.

  • I/O that is queued because a volume group is quiesced will not be completed until after the volume group is resumed, regardless of any logical volume I/O timeout that is set on the LVs. Some applications may be sensitive to this delay and could report errors or warnings as a result.

EXTERNAL INFLUENCES

Environment Variables

LANG determines the language in which messages are displayed.

If LANG is not specified or is null, it defaults to "C" (see lang(5)).

If any internationalization variable contains an invalid setting, all internationalization variables default to "C" (see environ(5)).

EXAMPLES

Activate volume group /dev/vg03:

vgchange -a y /dev/vg03

Deactivate volume group /dev/vg03:

vgchange -a n /dev/vg03

Activate volume group /dev/vg03 without synchronizing extents that are not current on logical volumes that have Mirror Write Cache turned on:

vgchange -a y -s /dev/vg03

Exclusive Activation

Set up volume group /dev/vg03 for use in a high availability cluster:

vgchange -a n /dev/vg03 # Deactivate volume group vgchange -c y /dev/vg03 # Enable volume group for HA cluster vgchange -c y -S y /dev/vg03 # Enable volume group for HA cluster and mark as sharable vgchange -a e /dev/vg03 # Activate volume group in exclusive mode vgchange -a s /dev/vg03 # Activate volume group in shared mode

Activate all volume groups; activate those that are marked for membership in a high availability cluster in shared mode:

vgchange -a y

Activate all volumes that are marked for membership in a high availability cluster in exclusive mode:

vgchange -a e

Cross Activation

Set up volume group /dev/sh_vg for use in a high availability cluster.

To make configuration changes, to a volume group activated in shared mode, deactivate the volume group by executing the following command on each cluster node except one:

vgchange -a n sh_vg

On the single node, where the volume group is active:

  • vgchange -a e -x sh_vg # Change mode to exclusive

  • vgchange -a s -x sh_vg # After configuration change, change

    # mode back to shared

Quiescing a Volume Group

Quiesce LVM metadata writes and application reads and writes to volume group /dev/vg03:

vgchange -Q rw /dev/vg03

Quiesce LVM metadata and application writes but allow application reads to volume group /dev/vg03:

vgchange -Q w /dev/vg03

Resume normal reads and writes to volume group /dev/vg03 (after having quiesced them earlier) :

vgchange -R /dev/vg03

Quiesce volume group /dev/vg03 quiescing both reads and writes and automatically resume normal read/write access in 600 seconds:

vgchange -Q rw -t 600 /dev/vg03

WARNINGS

Ordinary Operation

In ordinary operation (that is, without the optional high availability software), it is possible to activate a volume group for read-write access from more than one physically connected system, leading to a high potential for data corruption. Therefore, if access is desired from more than one system to a single volume group, it is important that only one system activate the volume group for read-write access; the other systems can use read-only access. There is no problem if all systems activate the volume group for read-only access.

Furthermore, volume group information is only read from the disks during volume group activation. Dynamic changes to the volume group such as the following are not propagated to other systems sharing the volume group:

  • Logical volume configuration changes.

  • Changes to the status of the mirrored extents.

  • Bad-block relocation that occurs during write operations.

Because of these limitations, when sharing volume groups between systems it is recommended that logical volumes be accessed only by one system at a time. If logical volumes must be accessed simultaneously, the logical volumes should not be mirrored and should not have bad-block relocation turned on, or all systems should use read-only access to the logical volumes.

SEE ALSO

mount(1M), vgcreate(1M), vgdisplay(1M), vgextend(1M), vgreduce(1M).

If MC/ServiceGuard is installed: cmcheckconf(1M), cmquerycl(1M), and Managing MC/ServiceGuard.

Printable version
Privacy statement Using this site means you accept its terms Feedback to webmaster
© 1983-2007 Hewlett-Packard Development Company, L.P.