Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
More options
HP.com home
HP-UX Reference > T

term(5)

ENHANCED CURSES
HP-UX 11i Version 3: February 2007
» 

Technical documentation

» Feedback
Content starts here

 » Table of Contents

 » Index

NAME

term — terminal capabilities

SYNOPSIS

#include <term.h>

DESCRIPTION

The following data type is defined through typedef:

TERMINAL

An opaque representation of the capabilities for a single terminal from the terminfo database.

The <term.h> header provides a declaration for the following object: cur_term . It represents the current terminal record from the terminfo database that the application has selected by calling set_curterm().

The <term.h> header contains the variable names listed in the Variable column in the table in Defined Capabilities in terminfo(4).

The following are declared as functions, and may also be defined as macros:

int del_curterm(TERMINAL *oterm); int putp(char *const str); int restartterm(char *term, int fildes, int *errret); TERMINAL * set_curterm(TERMINAL *nterm); int setupterm(char *term, int fildes, int *errret); int tgetent(char *bp, char *const name); int tgetflag(char id[2]); int tgetnum(char id[2]); char * tgetstr(char id[2], char **area); char * tgoto(char *const cap, int col, int row); int tigetflag(char *capname); int tigetnum(char *capname); char * tigetstr(char *capname); char * tparm(char *cap, long p1, long p2, long p3, long p4, long p5, long p6, long p7, long p8, long p9); int tputs(char *const str, int affcnt, int (*putfunc)(int));

SEE ALSO

terminfo(4), printf(1), putp(3X), tigetflag(3X), tgetent(3X), <curses.h>.

CHANGE HISTORY

First released in X/Open Curses, Issue 4.

Printable version
Privacy statement Using this site means you accept its terms Feedback to webmaster
© 1983-2007 Hewlett-Packard Development Company, L.P.