Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
More options
HP.com home
HP-UX Reference > S

scsimgr_esdisk(7)

HP-UX 11i Version 3: February 2007
» 

Technical documentation

» Feedback
Content starts here

 » Table of Contents

 » Index

NAME

scsimgr_esdisk — SCSI class driver esdisk plug-in for scsimgr

DESCRIPTION

The SCSI class driver esdisk plug-in for scsimgr implements management and diagnostic operations specific to classes of devices bound to the esdisk driver. esdisk is the native HP-UX SCSI class driver that handles, by default, all block devices including the following types : direct access, CD/DVD, write-once read-multiple (WORM), and optical memory (OM).

The plug-in handles the following operations for driver esdisk:

  • Displays and clears driver esdisk global statistics and the statistics it maintains on instances of LUNs bound to it, and on related LUN paths.

  • Displays status and other information maintained by driver esdisk on LUNs bound to it.

  • Gets, sets, and saves driver esdisk global, per-lun instance attributes or attributes for a set of devices bound to the driver.

Commands

The user can explicitly send the following scsimgr commands to driver esdisk plug-in by specifying the -d esdisk option:

clear_stat

Clears statistics.

get_attr

Displays information on attributes.

get_info

Displays status and other information.

get_stat

Displays statistics.

save_attr

Saves value of attributes in a persistent store.

set_attr

Set current values of attributes.

Note: Refer to scsimgr(1M) for the syntax of the above commands.

However, the only instance when it is necessary to explicitly send a command to the plug-in is when performing operations on objects global to driver esdisk: global statistics, attributes or status information. In all the other cases, scsimgr automatically invokes the plug-in to perform the driver specific part of the operation, when the operation applies to LUNs bound to driver esdisk or to their LUN paths.

Attributes

The following table lists driver esdisk specific attributes. Also, under the category "Device Set", it lists the attributes the esdisk driver can set at scopes; including, device type, vendor identifier, product identifier and product revision. On the concept of attribute and attribute scope, refer to scsimgr(1M).

Note: The following conventions are used :

  • RO is Read Only.

  • RW is Read Write.

  • uint32 is unsigned 32 bit integer.

  • Range of values for applicable attributes is listed.

ObjectAttribute NameRO/RWTypeDescription
GlobalversionROstringVersion of driver esdisk
LUNcapacityROuint32Device capacity in number of blocks
block_sizeROuint32Block size in bytes
path_fail_secsRWuint32Delay in seconds before declaring a LUN path offline after failure of first I/O. Range: 0-600
load_bal_policyRWstringI/O load balancing policy. May be: round_robin, least_cmd_load, cl_round_robin, preferred_path.
infinite_retries _enable RWbooleanEnable or disable infinite retry of I/Os. May be: true: enable, false: disable.
preferred_path RWstringHardware path of the lunpath to use preferably for I/O transfer, when I/O load balancing policy is set to preferred_path.
Device Set transient_secsRWuint32Seconds to wait after a LUN transitioned out of ONLINE state before failling I/Os. Range: 0-600
format_secsRWuint32Timeout in secs of SCSI command FORMAT. Range: 0-0xFFFFFFFF
start_unit_secsRWuint32Timeout in secs of SCSI command START UNIT. Range: 0-0xFFFFFFFF
max_retriesRWuint32Maximum number of I/O retries. Range: 1-0xFFFFFFFF
path_fail_secsRWuint32Timeout in secs before declaring a LUN path offline. Range: 0-600
esd_secsRWuint32Maximum time in secs for the transmission of an I/O. Range: 0-0xFFFFFFFF
max_q_depthRWuint32Maximum queue depth. Range: 1-0xFFFFFFFE
load_bal_policyRWstringI/O load balancing policy. May be: round_robin, least_cmd_load, cl_round_robin, preferred_path.
disable_flagsRWstringA set of flags representing SCSI task management and other functions. If a flag is set, the corresponding function is disabled for the set of devices. The following flags are currently defined: WCE: Write Cache Enable, RW16: 16 bytes READ/WRITE CDB, ABT: SCSI task management function Abort Task Set, CTS: SCSI task management function Clear Task Set, LR: SCSI task management function LUN Reset, WTR: SCSI task management function Warm Target Reset, CTR: SCSI task management function Cold Target Reset, BR: Bus Reset, PR: Persistent Reservation, WERO: Persistent Reservation WERO (Write Exclusive Read-Only), AERO: Persistent Reservation AERO (Access Exclusive Read-Only).
infinite_retries _enable RWbooleanEnable or disable infinite retries of I/Os. May be: true: enable, false: disable.

I/O Load Balancing Policy

The I/O load balancing policy attribute, load_bal_policy, is a tunable that controls how I/Os are distributed across the paths to a LUN:

  • round_robin

    Paths are selected in a round robin manner. This is more appropriate when all the paths to the device have similar I/O turn-around characteristics.

  • least_cmd_load

    The LUN path with the least number of active I/O requests is selected to execute the next I/O. This policy is appropriate when the paths to the LUN exhibit asymmetric latency characteristics. The load is distributed to optimize the bandwidth on each LUN path.

  • cl_round_robin (cell aware round robin)

    This load balancing policy is applicable to HP cell-based platforms. The LUN paths are selected in a round robin manner within the locality of CPU on which the I/O was initiated, to ensure that memory access latencies are optimized.

  • preferred_path

    The I/O path set in the preferred_path attribute is preferrably used for I/O transfer. If this I/O path is not available or if the preferred_path attribute was not set, any other path is selected for I/O transfer. This policy is useful for certain disk arrays, which may exhibit some performance degradation if I/Os are transferred via several I/O paths to a LUN simultaneously.

EXAMPLES

To display scsimgr esdisk plug-in general help and supported commands:

scsimgr -h -d esdisk

To get esdisk driver global statistics

scsimgr get_stat -d esdisk

To clear esdisk driver global statistics

scsimgr clear_stat -d esdisk

To get esdisk driver global status information

scsimgr get_info -d esdisk

To display information about esdisk driver global attributes

scsimgr get_attr -d esdisk

To set the load balancing policy for disk0 to preferred_path and set the I/O path to be used preferably

  • scsimgr set_attr -D /dev/rdisk/disk0 -a load_bal_policy=preferred_path -a preferred_path=0/3/1/0.0x21000020371972eb.0x0

To add a settable attribute scope corresponding to all disk devices from HP with product identifier "MSA VOLUME", for allowing modification of some settable attribute at this scope

scsimgr ddr_add -N "/escsi/esdisk/0x0/HP /MSA VOLUME "

To persistently change the default I/O load balancing policy, I/O timeout, and maximum concurrent I/O for all disk devices from HP with product identifier "MSA VOLUME"

  • scsimgr save_attr -N "/escsi/esdisk/0x0/HP /MSA VOLUME " -a load_bal_policy=least_cmd_load -a esd_secs=60 -a path_fail_secs=60

To disable write cache, Persistent Reservation and 16 bytes read/write CDB for all disk devices bound to the esdisk driver

scsimgr set_attr -N /escsi/esdisk -a disable_flags='WCE PR RW16'

AUTHOR

SCSI class driver esdisk plug-in for scsimgr was developed by Hewlett Packard Company.

Printable version
Privacy statement Using this site means you accept its terms Feedback to webmaster
© 1983-2007 Hewlett-Packard Development Company, L.P.