Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
More options
HP.com home
HP-UX Reference > R

rtradvd.conf(4)

HP-UX 11i Version 3: February 2007
» 

Technical documentation

» Feedback
Content starts here

 » Table of Contents

 » Index

NAME

rtradvd.conf — configuration file for router advertisement daemon

DESCRIPTION

This file describes the information used by rtradvd(1M) when constructing IPv6 router advertisement packets for a specific interface as specified by RFC 2461 ("Neighbor Discovery for IP Version 6"). This file is read by rtradvd at initialization time or upon reception of signal SIGHUP.

rtradvd configuration consists of two general statements (defaults, interface) and one substatement (prefixinfo) that is used only by the interface statement. All statements and substatements must end with a semicolon. Statements are composed of keywords separated by white space, which can be any combination of blanks and tabs.

The user may create an entry for each interface that is to be enabled for Router Advertisements. Any configuration information not specified in the individual interface or prefixinfo entry is inherited from the defaults statement. In absence of a defaults statement or specific keywords, the values of options are set according to their default values as defined in RFC-2461.

The defaults statement can be used to define global values for both interface and prefixinfo keywords. The defaults statement is defined as:

defaults { # list of interface specific keyword-value pairs; # list of prefixinfo specific keyword-value pairs; };

The interface statement is defined as:

interface interface-name { # list of interface specific keyword-value pairs; prefixinfo prefix/prefixlen { # list of prefixinfo specific keyword-value pairs; }; };

The prefixinfo specifies the "prefix" and "prefix length" to be advertised on that interface.

The interface and prefixinfo specific keywords (if specified) have a precedence over the keywords defined in the defaults statement.

NOTE: Comments begin with the pound character (#) and continue to the end of the line.

INTERFACE SPECIFIC OPTIONS

The following basic keywords and values are defined in RFC 2461:

AdvSendAdvertisement on|off

Enables (on) or disables (off) sending of periodic Router Advertisements and responding to Router Solicitations.

DEFAULT: off

MaxRtrAdvInterval integer

Specifies the maximum time, in seconds, between sending unsolicited multicast Router Advertisements from the interface. Valid values are between 4 and 1800 seconds, inclusive. When using Mobile IPv6 extension, the minimum valid value allowed drops to 0.07.

DEFAULT: 600

MinRtrAdvInterval integer

Specifies the minimum time, in seconds, between sending unsolicited multicast Router Advertisements from the interface. Valid values are between 3 seconds and .75 * MaxRtrAdvInterval inclusive. The default is 200 seconds. When using Mobile IPv6 extension, the minimum valid value allowed drops to 0.03.

DEFAULT: 0.33 * MaxRtrAdvInterval

AdvManagedFlag on|off

Enables (on) or disables (off) the setting of the "Managed Address Configuration" flag in Router Advertisements.

DEFAULT: off

AdvOtherConfigFlag on|off

Enables (on) or disables (off) the setting of the "Other Stateful Configuration" flag in Router Advertisements.

DEFAULT: off

AdvLinkMTU integer

Specifies the value to be placed in MTU option sent by the router. A value of zero means unspecified. When set to 0, rtradvd does not include the MTU option in Router Advertisements. It can not be greater than the maximum allowed MTU for a specific interface.

DEFAULT: 0

AdvReachableTime integer

Specifies a time, in milliseconds,that is placed in the Reachable Time field in Router Advertisement messages. Valid values are between 0 and 3,600,000 (1 hour), inclusive. A value of zero means unspecified by this router.

DEFAULT: 0

AdvRetransTimer integer

Specifies a time, in milliseconds, that is placed in the Retrans Timer field in Router Advertisement messages. A value of zero means unspecified by this router.

DEFAULT: 0

AdvCurHopLimit integer

Specifies the value to be placed in the Cur Hop Limit field in Router Advertisement messages sent by the router. A value of zero means unspecified by this router.

DEFAULT: 64

AdvRouterLifetime integer

Specifies a time, in seconds, that is placed in the Router Lifetime field in Router Advertisement messages. Valid values are 0 or between MaxRtrAdvInterval and 9000, inclusive. A value of zero indicates that the router is not to be used as a default router and should not appear in the default router list of the host receiving this Router Advertisement message.

DEFAULT: 3 * MaxRtrAdvInterval

AdvSourceLLAddress on|off

Enables (on) or disables (off) the sending of the interface link-layer address option in outgoing Router Advertisement messages.

DEFAULT: on

AdvHomeAgentFlag on|off

Mobile IPv6 option. Enables (on) or disables (off) setting of the "Home Agent" flag field in Router Advertisement messages. When enabled, this indicates that the router sending this Router Advertisement messages is also functioning as a Mobile IPv6 home agent on this link. When enabled, the minimum values specified by Mobile IPv6 extension can be used for MinRtrAdvInterval and MaxRtrAdvInterval.

DEFAULT: off

AdvHomeAgentLifetime integer

Mobile IPv6 option. Specifies the length of time in seconds that the router is offering Mobile IPv6 Home Agent service. The maximum value is 65520 seconds (18.2 hours). A value of zero is not allowed.

DEFAULT: AdvRouterLifetime

AdvHomeAgentPreference integer

Mobile IPv6 option. Specifies a preference level for the home agent sending this Router Advertisement. Higher values indicate a home agent is more preferable. If both the AdvHomeAgentPreference and AdvHomeAgentLifetime are set to their default values, the Home Agent Information option will not be included in Router Advertisement messages sent by this Home Agent router.

DEFAULT: 0

AdvIntervalOpt on|off

Mobile IPv6 option. Enables (on) or disable (off) the sending of Advertisement Interval Option in Router Advertisement messages. If this option is included in the message, the minimum limits specified by Mobile IPv6 extension for MinRtrAdvInterval and MaxRtrAdvInterval can be used.

DEFAULT: off

PREFIX SPECIFIC OPTIONS

The following address prefix keywords and values are defined in RFC 2461:

AdvValidLifetime seconds|forever

Specifies the valid lifetime of the address prefix, in seconds, to be placed in outgoing Router Advertisement messages. The symbolic name forever represents infinity.

DEFAULT: 2592000 seconds (30 days)

AdvPreferredLifetime seconds|forever

Specifies the preferred lifetime of the address prefix, in seconds, to be placed in outgoing Router Advertisement messages. The symbolic name forever represents infinity.

DEFAULT: 604800 seconds (7 days)

AdvOnlinkFlag on|off

Sets (on) or clears (off) the On-link flag field in the Prefix Information option.

DEFAULT: on

AdvAutonomousFlag on|off

Sets (on) or clears (off) the Autonomous Flag field in the Prefix Information option.

DEFAULT: on

AdvRouterAddress on|off

Mobile IPv6 prefix option. Sets (on) or clear (off) the Router Flag field in the Prefix Information option. This indicates that the Prefix field, in addition to advertising the indicated prefix, contains a complete IP address assigned to the sending router.

DEFAULT: off

EXAMPLES

Three example rtradvd configuration files are shown below for a system that has two interfaces. In these examples, the daemon will use default values defined in RFC-2461 for those keywords that are not specified in the configuration file. The second example uses defaults statement to define some global keywords for the both interfaces and prefixes. Finally, the last example shows a Mobile IPv6 example.

Example 1

interface lan1 { AdvCurHopLimit 32; AdvSendAdvertisement on; prefixinfo 2008:0:0:4::/64 { AdvValidLifetime 70100; AdvPreferredLifetime 50200; }; prefixinfo 2008:0:0:5::/64 { AdvValidLifetime 70100; AdvPreferredLifetime 50200; }; }; interface lan2 { AdvCurHopLimit 32; AdvRouterLifetime 0; AdvSendAdvertisement on; prefixinfo 2008:0:0:6::/64 { AdvValidLifetime 70100; AdvPreferredLifetime 50200; }; };

Example 1 specifies that the daemon should send Router Advertisement messages on both lan1 and lan2.

AdvSendAdvertisement must be on (the default is off). The AdvCurHopLimit is set to 32 for both interfaces (default value is 64). The AdvRouterLifetime for the second interface is set to 0. It means the receiving hosts should not add this router in their list of "IPv6 default router".

Example 2

defaults { AdvCurHopLimit 32; AdvSendAdvertisement on; AdvValidLifetime 70100; AdvPreferredLifetime 50200; }; interface lan1 { prefixinfo 2008:0:0:4::/64 { }; prefixinfo 2008:0:0:5::/64 { }; }; interface lan2 { AdvRouterLifetime 0; prefixinfo 2008:0:0:6::/64 { }; };

Same as Example 1 but using defaults statement.

Example 3

defaults { AdvSendAdvertisement on; MinRtrAdvInterval 2; MaxRtrAdvInterval 5; AdvHomeAgentFlag on; AdvHomeAgentLifetime 1200; AdvHomeAgentPreference 3; AdvIntervalOpt on; }; interface lan1 { prefixinfo 2008:0:0:4::/64 { }; prefixinfo 2008::5:210:83ff:fef7:7a9d/64 { AdvRouterAddress on; }; }; interface lan2 { prefixinfo 2008:0:0:6::9/64 { AdvRouterAddress on; AdvPreferredLifetime 18000; }; };

In this example, the Mobile IPv6 options (AdvHomeAgentFlag, AdvHomeAgentLifetime, AdvHomeAgentPreference) will be included in the Router Advertisement messages. AdvRouterAddress is turned on to also advertise the global address of the router on lan1 and lan2. If the kernel part of Mobile IPv6 product is detected (see mip6mod(7)), the node also acts as "Home Agent" for the two prefixes configured with AdvRouterAddress set on lan1 and lan2. In this case, the daemon enables processing of the four new ICMPv6 messages defined by Mobile IPv6 (see rtradvd(1M)).

SEE ALSO

ndp(1M), rtradvd(1M), mip6mod(7), ndp(7P).

1.

T. Narten, E. Nordmark, W. Simpson, Neighbor Discovery for IP Version 6 (IPv6), RFC2461 , December 1998.

2.

S. Thompson, T. Narten, IPv6 Stateless Address Autoconfiguration, RFC2462 , December 1998.

3.

D. Johnson, C. Perkins, Mobility Support in IPv6, IETF document.

Printable version
Privacy statement Using this site means you accept its terms Feedback to webmaster
© 1983-2007 Hewlett-Packard Development Company, L.P.