Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
More options
HP.com home
HP-UX Reference > N

nwmgr(1M)

HP-UX 11i Version 3: February 2007
» 

Technical documentation

» Feedback
Content starts here

 » Table of Contents

 » Index

NAME

nwmgr — network interface management command for LAN and RDMA interfaces

SYNOPSIS

/usr/sbin/nwmgr [-h|--help |-?] [operation] [target] [operation-qualifiers] [target-qualifiers]

DESCRIPTION

The nwmgr program is the unified command to administer all HP-UX LAN and RDMA interfaces.

This manpage describes command features that can be supported by nwmgr. However, each network interface driver (commonly referred to as a subsystem) might support a subset of these features. You can obtain information about features supported by a specific subsytem from the subsystem's individual manpage, named nwmgr_<subsystem>(1M).

To see the list of subsystems supported by nwmgr on the system, enter:

nwmgr -h -S all

You can use the nwmgr command on LAN or RDMA interfaces to:

  • Display information of an interface

  • Modify settings of an interface

  • Reset the interface or its statistics

  • Diagnose link connectivity

  • Create and set configuration information for a component simultaneously

  • Delete or erase components

All the operations other than display require the hpux.network.config authorization. For more information about authorizations and Role-Based Access Control, see rbac(5).

The nwmgr output for every operation is either in human-readable form (the default output form) or in a script-friendly parsable form (with the --sc or --script option). The format for human-readable and script-friendly output is described in the USAGE section below. Any change in the scriptable output across releases will contain only additions, never modifications or deletions, to ensure backward compatibility. The human-readable format can change across releases, including modifications and deletions.

The command usage is explained in greater detail below. The output format that is described is the human-readable one; references to the scriptable output are made as necessary.

Obsolescence Warning

The lanadmin, lanscan, and linkloop commands are deprecated. These commands will be removed in a future HP-UX release. HP recommends the use of replacement command nwmgr(1M) to perform all network interface-related tasks.

Structure of nwmgr Command Line

A nwmgr command line may contain the following options:

  • operation

  • target

  • target qualifier

  • operation qualifier

It is possible to specify multiple targets, target-qualifiers and operation-qualifiers in the same command line. In addition, you can also specify multiple arguments for these command options (when applicable) on a single command line. The target, target-qualifier, and operation-qualifier can appear in any order, but must follow the operation.

Operation

An operation is a key part of the command line. An operation is a way to specify how a subsystem has to be managed. The operation, if specified, must always be the first argument in the command line. The --get operation (to get/display interface information) is the default, when no operation option is specified.

The following operations are available:

--add | -a

Creates and sets configuration information for a component simultaneously. The add operation is subsystem specific. Any change done using the add operation can be runtime only, persistent or both.

--cra

Performs critical resource analysis (CRA) of network interfaces. The CRA operation displays the users of the component or subsystem that will be impacted if a destructive operation is performed. HP recommends performing CRA operation prior to any destructive operation.

--delete | --del | -d

Deletes or erases components, or modifies the attributes of a component. The delete operation can be subsystem specific. The changes made using the delete operation can be runtime only, persistent, or both.

--diagnose | --diag

Performs a diagnostic operation. Diagnostic operations are subsystem specific. An example of diagnostic operation is link connectivity check.

--disable | --dis

Suspends (or stops) a physical and virtual component.

--download | --do

Downloads firmware onto the physical device.

--dump | --du

Dumps or reads registers, memory, and debug information of controllers and devices

--enable | --en

Resumes a suspended (or starts or restarts) a physical device or a virtual component.

--get | -g

Displays system configuration information, component attribute information, and subsystem specific information (for example, statistics). You can also use this operation to view the current (runtime), saved (across reboots), and default configuration. This is the default operation if no operation is specified.

--help | -h | -?

Displays usage information and context dependent help for a command or a subsystem.

--reset | --re | -r

Performs hard and soft reset of physical and virtual components.

--set | -s

Sets configuration information of the components and the subsystems. Use this opperation to change the current (runtime), saved (across reboots), and default configuration.

Target

The target is the object on which an operation is performed. You must specify a target for all operations except for --get and --help operations. The choice to support multiple targets in a command is subsystem specific.

The following target options are supported:

{--class | -C} class1,...,classN

Limits the scope of the operation to the classes provided.

{--class_instance | -c } cinst1,...,cinstN

Limits the scope of the operation to the class instances provided.

{--instance | -I} inst1,...,instN

Limits the operation to the instances of the class/subsystem specified.

{--name | -N} name1,...,nameN

Limits the scope of the operation to the names provided.

{--subsystem | -S} subsys1,...,subsysN

Limits the scope of the operation to the subsystems provided.

Operation Qualifier

Operation qualifier is used to specify additional information to complete the requested operation.

The following operational qualifier options are supported:

--force | -f

Forces the operation even if errors are encountered during the operation.

{--from | --fr} arg

Specifies the configuration parameter values to be used for the operation. The from operation takes any one of current, saved, or default as argument.

{--interval | --int} value

Specifies the time interval (in seconds) between consecutive operations. If you do not specify a value, the default interval is 1 second.

{--iterations | --it} value

Specifies the number of iterations a specific operation needs to be performed. If you specify a value of 0, infinite iterations are performed. If you do not specify a value, the default is 1 iteration.

--lock | --lo

Performs a locked operation, where future accesses to the device is blocked.

--preview | --pr

Verifies if the operation can be performed without actually executing the operation.

--script | --sc

Displays the output in scriptable format.

{--time | --ti} value

Specifies the time or duration (in seconds) for which a specific operation needs to be performed. If you do not specify a value, the default time or duration is 1 second.

--unlock | --un

Unlocks the device that was previously locked.

--verbose | -v

Displays the output in verbose format.

--wrap | --wr

Displays output beyond the 80 column default.

Target Qualifiers

The target qualifier provides additional information on the object(s) the operation will act on.

The following target qualifier options are supported:

{--attribute | --att | -A} name1,...,nameN

Specifies the parameter/attribute associated with a target whose value can be retrieved or set.

Valid attributes for each interface is described in the Attribute section of the subsystem manpage, such as nwmgr_vlan(1M).

--current | --cu

Specifies that the operation applies to configuration parameter current values in system memory. If none of --current, --saved or --default is specified the command defaults to --current implicitly.

--default | --de

Specifies that the operation applies to configuration parameter default values.

--saved | --sa

Specifies that the operation applies to configuration parameter values saved in a persistent store.

--stats | --st

Specifies that the operation applies to the statistics of the target.

{--subsystem_qualifier | -q} qualifier

Specifies a generic target qualifier used to specify a subsystem specific target qualifier. Refer to the subsystem manpage for valid qualifiers for that particular subsystem, such as nwmgr_btlan(1M).

USAGE

The nwmgr command without any arguments displays all the network interfaces in the system, including physical LAN interfaces (NICs), virtual LAN interfaces (VLANs and APA aggregates and failover groups), and RDMA interfaces.

nwmgr

Use one of the following to view basic properties of one or more interfaces:

  • nwmgr -g --sc

    nwmgr --get --script

The human-readable form displays a table, with one row for each interface. If an interface is specified as a target with the -c option, only that interface is displayed. If the -S option is specified, all interfaces for the subsystem are displayed.

For example:

# nwmgr --get Name/ Interface Station Sub- Interface Related ClassInstance State Address system Type Interface ============== ========= ============== ======== ============== ========= lan0 UP 0x00306EF4E07C igelan 1000Base-T lan1 UP 0x000F202B92D4 igelan 1000Base-T lan2 UP 0x0010837BDE00 btlan 100Base-TX

The parsable (script-friendly) output contains the same data as the readable output for each subsystem. The format consists of four columns delimited with a number sign (#).

For example:

# nwmgr --get --script lan0#subsystem#current#igelan lan0#if_type#current#1000Base-T lan1#if_state#current#UP lan1#mac#current#0x000F202B92D4 lan1#subsystem#current#igelan lan1#if_type#current#1000Base-T lan2#if_state#current#UP lan2#mac#current#0x0010837BDE00 lan2#subsystem#current#btlan lan2#if_type#current#100Base-TX lan3#if_state#current#DOWN

Interface listing displays the following information about the LAN or RDMA device that has software support on the system:

  • Interface Name

  • Interface State

  • Interface Address. Indicates the primary unicast MAC address for LAN interfaces and the GID for RDMA interfaces

  • Subsystem

  • Interface Type

  • Association. Lists another interface that is associated with the interface

Note that the --get operation is the default; you do not need to specify the -g option.

Use one of the following commands to view help for nwmgr or subsystem specific usage.

  • nwmgr -h [ -S all | subsystem ]

  • nwmgr --help [ -S all | subsystem ]

When used with -S all, it displays the list of subsystems supported by nwmgr.

All other features are subsystem specific. You can obtain information about features supported by a specific subsytem from the subsystem specific manpages, using the nwmgr_<subsystem>(1M) name format.

RETURN VALUE

On success, nwmgr returns 0.

On failure, it returns one of the values described in the ERRORS section.

ERRORS

If nwmgr fails, it returns one of the following errors. The values of the error codes are described in <sys/errno.h>.

EACCES

Unable to access the interface.

EINVAL

One or more of the attributes or options is invalid for the operation.

EIO

I/O to the target interface failed.

ENOMEM

Memory allocation failed. This could be a transient condition.

ENOTSUP

Operation or feature is not supported.

ENXIO

The target interface does not exist.

EPERM

The user lacks the hpux.network.config authorization required for this operation.

EXAMPLES

List all LAN and RDMA interfaces in the system:

nwmgr --get

or

nwmgr

Display usage information for nwmgr command:

nwmgr --help

Display the list of subsystems:

nwmgr --help -S all

Display subsystem specific usage:

nwmgr --help -S subsystem

AUTHOR

nwmgr was developed by HP.

SEE ALSO

nwmgr_btlan(1M), nwmgr_intl100(1M), nwmgr_vlan(1M), rbac(5).

Other subsystem manpages are available if the driver is installed on your system. See nwmgr_<subsystem>(1M).

Nwmgr Manual.

Printable version
Privacy statement Using this site means you accept its terms Feedback to webmaster
© 1983-2007 Hewlett-Packard Development Company, L.P.