Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
More options
HP.com home
HP-UX Reference > I

ioinit(1M)

HP-UX 11i Version 3: February 2007
» 

Technical documentation

» Feedback
Content starts here

 » Table of Contents

 » Index

NAME

ioinit — test and maintain consistency between the kernel I/O data structures and the ioconfig files

SYNOPSIS

/sbin/ioinit -i [-r]

/sbin/ioinit -c

/sbin/ioinit -f infile [-r]

/sbin/ioinit -v ioconfig_file

/sbin/ioinit -rC class_name

DESCRIPTION

Starting with HP-UX 11i Version 3, there are two ioconfig files, /etc/ioconfig which is the same as on prior releases and /etc/ext_ioconfig which contains additional agile entries (see intro(7) for information on agile addressing).

The ioinit command is invoked by the init process when the system is booted, based on the ioin entry in /etc/inittab:

ioin::sysinit:/sbin/ioinitrc > /dev/console 2>&1

where ioinitrc is a script to invoke ioinit with the -i and -r options. Given the -i option, ioinit checks consistency between the kernel I/O data structures and information read from /etc/ioconfig and /etc/ext_ioconfig. If these are consistent, ioinit invokes insf to install special files for all new devices.

If the kernel is inconsistent with /etc/ioconfig or /etc/ext_ioconfig, ioinit updates /stand/ioconfig from /etc/ioconfig, and /stand/ext_ioconfig from /etc/ext_ioconfig, and, if the -r option is given, reboots the system.

If /etc/ioconfig or /etc/ext_ioconfig is corrupted or missing when the system reboots, ioinitrc brings the system up in single-user mode. The user should then restore /etc/ioconfig or /etc/ext_ioconfig accordingly from backup or invoke the ioinit with the -c option to recreate /etc/ioconfig and /etc/ext_ioconfig from the kernel.

If the -f option is given, ioinit reassigns instance numbers to existing devices within a given class based on infile. If the driver associated with the given hardware path does not support online instance number reassignment, reboot is required. If ioinit finds no errors associated with the reassignment, and the -r option is given, the system is rebooted. (See the WARNINGS section.)

If the -c option is given, ioinit recreates /etc/ioconfig and /etc/ext_ioconfig from the existing kernel I/O data structures.

If the -v option is given, ioinit verifies if there is any corruption in the specified system ioconfig file.

If the -C option is given, the kernel is forced to reassign instance numbers, starting from 0, for existing devices with the given class_name on the next reboot. Note that this option must be used with the -r option, which reboots the system immediately, if the operation is successful.

Options

ioinit recognizes the following options:

-c

Recreate /etc/ioconfig and /etc/ext_ioconfig, if the file is corrupted or missing and cannot be restored from backup. If -c is invoked, any previous binding of hardware path to device class and instance number is lost.

-C class_name

Forces the kernel to reassign instance numbers starting from 0 for all existing devices with the given class_name. This option must be used with the -r option. On successful completion the system is rebooted immediately.

-f infile

Use the file infile to reassign instance numbers to devices within a specified class. infile may have multiple entries, each to appear on a separate line, each field in the entry separated by one or more blanks. Entries should conform to the following format:

h/w_path class_name instance_#

ioinit preprocesses the contents of infile, looking for invalid entries, and prints out explanatory messages. If the infile contains more than 14 entries, then a reboot is required. An entry is considered to be invalid if the specified hardware path or class name does not already exist in the system. If the specified instance number already exists for the given class, the entry is invalid if it is not for circular reassignment. On successful completion of this operation, previous special files will still be associated with the device.

-i

Invoke insf to install special files for new devices after checking consistency between the kernel and /etc/ioconfig and /etc/ext_ioconfig.

-r

Reboot the system when it is required to correct the inconsistent state between the kernel and /etc/ioconfig and /etc/ext_ioconfig, as used with the -i option. When used with the -f option, if there are no errors associated with the instance reassignment, -r reboots the system.

-v ioconfig_file

Verify if there is any corruption in ioconfig_file. If the verification of ioconfig_file is successful, the command displays a message showing if the type of ioconfig_file is either legacy (for example, /etc/ioconfig) or agile (for example, /etc/ext_ioconfig).

Note: HP-UX cannot be rebooted without the /stand/ext_ioconfig file. If the file is missing or corrupted, HP-UX will recreate the file before rebooting the system. If there is a need for booting the system without the /stand/ext_ioconfig file (thus losing all the persistent I/O information (see ioconfig(4)), the user can delete the file and reboot the system with the command reboot -q (see reboot(1M)).

RETURN VALUE

0

No errors occurred, although warnings might be issued.

1

ioinit encountered an error.

2

file was recognized as an ioconfig_file file but it was found corrupted during verification.

DIAGNOSTICS

Most of the diagnostic messages from ioinit are self-explanatory. Listed below are some messages deserving further clarification. Errors cause ioinit to halt immediately.

Errors

/etc/ioconfig is missing.

/etc/ioconfig is corrupted.

/etc/ext_ioconfig is missing.

/etc/ext_ioconfig is corrupted.

Either restore /etc/ioconfig or /etc/ext_ioconfig accordingly from backup and then reboot, or recreate /etc/ioconfig or /etc/ext_ioconfig using ioinit -c.

Permission to access /etc/ioconfig is denied.

Change permissions to /etc/ioconfig to allow access by ioinit.

Permission to access /etc/ext_ioconfig is denied.

Change permissions to /etc/ext_ioconfig to allow access by ioinit.

exec of insf failed.

ioinit completed successfully, but insf failed.

Instance number is already in kernel.

Instance number already exists for a given class. Use rmsf to remove the existing instance number, then retry.

Hardware path is not in the kernel.

The given hardware path is not in the kernel. Use ioscan -k to get the correct hardware path, then retry.

Device class name is not in the kernel.

The given class name is not in the kernel. Use ioscan -k to get the correct class name, then retry.

EXAMPLES

To reassign an instance number to a device and class (specified in infile) and reboot the system:

/sbin/ioinit -f infile -r

where infile contains the following:

  • 56.52 scsi 2

    64000/0xfa00/0x7 disk 20

56.52 is the h/w_path, scsi is the class_name, and 2 is the instance_#.

64000/0xfa00/0x7 is the h/w_path, disk is the class_name, and 20 is the instance_#.

To achieve circular reassignment of instance numbers between two existing devices of a class (specified in infile), assuming the driver associated with the given hardware paths support online reassignment of instance numbers.

/sbin/ioinit -f infile

where infile contains the following:

  • 64000/0xfa00/0x7 disk 20

    64000/0xfa00/0xa disk 30

64000/0xfa00/0x7 is the h/w_path, disk is the class_name, and 20 is the instance_#. The existing instance_# of this device is 30.

64000/0xfa00/0xa is the h/w_path, disk is the class_name, and 30 is the instance_#. The existing instance_# of this device is 20. After the successful completion of this operation, 64000/0xfa00/0x7 will have the new instance_# as 20 and 64000/0xfa00/0xa will have the new instance_# as 30.

Verify my_ioconfig file for corruptions and find if it is of type legacy or agile.

/sbin/ioinit -v /etc/back/my_ioconfig

WARNINGS

Running rmsf or insf overwrites the effect of reassignment by ioinit before the system is rebooted.

AUTHOR

ioinit was developed by HP.

FILES

/stand/ioconfig

/etc/ioconfig

/stand/ext_ioconfig

/etc/ext_ioconfig

Printable version
Privacy statement Using this site means you accept its terms Feedback to webmaster
© 1983-2007 Hewlett-Packard Development Company, L.P.