Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
More options
HP.com home
HP-UX Reference > C

cdnode(4)

HP-UX 11i Version 3: February 2007
» 

Technical documentation

» Feedback
Content starts here

 » Table of Contents

 » Index

NAME

cdnode — format of a CDFS cdnode

SYNOPSIS

#include <sys/types.h> #include <sys/cdnode.h>

DESCRIPTION

This entry describes the cdnode structure and related concepts for the CDFS file system.

The CDFS file system does not have the concept of a separate entity called an inode. The information normally found in an HFS inode is kept in a cdnode data structure. However, the cdnode data structure does not reside on the physical media, but instead is kept in kernel memory space only. The cdnode information is used to uniquely identify a file.

The information kept in the cdnode structure is obtained from two other data structures in the CDFS file system:

1.

Directory record for the file or directory, and

2.

Extended attribute record (XAR) for the file or directory, if one exists.

Because few files usually have XARs associated with them, the cdnode information most often consists only of attributes given by the directory record for the file.

Since cdnodes are kept in kernel memory, they cannot be directly accessed by the user. The stat() system call attempts to map whatever information is included in the cdnode for a given file into the standard stat structure (see stat(2)). However, since a cdnode includes information that does not have corresponding fields in the stat structure, that information cannot be mapped and therefore cannot be accessed. No method is provided to access an entire cdnode structure.

FILES

/usr/include/sys/cdnode.h /usr/include/sys/cdfsdir.h

SEE ALSO

stat(2), cdrom(4).

Printable version
Privacy statement Using this site means you accept its terms Feedback to webmaster
© 1983-2007 Hewlett-Packard Development Company, L.P.